Zona Client API Document

Terazona C++ Client API Documentation

1.3

Feedback

Copyright ©2002 Zona, inc. All rights reserved


BaseServices.h File Reference

Go to the source code of this file.

Classes

class | BaseServices
BaseServices. More...

Defines

#define | _BASESERVICES_H_

Variables

ZONA_NAMESPACE_BEGIN class | GameStateCallback

Define Documentation

#define _BASESERVICES_H_

Definition at line 25 of file BaseServices.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class GameStateCallback

Definition at line 36 of file BaseServices.h.


BaseServices.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http: *www.zona.net  or
00004  *
00005  * Filename: BaseServices.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023
00024 #if !defined(_BASESERVICES_H_)
00025 #define _BASESERVICES_H_
00026
00027 #include "zona_api.h"
00028 #include "zaf/ZonaGlobalConstants.h"
00029 #include "util/ZonaBaseEntity.h"
00030
00031 #include "platform/ZonaTimeUtils.h"
00032 #include "Thread.h"
00033
00034 ZONA_NAMESPACE_BEGIN
00035
00036 class GameStateCallback;
00037 class EntityCallback;
00038 class ZonaClient;
00039 class BaseClient;
00040 class SessionIdManager;
00041 class GameStateService;
00042 class ZonaMessage;
00043 class ServiceState;
00044
00045 class ZonaClientEntity;
00046 class ZonaClientCharacter;
00047 class BaseBuffer;
00048
00055 class BaseServices {
00056 public:
00060         BaseServices(bool bMessageBuffering=true, bool bautoUpdate=true);
00061
00065         ~BaseServices();
00066
00078         int login(char* dispatcherURL, char* clientName, char* password );
00079
00093         int loginAsync(char* dispatcherURL, char* clientName, char* password);
00094
00098         void logoff();
00099
00106         int getLoginStatus();
00107
00120         int sendGameStateMsg(char *stateData, short dataSize);
00121
00135         int sendGameStateMsg(int entityId, char *stateData, short dataSize);
00136 /*
00137         char *sendSGameStateMsg(char *stateData, short dataSize, short &retLen);
00138
00139         Message *sendSGameStateMsg(ZonaMessage *msg);
00140 */
00150         int monitorGameState(GameStateCallback* callback);
00151
00161     int monitorEntityUpdates(EntityCallback* callback);
00162
00173         int subscribeToGameStateMsgs(int entityId, int msgFilters);
00174
00179         int getSessionId() const;
00180
00185         const char* getLoginName() const;
00186
00191         int getCharacterId() const;
00192
00193
00194         ZonaClientCharacter *getCharacter();
00195
00201         int getMillsSinceLogin();
00202
00210         int getMillsSinceZGST();
00211
00212 #if defined (WIN32)
00213
00218         static long64 FileTimeToZonaTime(FILETIME* timeFT);
00219
00225         static void  ZonaTimeToFileTime(jlong jtime, FILETIME* timeFT);
00226 #endif
00227
00228         //  ---------- Version Control ----------
00235         char* getZAFVersion();
00236
00252         bool setGameVersion(char* gameVersion, short size);
00253
00268         jlong getGlobalServerLoginTime();
00269
00270
00277         ZonaClientEntity *getEntityWithId(int eid);
00278
00295         int getAllEntities(ZonaBaseEntityPtrVector *entityVecPtr);
00296
00306         static int a2w(const char* as, wchar_t* sBuf, int sBufSize);
00307
00317         static int w2a(const wchar_t* ws, char* sBuf, int sBufSize);
00318
00329         void processMessage(int count=1);
00330
00331
00341         int getMessageBufferCount();
00342
00343 protected:
00344         virtual void initializeServices();
00345
00346         ZonaClient *zonaClient;
00347         SessionIdManager* sid;
00348         GameStateService *gameStateService;
00349         ServiceState*   m_state;
00350         bool m_autoUpdate;
00351         bool m_messageBuffering;
00352     BaseBuffer* _downcastBuffer;
00353
00354 private:
00355
00356     //settings having to do with JMS
00357         ZProperties *m_connectionProperty;
00358         ZProperties *zonaRouterProperties;
00359         int login(char* dispatcherURL, char* clientName, char* password, bool bMessageBuffering, bool syncLogin);
00360
00361         // These three private varibles are simply placeholders for the
00362         // connection context data. They should be deleted only in the destructor
00363         char*   m_jmsUserName;
00364         char*   m_jmsPassWord;
00365         char*   m_jmsHostUrl;
00366         char    m_gameVersion[MAX_INI_BUFFER];
00367         short   m_gameVersionSize;
00368         char    m_zonaVersion[MAX_INI_BUFFER];
00369         short   m_zonaVersionSize;
00370     int     m_uniqueBuildNum;
00371
00372     int         m_loginStatus;
00373
00374     GameStateService *getGameStateService();
00375
00376     void pause();
00377
00378     void resume();
00379
00380     class ZonaLoginThread: public Ice_Thread {
00381
00382         public:
00383                 ZonaLoginThread(BaseServices* baseServices);
00384                 void set(char* m_dispatcherURL, char* uname, char* pass);
00385                 virtual void run();
00386         private:
00387                 BaseServices* m_baseServices;
00388                 char m_clientName[50];
00389                 char m_password[50];
00390                 char m_dispatcherURL[128];
00391
00392         };
00393
00394         friend ZonaLoginThread;
00395         friend ZonaClientEntity;
00396         friend ZonaClientCharacter;
00397     friend BaseClient;
00398     friend ZonaClient;
00399         ZonaLoginThread *m_loginThread;
00400 };
00401
00402 ZONA_NAMESPACE_END
00403 ZONA_USING_NAMESPACE
00404
00405 #endif


Callback.h File Reference

Go to the source code of this file.

Classes

class Callback
Base class for all callbacks. More...


Callback.h

Go to the documentation of this file.
00001 #ifndef CALLBACK_H
00002 #define CALLBACK_H
00003
00004 #include "Zona_API.h"
00005 #include "util\ZString.h"
00006
00007 ZONA_NAMESPACE_BEGIN
00008
00010 class Callback{
00011 public:
00012
00021         virtual void serverThrownError(int errNum, ZWString* errMsg);
00022
00030         virtual void serverThrownError(const char* errMsg);
00031
00038     virtual void  onNotifyPlayerReset(int resetAction , int resetReason);
00039
00040 };
00041
00042 ZONA_NAMESPACE_END
00043 ZONA_USING_NAMESPACE
00044
00045 #endif // CALLBACK_H


ChatCallBack.h File Reference

Go to the source code of this file.

Classes

class | ChatCallback
Provides a service to recive chat messages for the sphere. More...

Defines

#define | _CHATCALLBACK_H

Define Documentation

#define _CHATCALLBACK_H

Definition at line 25 of file ChatCallBack.h.


ChatCallBack.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: ChatCallback.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023
00024 #if !defined(_CHATCALLBACK_H)
00025 #define _CHATCALLBACK_H
00026
00027 #include "Zona_API.h"
00028 #include "callback.h"
00029 #include "message/data/ChatMsg.h"
00030
00031 ZONA_NAMESPACE_BEGIN
00032
00040 class ChatCallback : public Callback
00041 {
00042 public:
00043
00047          ChatCallback();
00048
00052          ~ChatCallback();
00053
00061          virtual void onReceiveChat(ChatMsg* msg)=0;
00062
00063
00064
00065 };
00066
00067 ZONA_NAMESPACE_END
00068 ZONA_USING_NAMESPACE
00069
00070 #endif  // !defined(_CHATCALLBACK_H)


ChatMsg.h File Reference

Go to the source code of this file.

Classes

class | ChatMsg
ChatMsg. More...

Defines

#define | CHATMSG_H

Typedefs

typedef ZVector< ChatMsg * > | ChatMsgPtrVector
An vector containing ChatMsg objects.

Variables

ZONA_NAMESPACE_BEGIN

Define Documentation

#define CHATMSG_H

Definition at line 2 of file ChatMsg.h.

Typedef Documentation

typedef ZVector<ChatMsg*> ChatMsgPtrVector

An vector containing ChatMsg objects.

Definition at line 67 of file ChatMsg.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN

Definition at line 8 of file ChatMsg.h.


ChatMsg.h

Go to the documentation of this file.
00001 #if !defined(CHATMSG_H)
00002 #define CHATMSG_H
00003
00004 #include "PersistableObject.h"
00005 //#include <vector>
00006 #include <util/ZVector.h>
00007
00008 ZONA_NAMESPACE_BEGIN;
00009
00018 class ChatMsg
00019 {
00020 protected:
00021     void init(int recipId,
00022          char *toCharacterName,
00023          unsigned char intensityLevel,
00024          char* msgBody);
00025
00026 public:
00027
00029         enum MailFlags{
00030                         FLAG_UNDOWNLOADED = 1,
00031                         FLAG_UNREAD = 2,
00032                         FLAG_DELETED = 4,
00033                         FLAG_REPLIED = 8
00034         };
00035
00039         enum SpecialRecipients{
00040                 RECIPIENT_ID_SPHERE = -1,
00041         RECIPIENT_ID_SYSTEMWIDE = -2,
00042         RECIPIENT_ID_BY_NAME = -3
00043         };
00044
00045     ChatMsg();
00046
00047         ChatMsg(int recipId,
00048             unsigned char intensityLevel,
00049             char* msgBody);
00050
00051     virtual ~ChatMsg();
00052
00053
00054         LONG64 date;
00055         int flag;
00056         int senderId;
00057         int recipientId;
00058     char *toCharacterName;
00059         char* subject;
00060         char* body;
00061         unsigned char intensity;
00062         int recipientProperties;
00063         int id;
00064 };
00065
00067 typedef ZVector<ChatMsg*> ChatMsgPtrVector;
00068
00069 ZONA_NAMESPACE_END
00070 ZONA_USING_NAMESPACE
00071
00072
00073 #endif // !defined(CHATMSG_H)


EntityCallback.h File Reference

Go to the source code of this file.

Classes

class | EntityCallback
EntityCallback. More...

Defines

#define | _ENTITYCALLBACK_H_

Define Documentation

#define _ENTITYCALLBACK_H_

Definition at line 24 of file EntityCallback.h.


EntityCallback.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2003, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: EntityCallback.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023 #if !defined(_ENTITYCALLBACK_H_)
00024 #define _ENTITYCALLBACK_H_
00025
00026 #include "Zona_API.h"
00027 #include "callback.h"
00028 #include "util/ZonaClientEntity.h"
00029 #include "util/ZonaClientCharacter.h"
00030
00031 ZONA_NAMESPACE_BEGIN
00032
00042 class EntityCallback : public Callback
00043 {
00044 public:
00048     EntityCallback();
00049
00053         ~EntityCallback();
00054
00060         virtual void onNotifyEntityPropertyUpdate(ZonaClientEntity *zce);
00061
00067     virtual void onNotifyEntityParentChange(ZonaClientEntity *zce);
00068
00083         virtual void onNotifyEntityJoinedSphere(ZonaClientEntity *zce);
00084
00093         virtual void onNotifyEntityDepartedSphere(ZonaClientEntity *zce);
00094
00095 };
00096 ZONA_NAMESPACE_END
00097 ZONA_USING_NAMESPACE
00098
00099 #endif  // !defined(_ENTITYCALLBACK_H_)


GameGuildCallback.h File Reference

Go to the source code of this file.

Classes

class | GameGuildCallback

Defines

#define | AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_

Variables

ZONA_NAMESPACE_BEGIN class | ZonaClientGuild
Provides a service to recive chat messages for the sphere.

Define Documentation

#define AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_

Definition at line 6 of file GameGuildCallback.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaClientGuild

Provides a service to recive chat messages for the sphere.

Developers extend this abstract class and register their derived class with ZonaServices to receive updates on the player's sphere.

Definition at line 23 of file GameGuildCallback.h.


GameGuildCallback.h

Go to the documentation of this file.
00001 // GameGuildCallback.h: interface for the GameGuildCallback class.
00002 //
00004
00005 #if !defined(AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_)
00006 #define AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "Zona_API.h"
00013 #include "Callback.h"
00014 ZONA_NAMESPACE_BEGIN
00015
00023 class ZonaClientGuild;
00024 class ZonaClientGuildMembership;
00025 class ZonaGuildChatMsg;
00026 class ZonaClientEntity;
00027
00028
00029 class GameGuildCallback: public Callback
00030 {
00031 public:
00032
00036         GameGuildCallback();
00037
00041         ~GameGuildCallback();
00042
00043         /*
00044         *       Called by ZonaServices in response to a request to fetch member guilds, or if an
00045         *       invite has been sent by another member
00046         *
00047         *       @param guild Pointer to a ZonaClientGuild object
00048         */
00049         virtual void onAddGuild(ZonaClientGuild* guild) = 0;
00050
00051         /*
00052         *       Called by ZonaServices when any of foll actions take place -
00053         *       - the Guild is removed by a moderator
00054         *       - this member is removed by moderator
00055         *       - The member exits or leaves the Guild
00056         *
00057         *       @param guild Pointer to the removed ZonaClientGuild object
00058         */
00059         virtual void onRemoveGuild(ZonaClientGuild* guild)= 0;
00060
00061         /*
00062         *       Called by ZonaServices when another member joins a guild
00063         *       The GameGuildMemberShip object contains guild Id and memberId
00064         *
00065         *       @param guild Pointer to a ZonaClientGuildMemberShip object
00066         */
00067         virtual void onMemberJoinGuild(ZonaClientGuildMembership* aShip)= 0;
00068
00069         /*
00070         *       Called by ZonaServices when another member leaves a guild
00071         *       The GameGuildMemberShip object contains guild Id and memberId
00072         *
00073         *       @param guild Pointer to a ZonaClientGuildMemberShip object
00074         */
00075         virtual void onMemberLeaveGuild(ZonaClientGuildMembership* aShip)= 0;
00076
00077         /*
00078         *       Called by ZonaServices when another member enters a guild
00079         *       The GameGuildMemberShip object contains guild Id and memberId
00080         *
00081         *       @param guild Pointer to a ZonaClientGuildMemberShip object
00082         */
00083         virtual void onMemberEnterGuild(ZonaClientGuildMembership* aShip)= 0;
00084
00085         /*
00086         *       Called by ZonaServices when another member exits a guild
00087         *       The GameGuildMemberShip object contains guild Id and memberId
00088         *
00089         *       @param guild Pointer to a ZonaClientGuildMemberShip object
00090         */
00091         virtual void onMemberExitGuild(ZonaClientGuildMembership* aShip)= 0;
00092
00093         /*
00094         *       Called by ZonaServices when a member is set as a moderator
00095         *
00096         *       @param guildId The id of the guild
00097         *       @param moderatorId The id of the member set as moderator
00098         */
00099         virtual void onAddModerator(int guildId, int moderatorId)= 0;
00100
00101         /*
00102         *       Called by ZonaServices when a member is removed as a moderator
00103         *
00104         *       @param guildId The id of the guild
00105         *       @param moderatorId The id of the member removed as moderator
00106         */
00107         virtual void onRemoveModerator(int guildId, int moderatorId)= 0;
00108
00109         /*
00110         *       Called by ZonaServices when a member sends a guild invite to this member
00111         *
00112         *       @param guildId The id of the guild
00113         *       @param inviterId The id of the entity who has sent the invite
00114         *       @param inviteeId The id of the entity to whom the invite is directed
00115         *
00116         */
00117         virtual void onGuildInvite(int guildId, int inviterId, int inviteeId)= 0;
00118
00119         /*
00120         *       Called by ZonaServices when a member posts a guild game state
00121         *
00122         *       @param guildId The id of the guild
00123         *       @param state Pointer to guild game state
00124         *       @param stateLength The length of the game state
00125         *       @param entityId The id of the member sending the game state
00126         *
00127         */
00128         virtual void onGuildGameState(int guildId, char* state, int stateLength, int entityId)= 0;
00129
00130         /*
00131         *       Called by ZonaServices when a member posts a guild game state
00132         *
00133         *       @param guildId The id of the guild
00134         *       @param zce Pointer to ZonaClientEntity whose property has updated.
00135         *
00136         */
00137         virtual void onGuildEntityUpdate(int guildId, ZonaClientEntity *zce)= 0;
00138
00139         /*
00140         *       Called by ZonaServices when a member posts a guild chat Message
00141         *
00142         *       @param msg Pointer to guild chat message object
00143         *
00144         */
00145         virtual void onGuildChatMessage(ZonaGuildChatMsg* msg)= 0;
00146
00147
00148         /*
00149         *       Called by ZonaServices when some user action results in an error condition
00150         *
00151         *       @param errorId The id of the error condition
00152         *       @param guildId The id of the guild
00153         *       @param operationId The operation resulting in the error
00154         *       @param entityId The entity that performed erroneous operation.
00155         *
00156         */
00157         virtual void onGuildErrorMessage(int errorId, int guildId,
00158                                                                                         int operationId, int entityId)= 0;
00159
00160         /*
00161         *       Called by ZonaServices when Guild Server plug-in updates the properties of a guild
00162         *
00163         *       @param guild Pointer to the guild whose properties got updated. The object's dirty
00164         *                bit mask can be investigated to find out the updates.
00165         */
00166         virtual void onGuildPropertyUpdate(ZonaClientGuild *guild)=0;
00167
00168 };
00169
00170
00171 ZONA_NAMESPACE_END
00172 ZONA_USING_NAMESPACE
00173
00174
00175 #endif // !defined(AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_)


GameGuildServiceInterface.h File Reference

Go to the source code of this file.

Classes

class | GameGuildServiceInterface

Typedefs

typedef ZVector< ZonaClientGuild * > | ZonaClientGuildPtrVector
typedef ZVector< ZonaGuildChatMsg * > | ZonaGuildChatMsgPtrVector

Variables

ZONA_NAMESPACE_BEGIN class | ZonaClientGuild

Typedef Documentation

typedef ZVector<ZonaClientGuild*> ZonaClientGuildPtrVector

Definition at line 15 of file GameGuildServiceInterface.h.

typedef ZVector<ZonaGuildChatMsg*> ZonaGuildChatMsgPtrVector

Definition at line 16 of file GameGuildServiceInterface.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaClientGuild

Definition at line 10 of file GameGuildServiceInterface.h.


GameGuildServiceInterface.h

Go to the documentation of this file.
00001
00002 #ifndef _GAME_GUILD_SERVICE_INTERFACE_
00003 #define _GAME_GUILD_SERVICE_INTERFACE_
00004
00005 #include "Zona_Api.h"
00006
00007
00008 ZONA_NAMESPACE_BEGIN
00009
00010 class ZonaClientGuild;
00011 class ZonaClientGuildMembership;
00012 class GameGuildCallback;
00013 class ZonaGuildChatMsg;
00014
00015 typedef ZVector<ZonaClientGuild*> ZonaClientGuildPtrVector;
00016 typedef ZVector<ZonaGuildChatMsg*> ZonaGuildChatMsgPtrVector;
00017
00018 class GameGuildServiceInterface
00019 {
00020 public:
00021
00022         GameGuildServiceInterface(){}
00023
00024         virtual ~GameGuildServiceInterface() {}
00025
00035         virtual int createGuild(ZonaClientGuild * guild, int entityId) = 0;
00036
00037
00047         virtual int deleteGuild(ZonaClientGuild * guild, int entityId) = 0;
00048
00049
00057         virtual int requestMemberGuilds(int entityId) = 0;
00058
00059
00068         virtual int joinGuild(short guildClassId, int guildId, int entityId) = 0;
00069
00070
00078         virtual int leaveGuild(int guildId, int entityId) = 0;
00079
00080
00089         virtual int enterGuild(short guildClassId, int guildId, int entityId) = 0;
00090
00091
00099         virtual int exitGuild(int guildId, int entityId) = 0;
00100
00101
00110         virtual int inviteMember(int guildId, int inviteeId, int inviterId) = 0;
00111
00112
00121         virtual int removeMember(int guildId, int targetEntityId, int memberId) = 0;
00122
00123
00130         virtual int monitorGuildMessage(GameGuildCallback* guildCallback) = 0;
00131
00136         virtual int stopMonitorGuildMessage() = 0;
00137
00138
00147         virtual int addGuildModerator(int guildId, int entityId,
00148                                                                         int moderatorEntityId ) = 0;
00149
00150
00159         virtual int removeGuildModerator(int guildId, int entityId,
00160                                                                         int moderatorEntityId ) = 0;
00161
00162
00169         virtual int sendChatMessage(ZonaGuildChatMsg* aMsg) = 0;
00170
00171
00181         virtual int sendGuildGameState(int guildId, int entityId, char* state, int stateLen) = 0;
00182
00183
00191         virtual int publishEntityPropertyUpdates(int guildId, int entityId)=0   ;
00192
00193
00200         virtual ZonaClientGuild* getGameGuild(int guildId) = 0;
00201
00202
00211         virtual int fetchMemberGuilds(int entityId, ZonaClientGuildPtrVector& gpv) = 0;
00212
00220         virtual int fetchAccessibleGuilds(int entityId, ZonaClientGuildPtrVector& gpv) = 0;
00221
00232         virtual int fetchGuildMembers(short classId, int guildId, int entityId, ZonaClientEntityPtrVector& epv) = 0;
00233
00246         virtual int fetchZonaGuildChatMessages(
00247             int guildId, INT64 minDate, INT64 maxDate,
00248             ZonaGuildChatMsgPtrVector& msgs) = 0;
00249
00250 };
00251
00252 ZONA_NAMESPACE_END
00253 ZONA_USING_NAMESPACE
00254
00255
00256 #endif


GameStateCallback.h File Reference

Go to the source code of this file.

Classes

class | GameStateCallback
GameStateCallback. More...

Defines

#define | _GAMESTATECALLBACK_H_

Define Documentation

#define _GAMESTATECALLBACK_H_

Definition at line 24 of file GameStateCallback.h.


GameStateCallback.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: GameStateCallback.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023 #if !defined(_GAMESTATECALLBACK_H_)
00024 #define _GAMESTATECALLBACK_H_
00025
00026 #include "Zona_API.h"
00027 #include "callback.h"
00028 #include "util/ZonaClientCharacter.h"
00029
00030 ZONA_NAMESPACE_BEGIN
00031
00041 class GameStateCallback : public Callback
00042 {
00043 public:
00047         GameStateCallback();
00048
00049
00053         ~GameStateCallback();
00054
00063         virtual void onReceivedGameStateMsg(int entityId , char* stateData, short dataSize)=0;
00064
00065 };
00066 ZONA_NAMESPACE_END
00067 ZONA_USING_NAMESPACE
00068
00069 #endif  // !defined(_GAMESTATECALLBACK_H_)


Guild.h File Reference

Go to the source code of this file.

Classes

class | Guild
Guild. More...

Defines

#define | GUILD_H

Typedefs

typedef ZVector< Guild * > | GuildPtrVector
An STL vector containing Guilds.

Define Documentation

#define GUILD_H

Definition at line 4 of file Guild.h.

Typedef Documentation

typedef ZVector<Guild*> GuildPtrVector

An STL vector containing Guilds.

Definition at line 145 of file Guild.h.


Guild.h

Go to the documentation of this file.
00001 #pragma warning(disable: 4786)
00002
00003 #if !defined(GUILD_H)
00004 #define GUILD_H
00005
00006 #include "util/Streamable.h"
00007
00008 //#include <set>
00009 #include "message/data/ChatMsg.h"
00010 #include "message/data/NamedZonaObject.h"
00011
00012
00013 ZONA_NAMESPACE_BEGIN
00020 class Guild
00021 {
00022 public:
00023
00027   enum GuildAttributes
00028   {
00033         PERSISTENT_MEMBERSHIP=0x1,
00034
00036         EMAIL_FOLLOWUP=0x2,
00037
00043         PERSISTENT_MSG=0x4,
00044
00047         DESTROY_WITH_OWNER=0x8,
00048
00051     DONT_SEND_MEMBERSHIP_CHANGES=0x10,
00052
00054     MEMBERS_CAN_POST_MSG=0x20,    //Message permissions
00055
00057     MEMBERS_CAN_DELETE_ANY_MSG=0x40,
00058
00060     MEMBERS_CAN_DELETE_OWN_MSG=0x80,
00061
00063         DONT_SEND_NEW_MESSAGES=0x100
00064   };
00065
00066
00070   enum Inviter
00071   {
00073         SYSTEM=0x1,
00074
00076         MODERATOR=0x2,
00077
00079         MEMBER=0x4,
00080
00082         SELF=0x8,
00083   };
00084
00085 public:
00086         friend class CharacterService;
00087
00092         Guild(int attributes, int inv);
00093         virtual ~Guild();
00094
00098     IntVector userIds;
00099
00101     //virtual ZWString toString();
00102
00108         static Guild* createPersistantGuildInstance(){
00109           return new Guild(PERSISTENT_MEMBERSHIP | PERSISTENT_MSG, MODERATOR);
00110         }
00111
00112         static Guild* createGroupInstance(){
00113           return new Guild(DESTROY_WITH_OWNER, MODERATOR);
00114         }
00115
00116         static Guild* createForum(){
00117           return new Guild(PERSISTENT_MEMBERSHIP, SELF);
00118         }
00119
00120         int getAttributes();
00121
00122         int getInviters();
00123
00124         Guild();
00125
00126
00127         int getId();
00128
00129         void setId(int id);
00130
00131         void setName(const char* name);
00132
00133         const char* getName();
00134
00135 private:
00136   int attributes;
00137   int inviter;
00138   int id;
00139   char* name;
00140
00141   friend class ZonaGuildMessage;
00142 };
00143
00145 typedef ZVector<Guild*> GuildPtrVector;
00146
00147 ZONA_NAMESPACE_END
00148 ZONA_USING_NAMESPACE
00149 #endif // !defined(GUILD_H)


GuildCallback.h File Reference

Go to the source code of this file.

Classes

class | GuildCallback
Provides a service to recive chat messages for the sphere. More...

Defines

#define | GUILDCALLBACK_H

Variables

ZONA_NAMESPACE_BEGIN class | ZonaClientGuild

Define Documentation

#define GUILDCALLBACK_H

Definition at line 25 of file GuildCallback.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaClientGuild

Definition at line 32 of file GuildCallback.h.


GuildCallback.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: GuildCallback.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023
00024 #if !defined(GUILDCALLBACK_H)
00025 #define GUILDCALLBACK_H
00026
00027 #include "Zona_API.h"
00028 #include "Callback.h"
00029 #include "util/ZonaClientGuild.h"
00030
00031 ZONA_NAMESPACE_BEGIN
00032 class ZonaClientGuild;
00033
00041 class GuildCallback : public Callback
00042 {
00043 public:
00044
00048         GuildCallback();
00049
00053         ~GuildCallback();
00054
00060         virtual void memberJoinedGuild(int guildId, int charId);
00061
00067         virtual void memberDepartedGuild(int guildId, int charId);
00068
00074         virtual void moderatorChanged(int guildId);
00075
00082         virtual void guildDestroyed(int guildId);
00083
00084
00092         virtual void guildInvite(ZonaClientGuild* guild, int inviterId);
00093
00094
00095 };
00096 ZONA_NAMESPACE_END
00097 ZONA_USING_NAMESPACE
00098
00099 #endif  // !defined(GUILDCALLBACK_H)


NamedZonaObject.h File Reference

Go to the source code of this file.

Classes

class | NamedZonaObject
A ZonaObject with a text name. More...

Defines

#define | NamedZonaObject_H

Define Documentation

#define NamedZonaObject_H

Definition at line 4 of file NamedZonaObject.h.


NamedZonaObject.h

Go to the documentation of this file.
00001 #pragma warning(disable: 4786)
00002
00003 #if !defined(NamedZonaObject_H)
00004 #define NamedZonaObject_H
00005
00006 #include "ZonaObject.h"
00007 #include "ZonaMessage.h"
00008 #include "util/Streamable.h"
00009
00010 //#include <set>
00011
00012
00013 ZONA_NAMESPACE_BEGIN
00014
00016 class NamedZonaObject : public ZonaObject // implements Streamable through ZonaObject
00017 {
00018 public:
00019         NamedZonaObject();
00020         virtual ~NamedZonaObject();
00021         virtual OutStream& serialize(OutStream& os);
00022         virtual InStream& deserialize(InStream& is);
00023
00025         ZWString name;
00026
00028         virtual ZWString toString();
00029
00030         void appendToZonaMessage(ZonaMessage *zm);
00031
00032         void extractFromZonaMessage(ZonaMessage *zm);
00033 };
00034
00035
00036 ZONA_NAMESPACE_END
00037 ZONA_USING_NAMESPACE
00038 #endif // !defined(NamedZonaObject_H)


PersistableObject.h File Reference

Go to the source code of this file.

Classes

class | PersistableObject
PersistableObject. More...

Defines

#define | PERSISTABLEOBJECT_H

Variables

ZONA_NAMESPACE_BEGIN class | ZonaMessage
An object with a unique Id.

ZONA_NAMESPACE_END ZONA_USING_NAMESPACE
typedef ZVector< PersistableObject * > 		PersistableObjectPtrVector
An STL vector containing GameCharacters.

Define Documentation

#define PERSISTABLEOBJECT_H

Definition at line 2 of file PersistableObject.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaMessage

An object with a unique Id.

This must class must be an ancestor of all persistable objects (entities, MailMessages, etc. It has many other uses as well. This object is serialized/deserealized in the standard way.

Definition at line 13 of file PersistableObject.h.

ZONA_NAMESPACE_END ZONA_USING_NAMESPACE typedef ZVector<PersistableObject*> PersistableObjectPtrVector

An STL vector containing GameCharacters.

Definition at line 48 of file PersistableObject.h.


PersistableObject.h

Go to the documentation of this file.
00001 #if !defined(PERSISTABLEOBJECT_H)
00002 #define PERSISTABLEOBJECT_H
00003
00004 #include "util/streamable.h"
00005 #include <util/ZVector.h>
00006
00011 ZONA_NAMESPACE_BEGIN
00012
00013 class ZonaMessage;
00014
00020 class PersistableObject : public Streamable
00021 {
00022 public:
00023
00025         PersistableObject();
00026
00028         PersistableObject(const PersistableObject& other);
00029         virtual ~PersistableObject();
00031         PersistableObject& operator=(const PersistableObject& other);
00032
00033         virtual OutStream& serialize(OutStream& os);
00034         virtual InStream& deserialize(InStream& is);
00035
00036         virtual void appendToZonaMessage(ZonaMessage *zm);
00037         virtual void extractFromZonaMessage(ZonaMessage *zm);
00038
00040         int id;
00041
00042 };
00043
00044 ZONA_NAMESPACE_END
00045 ZONA_USING_NAMESPACE
00046
00048 typedef ZVector<PersistableObject*> PersistableObjectPtrVector;
00049
00050
00051 #endif // !defined(PERSISTABLEOBJECT_H)


ZonaBaseEntity.h File Reference

Go to the source code of this file.

Classes

class | ZonaBaseEntity

Defines

#define | _ZONABASEENTITY_H_INCLUDED_

Typedefs

typedef ZVector< ZonaBaseEntity * > | ZonaBaseEntityPtrVector

Define Documentation

#define _ZONABASEENTITY_H_INCLUDED_

Definition at line 6 of file ZonaBaseEntity.h.

Typedef Documentation

typedef ZVector<ZonaBaseEntity *> ZonaBaseEntityPtrVector

Definition at line 113 of file ZonaBaseEntity.h.


ZonaBaseEntity.h

Go to the documentation of this file.
00001 // ZonaBaseEntity.h: interface for the ZonaBaseEntity class.
00002 //
00004
00005 #if !defined(_ZONABASEENTITY_H_INCLUDED_)
00006 #define _ZONABASEENTITY_H_INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "Zona_API.h"
00013 #include "util/ZVector.h"
00014 #include "ZonaModeler/ZonaModelerObject.h"
00015
00016 ZONA_NAMESPACE_BEGIN
00017
00018 class ZonaBaseEntity : public ZonaModelerObject
00019 {
00020   public:
00024     ZonaBaseEntity(int type);
00025
00029     ZonaBaseEntity();
00030
00034     virtual ~ZonaBaseEntity();
00035
00040     virtual int  getEntityId()=0;
00041
00046     virtual int  getParentId()=0;
00047
00053     virtual int  getEntityType()=0;
00054
00060     virtual int  getEntityInfo()=0;
00061
00067     virtual int  getMapId()=0;
00068
00069
00075     virtual void setEntityId(int value)=0;
00076
00082     virtual void setParentId(int value)=0;
00083
00090     virtual void setEntityType(int value)=0;
00091
00097     virtual void setEntityInfo(int value)=0;
00098
00104     virtual void setMapId(int value)=0;
00105
00106
00107
00108     virtual void setIsMaster(bool value)=0;
00109     virtual bool getIsMaster()=0;
00110
00111 };
00112
00113 typedef ZVector<ZonaBaseEntity *> ZonaBaseEntityPtrVector;
00114
00115 ZONA_NAMESPACE_END
00116 ZONA_USING_NAMESPACE
00117
00118 #endif // !defined(_ZONABASEENTITY_H_INCLUDED_)


ZonaClientCharacter.h File Reference

Go to the source code of this file.

Classes

class | ZonaClientCharacter

Defines

#define | _ZONACLIENTCHARACTER_H_INCLUDED_

Typedefs

typedef ZVector< ZonaClientCharacter * > | ZonaClientCharacterPtrVector

Variables

ZONA_NAMESPACE_BEGIN class | GameCharacter

Define Documentation

#define _ZONACLIENTCHARACTER_H_INCLUDED_

Definition at line 6 of file ZonaClientCharacter.h.

Typedef Documentation

typedef ZVector<ZonaClientCharacter *> ZonaClientCharacterPtrVector

Definition at line 132 of file ZonaClientCharacter.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class GameCharacter

Definition at line 17 of file ZonaClientCharacter.h.


ZonaClientCharacter.h

Go to the documentation of this file.
00001 // ZonClientCharacter.h: interface for the ZonClientCharacter class.
00002 //
00004
00005 #if !defined(_ZONACLIENTCHARACTER_H_INCLUDED_)
00006 #define _ZONACLIENTCHARACTER_H_INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "ZonaClientEntity.h"
00013 #include "ZVector.h"
00014 #include "ZString.h"
00015
00016 ZONA_NAMESPACE_BEGIN
00017 class GameCharacter;
00018
00019 class ZonaClientCharacter : public ZonaClientEntity
00020 {
00021 public:
00025         ZonaClientCharacter(int type);
00026
00030         ZonaClientCharacter();
00031
00035         virtual ~ZonaClientCharacter();
00036
00050         int enter(int subFilter = ZONA_MSG_ALL);
00051
00061         int exit();
00062
00077         int  update();
00078
00088         int select();
00089
00090
00102         int acquireChildEntity(int entityId);
00103
00104
00114         int releaseChildEntity(int entityId);
00115
00116
00121         virtual char* getName(int& length)=0;
00122
00128         virtual void setName(char* name, int length)=0;
00129
00130 };
00131
00132 typedef ZVector<ZonaClientCharacter *> ZonaClientCharacterPtrVector;
00133
00134 ZONA_NAMESPACE_END
00135 ZONA_USING_NAMESPACE
00136
00137 #endif // !defined(_ZONACLIENTCHARACTER_H_INCLUDED_)


ZonaClientEntity.h File Reference

Go to the source code of this file.

Classes

class | ZonaClientEntity

Defines

#define | _ZONACLIENTENTITY_H_INCLUDED_

Typedefs

typedef ZVector< ZonaClientEntity * > | ZonaClientEntityPtrVector

Variables

ZONA_NAMESPACE_BEGIN class | ZonaClientEntity

Define Documentation

#define _ZONACLIENTENTITY_H_INCLUDED_

Definition at line 6 of file ZonaClientEntity.h.

Typedef Documentation

typedef ZVector<ZonaClientEntity *> ZonaClientEntityPtrVector

Definition at line 28 of file ZonaClientEntity.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaClientEntity

Definition at line 21 of file ZonaClientEntity.h.


ZonaClientEntity.h

Go to the documentation of this file.
00001 // ZonaClientEntity.h: interface for the ZonaClientEntity class.
00002 //
00004
00005 #if !defined(_ZONACLIENTENTITY_H_INCLUDED_)
00006 #define _ZONACLIENTENTITY_H_INCLUDED_
00007
00008 #if _MSC_VER > 1000
00009 #pragma once
00010 #endif // _MSC_VER > 1000
00011
00012 #include "Zona_API.h"
00013
00014 #include "ZonaBaseEntity.h"
00015 #include "util/ZVector.h"
00016 #include "ZonaPropertyData.h"
00017 #include "zaf/ZonaGlobalConstants.h"
00018
00019 ZONA_NAMESPACE_BEGIN
00020
00021 class ZonaClientEntity;
00022 class GameStateService;
00023 class ZonaServices;
00024 class ZonaClientCharacter;
00025 class ZonaClientEntityManager;
00026 class GameGuildService;
00027
00028 typedef ZVector<ZonaClientEntity *> ZonaClientEntityPtrVector;
00029
00030 class ZonaClientEntity : public ZonaBaseEntity
00031 {
00032   public:
00033
00037     ZonaClientEntity(int type);
00038
00042     ZonaClientEntity();
00043
00047     virtual ~ZonaClientEntity();
00048
00056     int publish();
00057
00071         int enter(int subFilter = ZONA_MSG_ALL);
00072
00082     int exit();
00083
00095         int getChildEntities(ZonaClientEntityPtrVector& childEntities, bool blockingCall = true);
00096
00103         bool isFetchingChildEntities();
00104
00112     int show();
00113
00121     int hide();
00122
00133     int attachEntity(int entityId);
00134
00145     int detachEntity(int entityId);
00146
00153     int activate();
00154
00162     int deactivate();
00163
00164
00173     void retain();
00174
00182     void release();
00183
00189     virtual void setRegionId(int regionId)=0;
00190
00196     virtual int getRegionId()=0;
00197
00198   protected:
00199
00200     int updateEntityType(int childId, int newEntityType);
00201     int updateEntityType(int parentId, int childId, int newEntityType);
00202
00203     ZonaServices *m_zs;
00204
00205     int m_refCount;
00206
00207   private:
00213     void setZonaServices(ZonaServices *zs);
00214
00220     int getRefCount();
00221
00226         void fetchChildEntitiesComplete();
00227
00232         void addChildEntityFromFetch(ZonaClientEntity *zce);
00233
00234         friend GameStateService;
00235     friend ZonaServices;
00236     friend ZonaClientCharacter;
00237     friend ZonaClientEntityManager;
00238         friend GameGuildService;
00239
00240         bool m_isFetchingChildEntities;
00241         ZonaClientEntityPtrVector *m_childEntities;
00242 };
00243
00244 ZONA_NAMESPACE_END
00245 ZONA_USING_NAMESPACE
00246
00247 #endif // !defined(_ZONACLIENTENTITY_H_INCLUDED_)


ZonaErrors.h File Reference

Go to the source code of this file.

Defines

#define | ERR_SUCCESS 50001
Success.

#define | ERR_CONNECTION_FAILED 50002
#define | ERR_LOGON_FAIL 50003
The login request failed. Usually a wrong password.

#define | ERR_MESSAGE_SEND 50004
#define | ERR_MESSAGE_RECEIVE 50005
#define | ERR_READ_INI_FILE 50006
#define | ERR_READ_INI_STRING 50007
#define | ERR_OPEN_LOGFILE 50008
#define | ERR_WRITE_LOGFILE 50009
#define | ERR_REGISTER_CALLBACK 50010
#define | ERR_MAX_CONN_LIMIT 50011
#define | ERR_NOT_CONNECTED 50012
#define | ERR_NO_FREE_SERVER 50013
#define | ERR_DISCONNECT_FAIL 50014
#define | ERR_NO_LISTENER 50015
#define | ERR_SUBSCRIBE 50016
#define | ERR_CHAT 50017
#define | ERR_MONITOR_SPHERE 50018
#define | ERR_SPHERE 50019
#define | ERR_RESET_IN_PROGRESS 50020
#define | ERR_GAME_PROFILE 50021
#define | ERR_GAME_STATE 50022
#define | ERR_UNSUBSCRIBE 50023
#define | ERR_NODATABASE 50024
An operation requiring a database was performed, but no database was configured.

#define | ERR_UNKNOWN 50025
An error occured, but the type could not be determined.

#define | ERR_ENTITY_MGNT 50026
#define | ERR_NULL_SERVICE 50027
#define | ERR_ENTITY_NOT_FOUND 50028
#define | ERR_UNKNOWN_PARENT_ID 50029
#define | ERR_INVALID_OPERATION 50030
#define | ERR_INVALID_ID 50031
#define | ERR_INVALID_CHILD_ENTITY 50032
#define | ERR_EMPTY_CHARACTER_NAME 50033
#define | ERR_DUP_CHARACTER_NAME 50034
#define | ERR_DB_INTEGRITY_CONST 50035
#define | ERR_LOGON_IN_PROGRESS 50036
#define | ERR_LOGON_ALREADY_LOGGED_IN 50037
#define | ERR_LOGON_FAILURE 50101
#define | ERR_LOGON_WRONG_GAME_VER 50102
#define | ERR_LOGON_WRONG_ZAF_VER 50103
#define | ERR_LOGON_FAIL_UNSET_VER 50104
#define | ERR_LOGON_FAIL_WRONG_GSS 50105
#define | ERR_LOGON_FAIL_NO_USER 50106
#define | ERR_LOGON_FAIL_BAD_PASSWD 50107
#define | ERR_CHAT_SERVICE_NOT_INIT 50108
#define | ERR_CHAT_SERVICE_CANT_INIT 50109
#define | ERR_PREV_CHARACTER_NOT_FOUND 52002
#define | ERR_PLUGIN_RET_INVALID 52003
#define | ERR_CHAT_NOT_MODERATOR 53001
#define | ERR_CHAT_NO_PERMISION 53002
#define | ERR_CHAT_UNKNOWN 53003
#define | ERR_INVALID_GUILD 53004
#define | ERR_NO_INIT_SERVICE 60001
#define | ERR_NO_LOGIN 60002
#define | ERR_NO_REG_CALLBACK 60005
#define | ERR_NO_ENTER_CHARACTER 60006
#define | ERR_NO_EXIT_CHARACTER 60007
#define | ERR_NO_SUBS_FILTERS_SET 60009
#define | ERR_ALREADY_ACTIVE 60010
#define | ERR_ALREADY_INACTIVE 60011

Define Documentation

#define ERR_SUCCESS 50001

Success.

Definition at line 10 of file ZonaErrors.h.

#define ERR_CONNECTION_FAILED 50002

Definition at line 11 of file ZonaErrors.h.

#define ERR_LOGON_FAIL 50003

The login request failed. Usually a wrong password.

Definition at line 12 of file ZonaErrors.h.

#define ERR_MESSAGE_SEND 50004

Definition at line 13 of file ZonaErrors.h.

#define ERR_MESSAGE_RECEIVE 50005

Definition at line 14 of file ZonaErrors.h.

#define ERR_READ_INI_FILE 50006

Definition at line 15 of file ZonaErrors.h.

#define ERR_READ_INI_STRING 50007

Definition at line 16 of file ZonaErrors.h.

#define ERR_OPEN_LOGFILE 50008

Definition at line 17 of file ZonaErrors.h.

#define ERR_WRITE_LOGFILE 50009

Definition at line 18 of file ZonaErrors.h.

#define ERR_REGISTER_CALLBACK 50010

Definition at line 19 of file ZonaErrors.h.

#define ERR_MAX_CONN_LIMIT 50011

Definition at line 20 of file ZonaErrors.h.

#define ERR_NOT_CONNECTED 50012

Definition at line 21 of file ZonaErrors.h.

#define ERR_NO_FREE_SERVER 50013

Definition at line 22 of file ZonaErrors.h.

#define ERR_DISCONNECT_FAIL 50014

Definition at line 23 of file ZonaErrors.h.

#define ERR_NO_LISTENER 50015

Definition at line 24 of file ZonaErrors.h.

#define ERR_SUBSCRIBE 50016

Definition at line 25 of file ZonaErrors.h.

#define ERR_CHAT 50017

Definition at line 26 of file ZonaErrors.h.

#define ERR_MONITOR_SPHERE 50018

Definition at line 27 of file ZonaErrors.h.

#define ERR_SPHERE 50019

Definition at line 28 of file ZonaErrors.h.

#define ERR_RESET_IN_PROGRESS 50020

Definition at line 29 of file ZonaErrors.h.

#define ERR_GAME_PROFILE 50021

Definition at line 30 of file ZonaErrors.h.

#define ERR_GAME_STATE 50022

Definition at line 31 of file ZonaErrors.h.

#define ERR_UNSUBSCRIBE 50023

Definition at line 32 of file ZonaErrors.h.

#define ERR_NODATABASE 50024

An operation requiring a database was performed, but no database was configured.

Definition at line 33 of file ZonaErrors.h.

#define ERR_UNKNOWN 50025

An error occured, but the type could not be determined.

Definition at line 34 of file ZonaErrors.h.

#define ERR_ENTITY_MGNT 50026

Definition at line 35 of file ZonaErrors.h.

#define ERR_NULL_SERVICE 50027

Definition at line 36 of file ZonaErrors.h.

#define ERR_ENTITY_NOT_FOUND 50028

Definition at line 37 of file ZonaErrors.h.

#define ERR_UNKNOWN_PARENT_ID 50029

Definition at line 38 of file ZonaErrors.h.

#define ERR_INVALID_OPERATION 50030

Definition at line 39 of file ZonaErrors.h.

#define ERR_INVALID_ID 50031

Definition at line 40 of file ZonaErrors.h.

#define ERR_INVALID_CHILD_ENTITY 50032

Definition at line 41 of file ZonaErrors.h.

#define ERR_EMPTY_CHARACTER_NAME 50033

Definition at line 42 of file ZonaErrors.h.

#define ERR_DUP_CHARACTER_NAME 50034

Definition at line 43 of file ZonaErrors.h.

#define ERR_DB_INTEGRITY_CONST 50035

Definition at line 44 of file ZonaErrors.h.

#define ERR_LOGON_IN_PROGRESS 50036

Definition at line 45 of file ZonaErrors.h.

#define ERR_LOGON_ALREADY_LOGGED_IN 50037

Definition at line 46 of file ZonaErrors.h.

#define ERR_LOGON_FAILURE 50101

Definition at line 47 of file ZonaErrors.h.

#define ERR_LOGON_WRONG_GAME_VER 50102

Definition at line 48 of file ZonaErrors.h.

#define ERR_LOGON_WRONG_ZAF_VER 50103

Definition at line 49 of file ZonaErrors.h.

#define ERR_LOGON_FAIL_UNSET_VER 50104

Definition at line 50 of file ZonaErrors.h.

#define ERR_LOGON_FAIL_WRONG_GSS 50105

Definition at line 51 of file ZonaErrors.h.

#define ERR_LOGON_FAIL_NO_USER 50106

Definition at line 52 of file ZonaErrors.h.

#define ERR_LOGON_FAIL_BAD_PASSWD 50107

Definition at line 53 of file ZonaErrors.h.

#define ERR_CHAT_SERVICE_NOT_INIT 50108

Definition at line 54 of file ZonaErrors.h.

#define ERR_CHAT_SERVICE_CANT_INIT 50109

Definition at line 55 of file ZonaErrors.h.

#define ERR_PREV_CHARACTER_NOT_FOUND 52002

Definition at line 56 of file ZonaErrors.h.

#define ERR_PLUGIN_RET_INVALID 52003

Definition at line 57 of file ZonaErrors.h.

#define ERR_CHAT_NOT_MODERATOR 53001

Definition at line 59 of file ZonaErrors.h.

#define ERR_CHAT_NO_PERMISION 53002

Definition at line 60 of file ZonaErrors.h.

#define ERR_CHAT_UNKNOWN 53003

Definition at line 61 of file ZonaErrors.h.

#define ERR_INVALID_GUILD 53004

Definition at line 62 of file ZonaErrors.h.

#define ERR_NO_INIT_SERVICE 60001

Definition at line 66 of file ZonaErrors.h.

#define ERR_NO_LOGIN 60002

Definition at line 67 of file ZonaErrors.h.

#define ERR_NO_REG_CALLBACK 60005

Definition at line 68 of file ZonaErrors.h.

#define ERR_NO_ENTER_CHARACTER 60006

Definition at line 69 of file ZonaErrors.h.

#define ERR_NO_EXIT_CHARACTER 60007

Definition at line 70 of file ZonaErrors.h.

#define ERR_NO_SUBS_FILTERS_SET 60009

Definition at line 71 of file ZonaErrors.h.

#define ERR_ALREADY_ACTIVE 60010

Definition at line 72 of file ZonaErrors.h.

#define ERR_ALREADY_INACTIVE 60011

Definition at line 73 of file ZonaErrors.h.


ZonaErrors.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2003, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net
00004  *
00005  * Filename: ZonaErrors.h
00006  *
00007  * Desc: Zona C CAPI Error codes
00008  ********************************************************************/
00009
00010 #define                 ERR_SUCCESS                                     50001
00011 #define                 ERR_CONNECTION_FAILED           50002
00012 #define                 ERR_LOGON_FAIL                          50003
00013 #define                 ERR_MESSAGE_SEND                        50004
00014 #define                 ERR_MESSAGE_RECEIVE                     50005
00015 #define                 ERR_READ_INI_FILE                       50006
00016 #define                 ERR_READ_INI_STRING                     50007
00017 #define                 ERR_OPEN_LOGFILE                        50008
00018 #define                 ERR_WRITE_LOGFILE                       50009
00019 #define                 ERR_REGISTER_CALLBACK           50010
00020 #define                 ERR_MAX_CONN_LIMIT                      50011
00021 #define                 ERR_NOT_CONNECTED                       50012
00022 #define                 ERR_NO_FREE_SERVER                      50013
00023 #define                 ERR_DISCONNECT_FAIL                     50014
00024 #define                 ERR_NO_LISTENER                         50015
00025 #define                 ERR_SUBSCRIBE                           50016
00026 #define                 ERR_CHAT                                        50017
00027 #define                 ERR_MONITOR_SPHERE                      50018
00028 #define                 ERR_SPHERE                                      50019
00029 #define                 ERR_RESET_IN_PROGRESS           50020
00030 #define                 ERR_GAME_PROFILE                        50021
00031 #define                 ERR_GAME_STATE                          50022
00032 #define                 ERR_UNSUBSCRIBE                         50023
00033 #define                 ERR_NODATABASE                          50024
00034 #define                 ERR_UNKNOWN                                     50025
00035 #define                 ERR_ENTITY_MGNT                         50026
00036 #define                 ERR_NULL_SERVICE                        50027
00037 #define                 ERR_ENTITY_NOT_FOUND            50028
00038 #define                 ERR_UNKNOWN_PARENT_ID           50029
00039 #define                 ERR_INVALID_OPERATION           50030 // operation not allowed for current state
00040 #define                 ERR_INVALID_ID                          50031
00041 #define                 ERR_INVALID_CHILD_ENTITY        50032
00042 #define                 ERR_EMPTY_CHARACTER_NAME        50033
00043 #define                 ERR_DUP_CHARACTER_NAME          50034
00044 #define                 ERR_DB_INTEGRITY_CONST          50035
00045 #define                 ERR_LOGON_IN_PROGRESS           50036
00046 #define                 ERR_LOGON_ALREADY_LOGGED_IN     50037
00047 #define                 ERR_LOGON_FAILURE                       50101
00048 #define                 ERR_LOGON_WRONG_GAME_VER        50102
00049 #define                 ERR_LOGON_WRONG_ZAF_VER         50103
00050 #define                 ERR_LOGON_FAIL_UNSET_VER        50104
00051 #define                 ERR_LOGON_FAIL_WRONG_GSS        50105
00052 #define                 ERR_LOGON_FAIL_NO_USER          50106
00053 #define                 ERR_LOGON_FAIL_BAD_PASSWD       50107
00054 #define                 ERR_CHAT_SERVICE_NOT_INIT       50108
00055 #define                 ERR_CHAT_SERVICE_CANT_INIT  50109
00056 #define         ERR_PREV_CHARACTER_NOT_FOUND       52002
00057 #define         ERR_PLUGIN_RET_INVALID             52003
00058
00059 #define                 ERR_CHAT_NOT_MODERATOR      53001
00060 #define                 ERR_CHAT_NO_PERMISION       53002
00061 #define                 ERR_CHAT_UNKNOWN            53003
00062 #define                 ERR_INVALID_GUILD                       53004
00063
00064 // Foll error codes are called when dependant operations are attempted
00065 // before the reqd. function call is made
00066 #define                 ERR_NO_INIT_SERVICE                     60001
00067 #define                 ERR_NO_LOGIN                            60002
00068 #define                 ERR_NO_REG_CALLBACK                     60005
00069 #define                 ERR_NO_ENTER_CHARACTER          60006
00070 #define                 ERR_NO_EXIT_CHARACTER           60007
00071 #define                 ERR_NO_SUBS_FILTERS_SET         60009
00072 #define                 ERR_ALREADY_ACTIVE                      60010
00073 #define                 ERR_ALREADY_INACTIVE            60011


ZonaGlobalConstants.h File Reference

Go to the source code of this file.

Defines

#define | MAX_INI_BUFFER 300
#define | PLAYER_JOINED_GAME 11
#define | PLAYER_DEPARTED_GAME 12
#define | ENTITY_JOINED_SPHERE 13
#define | ENTITY_DEPARTED_SPHERE 14
#define | PLAYER_RECONNECT_GAME 15
#define | ZONA_MSG_NONE 0x0000
#define | ZONA_MSG_SPHERE_UPDATES 0x0001
#define | ZONA_MSG_GAMESTATE 0x0002
#define | ZONA_MSG_GAMEEVENT 0x0004
#define | ZONA_MSG_ALL 0x7fff
#define | UPDATE_CHILD_REMOVE 1
#define | UPDATE_CHILD_ADD 2
#define | ZONA_PING 4000

Typedefs

typedef LinkedListTmpl< int > | IntList
typedef LinkedListTmpl< ZonaEntity * > | ZonaEntityList

Enumerations

enum SPHERE_CHAT_COVERAGE {
S_CHAT_COVERAGE_NEAR = 0x1,
S_CHAT_COVERAGE_FAR = 0x2
}
enum ChatType {
GUILD,
PRIVATE,
SPHERE,
SYSTEMWIDE,
COUNT
}
enum loginStatus {
NOT_LOGGED_IN,
LOGGED_IN,
LOGIN_IN_PROGRESS,
LOGOUT_IN_PROGRESS,
LOGIN_FAIL_NODATABASE,
LOGIN_FAIL_WRONG_PASS
}

Variables

char * | INI_FILE_NAME = "zonacomm.ini"
char * | ZAC_INI_FILENAME = "zona_ZAC.ini"
char * | HOST_URL = "Host"
char * | USER_NAME = "UserName"
char * | PASSWORD = "Password"
char * | INI_CONNECTION_SECTION = "ZonaConnectionSetup"
short | ZONA_ET_DEFAULT = 0
short | ZONA_ET_IS_HIDDEN = 1
short | ZONA_ET_IS_ATTACHED = 2
short | ZONA_ET_IS_USER_ENTITY = 4
short | ZONA_ET_RESERVED_1 = 8
short | ZONA_ET_RESERVED_2 = 16
short | ZONA_ET_RESERVED_3 = 32
short | ZONA_ET_RESERVED_4 = 64
short | ZONA_ET_RESERVED_5 = 128
char | GROUP_CHAT_CMD_SEND_MSG = 0
char | GROUP_CHAT_CMD_INVITE = 1
char | GROUP_CHAT_CMD_ACCEPT = 2
char | GROUP_CHAT_CMD_LEAVE = 3
char | GROUP_CHAT_CMD_DISBAND = 4
char | CHAT_INTENSITY_WHISPER = 1
char | CHAT_INTENSITY_TALK = 2
char | CHAT_INTENSITY_YELL = 4
char | CHAT_INTENSITY_SHOUT = 8
char | CHAT_COVERAGE_NEAR = 1
char | CHAT_COVERAGE_FAR = 2
char | CHAT_CHANNEL_PRIVATE = 1
char | CHAT_CHANNEL_SPHERE = 2
char | CHAT_CHANNEL_GROUP = 4
char | CHAT_CHANNEL_GUILD = 8
char | CHAT_CHANNEL_PUBLIC = 16

Define Documentation

#define MAX_INI_BUFFER 300

Definition at line 41 of file ZonaGlobalConstants.h.

#define PLAYER_JOINED_GAME 11

Definition at line 103 of file ZonaGlobalConstants.h.

#define PLAYER_DEPARTED_GAME 12

Definition at line 104 of file ZonaGlobalConstants.h.

#define ENTITY_JOINED_SPHERE 13

Definition at line 105 of file ZonaGlobalConstants.h.

#define ENTITY_DEPARTED_SPHERE 14

Definition at line 106 of file ZonaGlobalConstants.h.

#define PLAYER_RECONNECT_GAME 15

Definition at line 107 of file ZonaGlobalConstants.h.

#define ZONA_MSG_NONE 0x0000

Definition at line 110 of file ZonaGlobalConstants.h.

#define ZONA_MSG_SPHERE_UPDATES 0x0001

Definition at line 112 of file ZonaGlobalConstants.h.

#define ZONA_MSG_GAMESTATE 0x0002

Definition at line 114 of file ZonaGlobalConstants.h.

#define ZONA_MSG_GAMEEVENT 0x0004

Definition at line 116 of file ZonaGlobalConstants.h.

#define ZONA_MSG_ALL 0x7fff

Definition at line 118 of file ZonaGlobalConstants.h.

#define UPDATE_CHILD_REMOVE 1

Definition at line 132 of file ZonaGlobalConstants.h.

#define UPDATE_CHILD_ADD 2

Definition at line 133 of file ZonaGlobalConstants.h.

#define ZONA_PING 4000

Definition at line 136 of file ZonaGlobalConstants.h.

Typedef Documentation

typedef LinkedListTmpl<int> IntList

Definition at line 139 of file ZonaGlobalConstants.h.

typedef LinkedListTmpl<ZonaEntity*> ZonaEntityList

Definition at line 140 of file ZonaGlobalConstants.h.

Enumeration Type Documentation

enum SPHERE_CHAT_COVERAGE

Enumeration values:
S_CHAT_COVERAGE_NEAR
S_CHAT_COVERAGE_FAR

Definition at line 71 of file ZonaGlobalConstants.h.

enum ChatType

Enumeration values:
GUILD
PRIVATE
SPHERE
SYSTEMWIDE
COUNT

Definition at line 94 of file ZonaGlobalConstants.h.

enum loginStatus

Enumeration values:
NOT_LOGGED_IN
LOGGED_IN
LOGIN_IN_PROGRESS
LOGOUT_IN_PROGRESS
LOGIN_FAIL_NODATABASE
LOGIN_FAIL_WRONG_PASS

Definition at line 121 of file ZonaGlobalConstants.h.

Variable Documentation

char* INI_FILE_NAME = "zonacomm.ini" [static]

Definition at line 45 of file ZonaGlobalConstants.h.

char* ZAC_INI_FILENAME = "zona_ZAC.ini" [static]

Definition at line 46 of file ZonaGlobalConstants.h.

char* HOST_URL = "Host" [static]

Definition at line 47 of file ZonaGlobalConstants.h.

char* USER_NAME = "UserName" [static]

Definition at line 48 of file ZonaGlobalConstants.h.

char* PASSWORD = "Password" [static]

Definition at line 49 of file ZonaGlobalConstants.h.

char* INI_CONNECTION_SECTION = "ZonaConnectionSetup" [static]

Definition at line 50 of file ZonaGlobalConstants.h.

short ZONA_ET_DEFAULT = 0 [static]

Definition at line 53 of file ZonaGlobalConstants.h.

short ZONA_ET_IS_HIDDEN = 1 [static]

Definition at line 54 of file ZonaGlobalConstants.h.

short ZONA_ET_IS_ATTACHED = 2 [static]

Definition at line 55 of file ZonaGlobalConstants.h.

short ZONA_ET_IS_USER_ENTITY = 4 [static]

Definition at line 56 of file ZonaGlobalConstants.h.

short ZONA_ET_RESERVED_1 = 8 [static]

Definition at line 57 of file ZonaGlobalConstants.h.

short ZONA_ET_RESERVED_2 = 16 [static]

Definition at line 58 of file ZonaGlobalConstants.h.

short ZONA_ET_RESERVED_3 = 32 [static]

Definition at line 59 of file ZonaGlobalConstants.h.

short ZONA_ET_RESERVED_4 = 64 [static]

Definition at line 60 of file ZonaGlobalConstants.h.

short ZONA_ET_RESERVED_5 = 128 [static]

Definition at line 61 of file ZonaGlobalConstants.h.

char GROUP_CHAT_CMD_SEND_MSG = 0 [static]

Definition at line 64 of file ZonaGlobalConstants.h.

char GROUP_CHAT_CMD_INVITE = 1 [static]

Definition at line 65 of file ZonaGlobalConstants.h.

char GROUP_CHAT_CMD_ACCEPT = 2 [static]

Definition at line 66 of file ZonaGlobalConstants.h.

char GROUP_CHAT_CMD_LEAVE = 3 [static]

Definition at line 67 of file ZonaGlobalConstants.h.

char GROUP_CHAT_CMD_DISBAND = 4 [static]

Definition at line 68 of file ZonaGlobalConstants.h.

char CHAT_INTENSITY_WHISPER = 1 [static]

Definition at line 77 of file ZonaGlobalConstants.h.

char CHAT_INTENSITY_TALK = 2 [static]

Definition at line 78 of file ZonaGlobalConstants.h.

char CHAT_INTENSITY_YELL = 4 [static]

Definition at line 79 of file ZonaGlobalConstants.h.

char CHAT_INTENSITY_SHOUT = 8 [static]

Definition at line 80 of file ZonaGlobalConstants.h.

char CHAT_COVERAGE_NEAR = 1 [static]

Definition at line 83 of file ZonaGlobalConstants.h.

char CHAT_COVERAGE_FAR = 2 [static]

Definition at line 84 of file ZonaGlobalConstants.h.

char CHAT_CHANNEL_PRIVATE = 1 [static]

Definition at line 87 of file ZonaGlobalConstants.h.

char CHAT_CHANNEL_SPHERE = 2 [static]

Definition at line 88 of file ZonaGlobalConstants.h.

char CHAT_CHANNEL_GROUP = 4 [static]

Definition at line 89 of file ZonaGlobalConstants.h.

char CHAT_CHANNEL_GUILD = 8 [static]

Definition at line 90 of file ZonaGlobalConstants.h.

char CHAT_CHANNEL_PUBLIC = 16 [static]

Definition at line 91 of file ZonaGlobalConstants.h.


ZonaGlobalConstants.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: ZonaGlobalConstants.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023 #ifndef _ZONA_CONSTANTS
00024 #define _ZONA_CONSTANTS
00025
00026 #ifndef _NGC
00027 #pragma once
00028 #endif
00029 // Header file for Zona Global constants constants
00030
00031 // Program specific constants
00032 #include "Zona_API.h"
00033 #include "ZonaErrors.h"
00034 #include "util/ZonaHashTable.h" // hashtable template implementation
00035 #include "util/LinkedListTmpl.h"// linked list implementation
00036 #include "util/ZonaEntity.h"
00037 #include "message/icetech_jms.h"
00038 #include "util/ZonaBaseGuildMembership.h"
00039
00040 // Data size constants
00041 #define MAX_INI_BUFFER 300      // Defines the maximum number of chars we can
00042                             // read from the ini file
00043
00044 // ini file related constants
00045 static char*    INI_FILE_NAME                   =       "zonacomm.ini";
00046 static char*  ZAC_INI_FILENAME  = "zona_ZAC.ini";
00047 static char*    HOST_URL                                        =       "Host";
00048 static char*    USER_NAME                                       =       "UserName";
00049 static char*    PASSWORD                                                                =       "Password";
00050 static char*  INI_CONNECTION_SECTION    =       "ZonaConnectionSetup";
00051
00052 //Entity Types
00053 static short ZONA_ET_DEFAULT        = 0;
00054 static short ZONA_ET_IS_HIDDEN      = 1;
00055 static short ZONA_ET_IS_ATTACHED    = 2;
00056 static short ZONA_ET_IS_USER_ENTITY = 4;
00057 static short ZONA_ET_RESERVED_1     = 8;
00058 static short ZONA_ET_RESERVED_2     = 16;
00059 static short ZONA_ET_RESERVED_3     = 32;
00060 static short ZONA_ET_RESERVED_4     = 64;
00061 static short ZONA_ET_RESERVED_5     = 128;
00062
00063 //Chat
00064 static char GROUP_CHAT_CMD_SEND_MSG=0;
00065 static char GROUP_CHAT_CMD_INVITE=1;
00066 static char GROUP_CHAT_CMD_ACCEPT=2;
00067 static char GROUP_CHAT_CMD_LEAVE=3;
00068 static char GROUP_CHAT_CMD_DISBAND=4;
00069
00070 // Sphere Chat Options
00071 enum SPHERE_CHAT_COVERAGE {
00072         S_CHAT_COVERAGE_NEAR      = 0x1,
00073     S_CHAT_COVERAGE_FAR       = 0x2
00074 };
00075
00076 // Levels of intensity for the chat messages.
00077 static char    CHAT_INTENSITY_WHISPER  = 1;
00078 static char    CHAT_INTENSITY_TALK     = 2;
00079 static char    CHAT_INTENSITY_YELL     = 4;
00080 static char    CHAT_INTENSITY_SHOUT    = 8;
00081
00082 // Ranges for the chat messages
00083 static char    CHAT_COVERAGE_NEAR      = 1;
00084 static char    CHAT_COVERAGE_FAR       = 2;
00085
00086 // channels of the chat messages
00087 static char    CHAT_CHANNEL_PRIVATE    = 1;
00088 static char    CHAT_CHANNEL_SPHERE     = 2;
00089 static char    CHAT_CHANNEL_GROUP      = 4;
00090 static char    CHAT_CHANNEL_GUILD      = 8;
00091 static char    CHAT_CHANNEL_PUBLIC     = 16;
00092
00093 // Enumeration type for CHAT GUILDS
00094 enum ChatType{
00095                 GUILD,
00096                 PRIVATE,
00097                 SPHERE,
00098     SYSTEMWIDE,
00099                 COUNT
00100 };
00101
00102 // client status
00103 #define PLAYER_JOINED_GAME       11
00104 #define PLAYER_DEPARTED_GAME     12
00105 #define ENTITY_JOINED_SPHERE     13
00106 #define ENTITY_DEPARTED_SPHERE   14
00107 #define PLAYER_RECONNECT_GAME    15
00108
00109 // do not receive any messages.
00110 #define ZONA_MSG_NONE            0x0000
00111 // receive enter & exit spheres updates.
00112 #define ZONA_MSG_SPHERE_UPDATES  0x0001
00113 // receive game states.
00114 #define ZONA_MSG_GAMESTATE       0x0002
00115 // receive game events.
00116 #define ZONA_MSG_GAMEEVENT       0x0004
00117 // receive all messages.
00118 #define ZONA_MSG_ALL                        0x7fff
00119
00120 // Enumeration type for Login Status
00121 enum loginStatus {
00122         NOT_LOGGED_IN,
00123         LOGGED_IN,
00124         LOGIN_IN_PROGRESS,
00125         LOGOUT_IN_PROGRESS,
00126         LOGIN_FAIL_NODATABASE,
00127         LOGIN_FAIL_WRONG_PASS
00128 };
00129
00130
00131 // Flags for onNotifyEntityUpdate
00132 #define UPDATE_CHILD_REMOVE 1
00133 #define UPDATE_CHILD_ADD 2
00134
00135 // ZONA_PING is also defined in internal header file
00136 #define ZONA_PING                                               4000 // router pinging daemon
00137
00138 // Linked list Implementation
00139 typedef LinkedListTmpl<int> IntList;
00140 typedef LinkedListTmpl<ZonaEntity*> ZonaEntityList;
00141
00142
00143
00144
00145 #endif


ZonaObject.h File Reference

Go to the source code of this file.

Classes

class | ZonaObject
ZonaObject. More...

Defines

#define | ZONAOBJECT_H

Typedefs

typedef ZVector< ZonaObject * > | ZonaObjectPtrVector
An STL vector containing ZonaObjects.

Variables

ZONA_NAMESPACE_BEGIN class | ZonaMessage
This structure represents a persistable entity in a game.

Define Documentation

#define ZONAOBJECT_H

Definition at line 24 of file ZonaObject.h.

Typedef Documentation

typedef ZVector<ZonaObject*> ZonaObjectPtrVector

An STL vector containing ZonaObjects.

Definition at line 167 of file ZonaObject.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaMessage

This structure represents a persistable entity in a game.

The ZonaObject is identified by the id member field. If the id is 0, it means that the ZonaObject does not yet exist in the Database. When the object is persisted to the database, id is set to a unique number generated by the database. This allows for easy copying and updating of zonaObjects in the DB. For example to clone a ZonaObject, all you have to do is set the id to 0 and pass the zonaObject to a function which will create the zonaObject in the DB (such as zonaServices.createCharacter()). This object is streamable.

Definition at line 43 of file ZonaObject.h.


ZonaObject.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http://www.zona.net  or
00004  *
00005  * Filename: ZonaObject.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023 #if !defined(ZONAOBJECT_H)
00024 #define ZONAOBJECT_H
00025
00026 #include "util/ZonaPropertyData.h"
00027
00028 #include "PersistableObject.h"
00029
00030 #include "util/ZVector.h"
00031
00041 ZONA_NAMESPACE_BEGIN
00042
00043 class ZonaMessage;
00044 class ZonaClientEntity;
00050 class ZonaObject : public PersistableObject
00051 {
00052 public:
00053
00055         ZonaObject();
00056
00058         ZonaObject(const ZonaObject& other);
00059
00060         ~ZonaObject();
00061
00062         ZonaObject&ZonaObject::operator=(const ZonaObject& other);
00063
00066         ZonaObject(short type, int id);
00067
00069         ZWString toString();
00070
00071
00072
00078         ZonaPropertyData * getPublicDisplayPropertyData() { return &m_publicDisplayProperties;} ;
00079
00080         ZonaPropertyData * getPublicStatePropertyData() { return &m_publicStateProperties;} ;
00081
00082         ZonaPropertyData * getPrivatePropertyData() { return &m_privateProperties;} ;
00083
00084         ZonaPropertyData * getSystemPropertyData() { return &m_systemProperties;} ;
00085
00091         void setPublicDisplayPropertyData(ZonaPropertyData &p) { m_publicDisplayProperties = p;} ;
00092
00093         void setPublicStatePropertyData(ZonaPropertyData &p) { m_publicStateProperties = p;} ;
00094
00095         void setPrivatePropertyData(ZonaPropertyData &p) { m_privateProperties = p;} ;
00096
00097         void setSystemPropertyData(ZonaPropertyData &p) { m_systemProperties = p;} ;
00098
00099         void setId(int theId) { id = theId;};
00100
00101         void clearPropertyData();
00102
00108         virtual OutStream& serialize(OutStream& os);
00109
00115         virtual InStream& deserialize(InStream& is);
00116
00117         virtual void appendToZonaMessage(ZonaMessage *zm);
00118
00119         virtual void extractFromZonaMessage(ZonaMessage *zm);
00120
00124         int type;
00125
00127         int parent;
00128
00129
00130         void setParent(int aParent) { parent = aParent; };
00131
00132         void setType(int aType) { type = aType; };
00133
00134         short getType() { return type; }
00135
00136     void setClassId(short value);
00137
00138     short getClassId();
00139
00143         char *getGenericDataBlob();
00144
00145         int getGenericDataLength();
00146
00147         void setGenericData(char *blob, int length);
00148
00149 private:
00151         wchar_t desc[80];
00152
00153
00155         short m_classId;
00156
00157 public:
00158         ZonaPropertyData m_publicDisplayProperties;
00159         ZonaPropertyData m_publicStateProperties;
00160         ZonaPropertyData m_privateProperties;
00161         ZonaPropertyData m_systemProperties;
00162
00163 };
00164
00165
00167 typedef ZVector<ZonaObject*> ZonaObjectPtrVector;
00168
00169 ZONA_NAMESPACE_END
00170 ZONA_USING_NAMESPACE
00171
00172 #endif // !defined(ZONAOBJECT_H)


ZonaServices.h File Reference

Go to the source code of this file.

Classes

class | ZonaServices

Defines

#define | _ZONASERVICES_H_

Typedefs

typedef ZVector< ZonaClientCharacter * > | ZonaClientCharacterPtrVector
typedef ZVector< ZonaClientEntity * > | ZonaClientEntityPtrVector

Variables

ZONA_NAMESPACE_BEGIN class | ZonaClientEntity

Define Documentation

#define _ZONASERVICES_H_

Definition at line 25 of file ZonaServices.h.

Typedef Documentation

typedef ZVector<ZonaClientCharacter *> ZonaClientCharacterPtrVector

Definition at line 54 of file ZonaServices.h.

typedef ZVector<ZonaClientEntity *> ZonaClientEntityPtrVector

Definition at line 55 of file ZonaServices.h.

Variable Documentation

ZONA_NAMESPACE_BEGIN class ZonaClientEntity

Definition at line 51 of file ZonaServices.h.


ZonaServices.h

Go to the documentation of this file.
00001 /*********************************************************************
00002  * Copyright (c) 2001, Zona, Inc. All Rights Reserved
00003  * Please visit http: *www.zona.net  or
00004  *
00005  * Filename: ZonaServices.h
00006  *
00007  * Original Author:
00008  *
00009  * Purpose:
00010  *
00011  * Restrictions: None
00012  *
00013  * Error handling: None
00014  *
00015  * Notes:
00016  *
00017  * To Do:
00018  *
00019  * $History: $
00020  * 1.0 -
00021  *
00022  ********************************************************************/
00023
00024 #if !defined(_ZONASERVICES_H_)
00025 #define _ZONASERVICES_H_
00026
00027
00028 #include "BaseServices.h"
00029 #include "Zona_API.h"
00030 #include "zaf/ZonaGlobalConstants.h"
00031
00032 #include "callback/GameStateCallback.h"
00033 #include "callback/ChatCallback.h"
00034 #include "callback/GuildCallback.h"
00035 #include "callback/GameGuildCallback.h"
00036 #include "callback/EntityCallback.h"
00037
00038 #include "GameGuildServiceInterface.h"
00039
00040 class ChatService;
00041 class CharacterService;
00042 class PlayerAdminService;
00043 class GuildService;
00044 class ModelerService;
00045
00046 #include "util/ZonaClientGuild.h"
00047 #include "message/data/ChatMsg.h"
00048
00049 ZONA_NAMESPACE_BEGIN
00050
00051 class ZonaClientEntity;
00052 class ZonaClientCharacter;
00053
00054 typedef ZVector<ZonaClientCharacter *> ZonaClientCharacterPtrVector;
00055 typedef ZVector<ZonaClientEntity *> ZonaClientEntityPtrVector;
00056
00066 class ZonaServices :
00067         public BaseServices
00068 {
00069 public:
00082         ZonaServices(bool messageBuffering=true, bool autoUpdate=false);
00083
00087         ~ZonaServices();
00088
00102         int getCharacters(ZonaClientCharacterPtrVector& zccVector);
00103
00104
00111         int getNewChildEntityId();
00112
00120         int createSingleChildEntity(ZonaClientEntity & aEntity);
00121
00122
00132         int createMultipleChildEntities(ZonaClientEntityPtrVector& zChars);
00133
00144         int deleteChildEntity(int childEntityId);
00145
00146
00155   int publishEntityPropertyUpdates(int entityId);
00156
00165   int publishAllEntityProperties(int entityId);
00166
00179         int getIdForCharacterName(const char* name, int& id);
00180
00184         int getIdForGuildName(const char* name, int& id);
00185
00199         int createCharacter(ZonaClientCharacter & newCharacter);
00200
00213         int deleteCharacter(int characterId);
00214
00216         //guild functionality
00218
00231         int createGuild(ZonaClientGuild *zcg, int entityId);
00232
00244         int deleteGuild(ZonaClientGuild *zcg, int entityId);
00245
00246
00256         int joinGuild(int guildId);
00257
00267         int removeGuildMember(int guildId, int charId);
00268
00280         int inviteGuildMember(int guildId, int charId);
00281
00282
00283         bool addGuildModerator(int guildId, int charId);
00284         bool removeGuildModerator(int guildId, int charId);
00285         bool getModerators(int guildId, IntVector& vec);
00286
00300         int fetchMyGuilds(ZonaClientGuildPtrVector& gpv);
00301
00311         int monitorGuildUpdates(GuildCallback& guildCallback);
00312
00319         int stopMonitorGuildUpdates();
00320
00322         //Functions affecting all chat messages messages
00324
00325
00337         int sendChatMessage(const ChatMsg& m);
00338
00347         int setChatHandler(ChatType type, ChatCallback& chatCallback);
00348
00349
00355         int stopMonitorChat(ChatType type);
00356
00365         void setFilterOptions(bool options);
00366
00374         int setChatHandler(int entityId, ChatCallback& chatCallback);
00375
00376
00382         int stopMonitorChat(int entityId);
00383
00384
00390         int setDefaultChatHandler(ChatCallback& chatCallback);
00391
00392
00397         int stopMonitorChatDefault(void);
00398
00399
00400
00402         //Functions affecting only persistent messages
00404
00412         int deletePersistentMessage(int messageId);
00413
00414
00434         int fetchPersistentMessages(    ChatMsgPtrVector& mpv,
00435                                                                 int recipientId,
00436                                                                 int flag = 0,
00437                                                                 INT64 minDate=-1,
00438                                                                 INT64 maxDate=-1,
00439                                                                 int senderId = -1);
00440
00441
00448         GameGuildServiceInterface* getGameGuildServices();
00449
00450
00451         char lastError[255];
00452
00453         // -- Advanced Entity Management --
00454
00455
00456
00457 protected:
00458         void initializeChatServices();
00459         void initializeServices();
00460         void setServiceEntityId(int id);
00461
00462 private:
00463         ChatService *chatService;
00464         CharacterService *characterService;
00465         PlayerAdminService *adminService;
00466         GuildService *guildService;
00467         ModelerService * _modelerService;
00468         GameGuildServiceInterface* gameGuildService;
00469
00470         int m_serviceEntityId;
00471         bool m_filterOptions;
00472         friend ZonaClientCharacter;
00473
00474 };
00475 ZONA_NAMESPACE_END
00476 ZONA_USING_NAMESPACE
00477
00478
00479
00480 #endif


ZonaTimeUtils.h File Reference

Go to the source code of this file.

Classes

class | ZonaTimeUtils
ZonaTimeUtils. More...

Defines

#define | ZONA_TIMEUTILS_H_INCLUDED_

Define Documentation

#define ZONA_TIMEUTILS_H_INCLUDED_

Definition at line 4 of file ZonaTimeUtils.h.


ZonaTimeUtils.h

Go to the documentation of this file.
00001
00002
00003 #if !defined(ZONA_TIMEUTILS_H_INCLUDED_)
00004 #define ZONA_TIMEUTILS_H_INCLUDED_
00005
00006 #include "Zona_API.h"
00007
00008 #if defined(_XBOX) && defined (WIN32)
00009 #include <xtl.h>
00010 #endif
00011 #if !defined(_XBOX) && defined (WIN32)
00012 #include <windows.h>
00013 #endif
00014
00015 ZONA_NAMESPACE_BEGIN
00016
00022 class ZonaTimeUtils
00023 {
00024 public:
00025
00026         ZonaTimeUtils();
00027         ~ZonaTimeUtils();
00028
00029         static void ZonaTimeToFileTime(jlong jtime, FILETIME* timeFT);
00030         static jlong FileTimeToZonaTime(FILETIME* timeFT);
00031         static int millsSinceGlobalSyncPoint(jlong localSyncPoint, int millsSinceZST);
00032         static jlong millsAtCurrentTime();
00033
00034 private:
00035         // the delta between filetime and javatime starts
00036         const static jlong JAVATIMESTART64;
00037
00038 };
00039 ZONA_NAMESPACE_END
00040
00041 #endif // !defined(ZONA_TIMEUTILS_H_INCLUDED_)


ZString.h File Reference

Go to the source code of this file.

Classes

class | ZString
ZString. More...

class | ZWString
ZWString. More...

Defines

#define | ZSTRING_H

Define Documentation

#define ZSTRING_H

Definition at line 39 of file ZString.h.


ZString.h

Go to the documentation of this file.
00001 /******************************************************************************
00002 *                                                                             *
00003 *        Code from Item 29 ("Reference Counting") of MORE EFFECTIVE C++       *
00004 *                                                                             *
00005 *                               Scott Meyers                                  *
00006 *                                                                             *
00007 *his file, but they are used in the code that
00008                          // tests the classes.
00009
00010 #include <cstring>       // This includes the C string functions, e.g.,
00011                          //             Copyright 1996 (c) Addison-Wesley Publishing Company             *
00012 *       You are free to use this code for non-commercial purposes only.       *
00013 *                                                                             *
00014 * This page contains the code for the classes and class templates making up   *
00015 * the Reference Counting Item of More Effective C++.  To use this code,       *
00016 * either copy this page and paste it into a C++ source file or save the       *
00017 * entire page as text into a C++ source file.  Don't save the HTML source     *
00018 * and expect that to compile :-)                                              *
00019 *                                                                             *
00020 * Each class or template in this file follows a block comment that shows the  *
00021 * corresponding pages in the book.  This page also contains a main function   *
00022 * that performs a VERY limited test of the code in this file.  You can        *
00023 * compile the code in this file as a stand-alone program, and you should get  *
00024 * this output:                                                                *
00025 *                                                                             *
00026 *     ZString with no changes.                                                 *
00027 *     ZString with    changes.                                                 *
00028 *     10                                                                      *
00029 *     -1                                                                      *
00030 *                                                                             *
00031 * The code here reflects all changes made to date in response to bug reports  *
00032 * from readers of the book.  (To see a complete list of known bugs in More    *
00033 * Effective C++, as well as whether they've been fixed yet, visit the         *
00034 * More Effective C++ Errata List.)  If you find any additional bugs, please   *
00035 * send them to me.                                                            *
00036 ******************************************************************************/
00037
00038 #if !defined(ZSTRING_H)
00039 #define ZSTRING_H
00040 #include <wchar.h>
00041
00042 //#include <iostream>      // The iostream facilities are not used in the classes
00043                          // in tstrlen, strcpy, etc.  They are used in the
00044                          // implementation of class ZString::StringValue.
00045 #include "RCObjects.h"
00046
00047 // The following is for compilers that don't support bool.  Uncomment these
00048 // lines if your compilers lack bool support.  For details on this emulation
00049 // of bool, see More Effective C++, pp. 3-4.
00050 // typedef int bool;
00051 // const bool false = 0;
00052 // const bool true = 1;
00053
00054 /******************************************************************************
00055 *           Classes ZString and StringValue (from pp. 204, 206-207)            *
00056 ******************************************************************************/
00062 class ZString {                          // class to be used by
00063 public:                                 // application developers
00064   ZString(const char *value = "");
00065
00066   char operator[](int index) const;
00067   char& operator[](int index);
00068         const char* toString();
00069         const wchar_t* toWString();
00070         bool  compare(const char* value);
00071         void  append(const char* str);
00072         int   length();
00073
00074         static int w2a(const wchar_t* ws, char* sBuf, int sBufSize);
00075         static int a2w(const char* as, wchar_t* sBuf, int sBufSize);
00076
00077 private:
00078   // class representing string values
00079   struct StringValue: public RCObject {
00080     char                  *data;
00081     wchar_t             *dataW;
00082     StringValue(const char *initValue);
00083     StringValue(const StringValue& rhs);
00084     void init(const char *initValue);
00085     ~StringValue();
00086   };
00087
00088   RCPtr<StringValue> value;
00089
00090 };
00091
00092
00093 /******************************************************************************
00094 *           Classes ZWString and StringValue (from pp. 204, 206-207)            *
00095 ******************************************************************************/
00101 class ZWString {                          // class to be used by
00102 public:                                 // application developers
00103   ZWString(const wchar_t *value = L"");
00104         ZWString(const char *valueA);
00105
00106   wchar_t operator[](int index) const;
00107   wchar_t& operator[](int index);
00108         const wchar_t* toString();
00109         const char* toStringA();
00110         bool  compare(const wchar_t* value);
00111         void  append(const wchar_t* str);
00112         int   length();
00113         void  copyFromChar(const wchar_t* str);
00114
00115         static int w2a(const wchar_t* ws, char* sBuf, int sBufSize);
00116         static int a2w(const char* as, wchar_t* sBuf, int sBufSize);
00117
00118 private:
00119   // class representing string values
00120   struct StringValue: public RCObject {
00121     wchar_t *data;
00122     char                *dataA;
00123     StringValue(const wchar_t *initValue);
00124                 StringValue(const char *initValue);
00125     StringValue(const StringValue& rhs);
00126     void init(const wchar_t *initValue);
00127                 void init(const char *initValue);
00128     ~StringValue();
00129   };
00130
00131   RCPtr<StringValue> value;
00132
00133 };
00134
00135
00136 #endif // !defined(ZSTRING_H)


ZVector.h File Reference

Go to the source code of this file.

Classes

class | ZVector
class | ZScalarVector

Typedefs

typedef ZScalarVector< int > | IntVector

Typedef Documentation

typedef ZScalarVector<int> IntVector

Definition at line 266 of file ZVector.h.


ZVector.h

Go to the documentation of this file.
00001 #ifndef ZVECTOR_H
00002 #define ZVECTOR_H
00003
00004 #include "ZVectorNode.h"
00005 #include "ZPtrVectorNode.h"
00006 #include "ZScalarVectorNode.h"
00007
00008 template <class T> class ZVector {
00009 private:
00010                 T nullObject;
00011 public:
00019   ZVector(bool disableDelete=true):m_disableDelete(disableDelete)
00020   {
00021     nullObject = NULL;
00022     headNode = NULL;
00023     headNode = new ZVectorNode<T>(disableDelete);
00024
00025     currentNode = NULL;
00026     size = 0;
00027   };
00028
00029         // Destructor
00030         ~ZVector()
00031         {
00032                 ZVectorNode<T> *pointerToDelete, *pointer = headNode;
00033
00034                 while (pointer != NULL) {
00035                         pointerToDelete = pointer;
00036                         pointer = pointer->getNext();
00037                         delete pointerToDelete;
00038                 }
00039         };
00040
00045         T &operator[](int index){
00046
00047                 if (getSize() == 0) return nullObject;
00048
00049                 int rIndex = (getSize()-1) - index;
00050
00051                 if (rIndex < getSize())
00052                 {
00053                         start();
00054                         int i = 0;
00055                         while(next())   {
00056                                 if(i++ == rIndex) {
00057                                         return get();
00058                                 }
00059                         }
00060                 }
00061                 return nullObject;
00062         }
00063
00068         T &get(int index)
00069         {
00070                 return operator[](index);
00071         };
00072
00073
00078         T &get()
00079         {
00080                 if (currentNode == NULL)
00081                         start();
00082
00083                 if (currentNode == headNode)
00084                         next();
00085
00086                 return currentNode->get();
00087         };
00088
00089
00094         void add(T &addObject)
00095         {
00096                 ZVectorNode<T> *newNode = new ZPtrVectorNode<T>(m_disableDelete);
00097                 newNode->set(addObject);
00098
00099                 lastCurrentNode=currentNode;
00100                 currentNode=newNode;
00101
00102                 currentNode->setNext(headNode->getNext());
00103                 headNode->setNext(currentNode);
00104
00105                 size++;
00106         };
00107
00112         void remove()
00113         {
00114
00115                 lastCurrentNode->setNext(currentNode->getNext());
00116
00117                 delete currentNode;
00118
00119                 currentNode = lastCurrentNode;
00120
00121                 size--;
00122
00123                 // set headnode next ptr to null.
00124                 if(size<=0)
00125                         headNode->setNext(NULL);
00126
00127                 next();
00128         };
00129
00136         bool remove(T &remObject)
00137         {
00138                 start();
00139                 do{
00140                         if (get()==remObject){
00141                                 remove();
00142                                 return true;
00143                         }
00144                 }while(next());
00145
00146                 return false;
00147         };
00148
00157         bool contains(T &object)
00158         {
00159                 start();
00160                 do{
00161                         if (get()==object){
00162                                 return true;
00163                         }
00164                 }while(next());
00165
00166                 return false;
00167         };
00168
00169
00170
00178         void start()
00179         {
00180                 lastCurrentNode = headNode;
00181                 currentNode = headNode;
00182         };
00183
00191         bool next()
00192         {
00193                 // If the currentNode now points at nothing, we've reached the end
00194                 if (currentNode == NULL)
00195                         start();
00196
00197                 // Update the last node and current node
00198                 lastCurrentNode = currentNode;
00199                 currentNode = currentNode->getNext();
00200
00201                 // If currentNode points at nothing or there is nothing added, we can immediately return false
00202                 if (currentNode == NULL || size == 0)
00203                         return false;
00204                 else
00205                         return true;
00206         };
00207
00213         int getSize()const  { return size; };
00214
00220         void clear()
00221         {
00222                 start();
00223
00224                 next();
00225
00226
00227                 while(size > 0)
00228                         remove();
00229
00230
00231                 size = 0;
00232
00233                 //start();
00234         }
00235
00236 protected:
00237         int size;
00238         bool m_disableDelete;
00239         ZVectorNode<T> *headNode;
00240         ZVectorNode<T> *currentNode, *lastCurrentNode;
00241 };
00242
00243
00244 template <class T> class ZScalarVector : public ZVector<T> {
00245
00246 public:
00247     ZScalarVector () : ZVector<T>(false) {}
00248
00249         void add(T &addObject)
00250         {
00251                 ZVectorNode<T> *newNode = new ZScalarVectorNode<T>;
00252
00253                 newNode->set(addObject);
00254
00255                 lastCurrentNode=currentNode;
00256                 currentNode=newNode;
00257
00258                 currentNode->setNext(headNode->getNext());
00259                 headNode->setNext(currentNode);
00260
00261                 size++;
00262         };
00263
00264 };
00265
00266 typedef ZScalarVector<int> IntVector;
00267
00268
00269
00270 #endif


BaseServices Class Reference

BaseServices. More...

Inheritance diagram for BaseServices:

ZonaServices List of all members.

Public Member Functions

BaseServices (bool bMessageBuffering=true, bool bautoUpdate=true)
Constructor.

~BaseServices ()
Destructor.

int | login (char *dispatcherURL, char *clientName, char *password)
(BaseServices) Logs users onto the Zona service.

int | loginAsync (char *dispatcherURL, char *clientName, char *password)
(BaseServices) Logs users onto the Zona service asynchronously.

void | logoff ()
(BaseServices) Logs users off the Zona service, ending all services.

int | getLoginStatus ()
(BaseServices) Return the current login status.

int | sendGameStateMsg (char *stateData, short dataSize)
(BaseServices) Communicates game state events to the Zona game servers.

int | sendGameStateMsg (int entityId, char *stateData, short dataSize)
(BaseServices) Communicates game state events to the Zona game servers.

int | monitorGameState (GameStateCallback *callback)
(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

int | monitorEntityUpdates (EntityCallback *callback)
(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

int | subscribeToGameStateMsgs (int entityId, int msgFilters)
(BaseServices) Subscribes an entity to updates in game state from the Zona service.

int | getSessionId () const
(BaseServices) Get player session Id, which is assigned to the player upon login

const char * | getLoginName () const
(BaseServices) Get player name used for login

int | getCharacterId () const
(BaseServices) Returns the character id which was picked by the user.

ZonaClientCharacter * getCharacter ()
int | getMillsSinceLogin ()
(BaseServices) Get Milliseconds since the user logined in

int | getMillsSinceZGST ()
(BaseServices) Get Milliseconds since Zona Global Sync Time The ZGST is reset every day and its purpose is to allow for 4 byte timestamp that are valid for 24 hours

char * | getZAFVersion ()
(BaseServices) Returns pointer to string of current version of ZAF static lib Do not delete the string.

bool | setGameVersion (char *gameVersion, short size)
(BaseServices) This function gives the CAPI a client specified version string to track the current version of the client game code.

jlong | getGlobalServerLoginTime ()
(BaseServices) Get global server login time This is the last time the servers time was set to zero.

ZonaClientEntity * | getEntityWithId (int eid)
(BaseServices) Retrieve ZonaClientEntity from Entity Manager

int | getAllEntities (ZonaBaseEntityPtrVector *entityVecPtr)
(BaseServices) Fetches a list of all local entities(character and children) that have entered the game as well as all remote entities in the same sphere as the character and children from the Zona Entity Manager.

void | processMessage (int count=1)
If autoUpdate is false during the construction of ZonaServices, game code should call this method preferably in the game loop to process messages received from the network.

int | getMessageBufferCount ()
This method returns the count of pending incoming network messages that need to be processed.

Static Public Member Functions

int | a2w (const char *as, wchar_t *sBuf, int sBufSize)
(BaseServices) This function converts a 8bit based ASCII string to a wide character unicode string.

int | w2a (const wchar_t *ws, char *sBuf, int sBufSize)
(BaseServices) This function converts a wide character UNICODE string to 8 bit based ASCII string.

Protected Member Functions

virtual void | initializeServices ()

Protected Attributes

ZonaClient * | zonaClient
SessionIdManager * | sid
GameStateService * | gameStateService
ServiceState * | m_state
bool | m_autoUpdate
bool | m_messageBuffering
BaseBuffer * | _downcastBuffer

Detailed Description

BaseServices.

Provides lower level user services based on permissions and uses callbacks to comunicate the information.

Definition at line 55 of file BaseServices.h.

Constructor & Destructor Documentation

BaseServices | ( | bool | bMessageBuffering = true,
 |  | bool | bautoUpdate = true
 | ) |

Constructor.

~BaseServices ( )

Destructor.

Member Function Documentation

int login | ( | char * | dispatcherURL,
 |  | char * | clientName,
 |  | char * | password
 | ) |

(BaseServices) Logs users onto the Zona service.

Parameters:
dispatcherURL | URL of Dispatcher Must be in the form of http://MyDispatcher:port i.e. http://192.168.1.10:2000
clientName | player identification
password | validation of player identity
Returns:
ERR_NODATABASE, ERR_SUCCESS or ERR_LOGON_FAIL
See also:
ZonaErrors.h

int loginAsync | ( | char * | dispatcherURL,
 |  | char * | clientName,
 |  | char * | password
 | ) |

(BaseServices) Logs users onto the Zona service asynchronously.

The calling thread returns immediately. Status of login can be queried by calling getLoginStatus().

Parameters:
dispatcherURL | URL of Dispatcher Must be in the form of http://MyDispatcher:port i.e. http://192.168.1.10:2000
clientName | player identification
password | validation of player identity
Returns:
ERR_NODATABASE, ERR_SUCCESS or ERR_LOGON_FAIL
See also:
ZonaErrors.h

void logoff ( )

(BaseServices) Logs users off the Zona service, ending all services.

int getLoginStatus ( )

(BaseServices) Return the current login status.

Used for asynchronous login.

Returns:
NOT_LOGGED_IN, LOGGED_IN, LOGIN_IN_PROGRESS, LOGOUT_IN_PROGRESS, LOGIN_FAIL_NODATABASE, LOGIN_FAIL_WRONG_PASS

int sendGameStateMsg | ( | char * | stateData,
 |  | short | dataSize
 | ) |

(BaseServices) Communicates game state events to the Zona game servers.

It may also be used for communicating changes in the state of dynamic game objects in special cases, specifically where setting the character properties will not apply.

Parameters:
stateData | a pointer to an arbitrary data structure holding entity state information
dataSize | the length, in bytes, of the data pointed to stateData
Returns:
ERR_SUCCESS upon successful transmission of the game state information

ERR_MESSAGE_SEND upon failure to transmit game state information.

int sendGameStateMsg | ( | int | entityId,
 |  | char * | stateData,
 |  | short | dataSize
 | ) |

(BaseServices) Communicates game state events to the Zona game servers.

It may also be used for communicating changes in the state of dynamic game objects in special cases, specifically where setting the entity properties will not apply.

Parameters:
entityId | id of the entity whose game state is being sent
stateData | a pointer to an arbitrary data structure holding entity state information
dataSize | the length, in bytes, of the data pointed to stateData
Returns:
ERR_SUCCESS upon successful transmission of the game state information

ERR_MESSAGE_SEND upon failure to transmit game state information.

int monitorGameState ( GameStateCallback * callback )

(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

Parameters:
callback Implemented callback class pointer for GameStateCallback
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int monitorEntityUpdates ( EntityCallback * callback )

(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

Parameters:
callback Implemented callback class pointer for EntityCallback
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int subscribeToGameStateMsgs | ( | int | entityId,
 |  | int | msgFilters
 | ) |

(BaseServices) Subscribes an entity to updates in game state from the Zona service.

Must be called at least once for each entity to receive any messages on behalf of the entity

Parameters:
entityId | Id of the entity that should start receiving state update information
msgFilters | subscribes to messages specified in the msgFilters, use one of ZONA_MSG_*
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int getSessionId ( ) const

(BaseServices) Get player session Id, which is assigned to the player upon login

Returns:
player session Id

const char* getLoginName ( ) const

(BaseServices) Get player name used for login

Returns:
user name

int getCharacterId ( ) const

(BaseServices) Returns the character id which was picked by the user.

If this function is called before pickCharacter() is called, it returns 0;

ZonaClientCharacter* getCharacter ( )

int getMillsSinceLogin ( )

(BaseServices) Get Milliseconds since the user logined in

Returns:
number of mills since login

int getMillsSinceZGST ( )

(BaseServices) Get Milliseconds since Zona Global Sync Time The ZGST is reset every day and its purpose is to allow for 4 byte timestamp that are valid for 24 hours

Returns:
number of mills since login

char* getZAFVersion ( )

(BaseServices) Returns pointer to string of current version of ZAF static lib Do not delete the string.

Returns:
Version of Zona Application Framework

bool setGameVersion | ( | char * | gameVersion,
 |  | short | size
 | ) |

(BaseServices) This function gives the CAPI a client specified version string to track the current version of the client game code.

This function MUST be called before login can be called. The server plugin must validate this game specific version string. If the client game version does not match the server plugin the client must upgraded before being able to log on successfully.

Parameters:
gameVersion | string of client game code version validated by server plugin before successful login (size can be upto MAX_INI_BUFFER defined in ZonaGlobalConstants.h 8-bit char ASCII string)
size | Size of the gameVersion
Returns:
void

jlong getGlobalServerLoginTime ( )

(BaseServices) Get global server login time This is the last time the servers time was set to zero.

This allows getMillsSinceZGST to return mills since ZGST. Given a known zero point allows time stamps to be a smaller value. The getMillsSinceZGST returns a 32 bit value at millisecond accuracy. Note: These time stamps should not be used for long term time stamps. Use the OS full 64 bit time stamps for time stamps that will need to date data for more than 24 hours. This function is designed for use of prediction algorithms that require a syncronized time stamp between clients.

Returns:
global server time when login

ZonaClientEntity* getEntityWithId ( int eid )

(BaseServices) Retrieve ZonaClientEntity from Entity Manager

Parameters:
eid entity ID
Returns:
a pointer to ZonaClientEntity if found, otherwise NULL.

int getAllEntities ( ZonaBaseEntityPtrVector * entityVecPtr )

(BaseServices) Fetches a list of all local entities(character and children) that have entered the game as well as all remote entities in the same sphere as the character and children from the Zona Entity Manager.

The function returns a count of all such entities. This call is executed locally and does not access the server. The references to entities are not guaranteed to be legal for remote entities after the call is returned.

This method will be deprecated in the future.

Parameters:
entityVecPtr A vector holding pointers to ZonaBaseEntity
Returns:
total number of entities

int a2w | ( | const char * | as,
 |  | wchar_t * | sBuf,
 |  | int | sBufSize
 | ) | [static]

(BaseServices) This function converts a 8bit based ASCII string to a wide character unicode string.

Call this function once with a value of a sBufSize=0 to get size of buffer the user should create to get copied into. Then allocate memory for the UNICODE buffer and call function again to fill buffer.

Returns:
The size of the buffer copied or size of buffer needed A zero value indicated error

int w2a | ( | const wchar_t * | ws,
 |  | char * | sBuf,
 |  | int | sBufSize
 | ) | [static]

(BaseServices) This function converts a wide character UNICODE string to 8 bit based ASCII string.

Call this function once with a value of a sBufSize=0 to get size of buffer user should create to get copied into. Then allocate memory for the ASCII buffer and call function again to fill buffer.

Returns:
The size of the buffer copied or size of buffer needed A zero value indicated error

void processMessage ( int count = 1 )

If autoUpdate is false during the construction of ZonaServices, game code should call this method preferably in the game loop to process messages received from the network.

Parameters:
count The number of messages to flush from the inbound message buffer . @ The default value is 1.
Returns:
void

int getMessageBufferCount ( )

This method returns the count of pending incoming network messages that need to be processed.

This method is typically used when client specifies the autoUpdate parameter as false in the ZonaServices constructor

Returns:
The number of pending messages in the inbound message buffer .

virtual void initializeServices ( ) [protected, virtual]

Reimplemented in ZonaServices.

Member Data Documentation

ZonaClient* zonaClient [protected]

Definition at line 346 of file BaseServices.h.

SessionIdManager* sid [protected]

Definition at line 347 of file BaseServices.h.

GameStateService* gameStateService [protected]

Definition at line 348 of file BaseServices.h.

ServiceState* m_state [protected]

Definition at line 349 of file BaseServices.h.

bool m_autoUpdate [protected]

Definition at line 350 of file BaseServices.h.

bool m_messageBuffering [protected]

Definition at line 351 of file BaseServices.h.

BaseBuffer* _downcastBuffer [protected]

Definition at line 352 of file BaseServices.h.

The documentation for this class was generated from the following file:
  • BaseServices.h


BaseServices Member List

This is the complete list of members for BaseServices, including all inherited members.
_downcastBuffer | BaseServices | [protected]
a2w(const char *as, wchar_t *sBuf, int sBufSize) | BaseServices | [static]
BaseServices(bool bMessageBuffering=true, bool bautoUpdate=true) | BaseServices |
gameStateService | BaseServices | [protected]
getAllEntities(ZonaBaseEntityPtrVector *entityVecPtr) | BaseServices |
getCharacter() | BaseServices |
getCharacterId() const | BaseServices |
getEntityWithId(int eid) | BaseServices |
getGlobalServerLoginTime() | BaseServices |
getLoginName() const | BaseServices |
getLoginStatus() | BaseServices |
getMessageBufferCount() | BaseServices |
getMillsSinceLogin() | BaseServices |
getMillsSinceZGST() | BaseServices |
getSessionId() const | BaseServices |
getZAFVersion() | BaseServices |
initializeServices() | BaseServices | [protected, virtual]
login(char *dispatcherURL, char *clientName, char *password) | BaseServices |
loginAsync(char *dispatcherURL, char *clientName, char *password) | BaseServices |
logoff() | BaseServices |
m_autoUpdate | BaseServices | [protected]
m_messageBuffering | BaseServices | [protected]
m_state | BaseServices | [protected]
monitorEntityUpdates(EntityCallback *callback) | BaseServices |
monitorGameState(GameStateCallback *callback) | BaseServices |
processMessage(int count=1) | BaseServices |
sendGameStateMsg(char *stateData, short dataSize) | BaseServices |
sendGameStateMsg(int entityId, char *stateData, short dataSize) | BaseServices |
setGameVersion(char *gameVersion, short size) | BaseServices |
sid | BaseServices | [protected]
subscribeToGameStateMsgs(int entityId, int msgFilters) | BaseServices |
w2a(const wchar_t *ws, char *sBuf, int sBufSize) | BaseServices | [static]
zonaClient | BaseServices | [protected]
~BaseServices() | BaseServices |


Callback Class Reference

Base class for all callbacks. More...

Inheritance diagram for Callback:

ChatCallback EntityCallback GameGuildCallback GameStateCallback GuildCallback List of all members.

Public Member Functions

virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Detailed Description

Base class for all callbacks.

Definition at line 10 of file Callback.h.

Member Function Documentation

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • Callback.h


Callback Member List

This is the complete list of members for Callback, including all inherited members.
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]


ChatCallback Class Reference

Provides a service to recive chat messages for the sphere. More...

Inheritance diagram for ChatCallback:

Callback List of all members.

Public Member Functions

ChatCallback ()
Constructor.

~ChatCallback ()
Destructor.

virtual void | onReceiveChat (ChatMsg *msg)=0
Called by Zona Services with chat messages from other players.

virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Detailed Description

Provides a service to recive chat messages for the sphere.

Developers extend this abstract class and register their derived class with ZonaServices to receive updates on the player's sphere.

Definition at line 40 of file ChatCallBack.h.

Constructor & Destructor Documentation

ChatCallback ( )

Constructor.

~ChatCallback ( )

Destructor.

Member Function Documentation

virtual void onReceiveChat ( ChatMsg * msg ) [pure virtual]

Called by Zona Services with chat messages from other players.

The called function is not responsible for freeing msg.

Parameters:
msg The received message

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual, inherited]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • ChatCallBack.h


ChatCallback Member List

This is the complete list of members for ChatCallback, including all inherited members.
ChatCallback() | ChatCallback |
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
onReceiveChat(ChatMsg *msg)=0 | ChatCallback | [pure virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]
~ChatCallback() | ChatCallback |


ChatMsg Class Reference

ChatMsg. More...

List of all members.

Public Types

enum MailFlags {
FLAG_UNDOWNLOADED = 1,
FLAG_UNREAD = 2,
FLAG_DELETED = 4,
FLAG_REPLIED = 8
}
Possible bits that can be set in the flag variable. More...

enum SpecialRecipients {
RECIPIENT_ID_SPHERE = -1,
RECIPIENT_ID_SYSTEMWIDE = -2,
RECIPIENT_ID_BY_NAME = -3
}
Special recipients. More...

Public Member Functions

ChatMsg ()
ChatMsg (int recipId, unsigned char intensityLevel, char *msgBody)
virtual | ~ChatMsg ()

Public Attributes

LONG64 | date
The date this message has been sent.

int | flag
A bit field specifying the status of the message. see MailFlags.

int | senderId
The id of the character that sent the message.

int | recipientId
Optional id of the guild or character that should receive this message.

char * | toCharacterName
Optional recipent's character name.

char * | subject
The subject of the message.

char * | body
The body of the message.

unsigned char | intensity
int | recipientProperties
int | id

Protected Member Functions

void | init (int recipId, char *toCharacterName, unsigned char intensityLevel, char *msgBody)

Detailed Description

ChatMsg.

A Persistent Zona mail message which can be sent by characters to other characters or guilds. It is streamable in the usual way. If the message is sent to the server, the server verifies that the recipient exists, and automatically sets certain variables such as date, sender, and some flag bits.

See also:
ZonaServices.

Definition at line 18 of file ChatMsg.h.

Member Enumeration Documentation

enum MailFlags

Possible bits that can be set in the flag variable.

They are useful when fetching emails.

Enumeration values:
FLAG_UNDOWNLOADED | If set, this message has not yet been downloaded.
FLAG_UNREAD | If set, this message has not yet been read.
FLAG_DELETED | If set, this message has been deleted.
FLAG_REPLIED | If set, this message has been replied to.

Definition at line 29 of file ChatMsg.h.

enum SpecialRecipients

Special recipients.

If the ChatMsg.recipientId may also be set to one of the values below, in addition to guild and character ids.

Enumeration values:
RECIPIENT_ID_SPHERE
RECIPIENT_ID_SYSTEMWIDE
RECIPIENT_ID_BY_NAME

Definition at line 39 of file ChatMsg.h.

Constructor & Destructor Documentation

ChatMsg ( )

ChatMsg | ( | int | recipId,
 |  | unsigned char | intensityLevel,
 |  | char * | msgBody
 | ) |

virtual ~ChatMsg ( ) [virtual]

Member Function Documentation

void init | ( | int | recipId,
 |  | char * | toCharacterName,
 |  | unsigned char | intensityLevel,
 |  | char * | msgBody
 | ) | [protected]

Member Data Documentation

LONG64 date

The date this message has been sent.

Definition at line 54 of file ChatMsg.h.

int flag

A bit field specifying the status of the message. see MailFlags.

Definition at line 55 of file ChatMsg.h.

int senderId

The id of the character that sent the message.

Definition at line 56 of file ChatMsg.h.

int recipientId

Optional id of the guild or character that should receive this message.

Definition at line 57 of file ChatMsg.h.

char* toCharacterName

Optional recipent's character name.

Definition at line 58 of file ChatMsg.h.

char* subject

The subject of the message.

Definition at line 59 of file ChatMsg.h.

char* body

The body of the message.

Definition at line 60 of file ChatMsg.h.

unsigned char intensity

Definition at line 61 of file ChatMsg.h.

int recipientProperties

Definition at line 62 of file ChatMsg.h.

int id

Definition at line 63 of file ChatMsg.h.

The documentation for this class was generated from the following file:
  • ChatMsg.h


ChatMsg Member List

This is the complete list of members for ChatMsg, including all inherited members.
body | ChatMsg |
ChatMsg() | ChatMsg |
ChatMsg(int recipId, unsigned char intensityLevel, char *msgBody) | ChatMsg |
date | ChatMsg |
flag | ChatMsg |
FLAG_DELETED enum value | ChatMsg |
FLAG_REPLIED enum value | ChatMsg |
FLAG_UNDOWNLOADED enum value | ChatMsg |
FLAG_UNREAD enum value | ChatMsg |
id | ChatMsg |
init(int recipId, char *toCharacterName, unsigned char intensityLevel, char *msgBody) | ChatMsg | [protected]
intensity | ChatMsg |
MailFlags enum name | ChatMsg |
RECIPIENT_ID_BY_NAME enum value | ChatMsg |
RECIPIENT_ID_SPHERE enum value | ChatMsg |
RECIPIENT_ID_SYSTEMWIDE enum value | ChatMsg |
recipientId | ChatMsg |
recipientProperties | ChatMsg |
senderId | ChatMsg |
SpecialRecipients enum name | ChatMsg |
subject | ChatMsg |
toCharacterName | ChatMsg |
~ChatMsg() | ChatMsg | [virtual]


EntityCallback Class Reference

EntityCallback. More...

Inheritance diagram for EntityCallback:

Callback List of all members.

Public Member Functions

EntityCallback ()
Constructor.

~EntityCallback ()
Destructor.

virtual void | onNotifyEntityPropertyUpdate (ZonaClientEntity *zce)
Called by Zona Services to notify the update of ZonaClientEnity's property.

virtual void | onNotifyEntityParentChange (ZonaClientEntity *zce)
Called by Zona Services to notify the update of an Entities owner.

virtual void | onNotifyEntityJoinedSphere (ZonaClientEntity *zce)
Called by the Zona Services to notify that an entity joined Sphere A local remote entity will instantiated of type ZonaClientEntity and and added to the CAPI's internal entity manager.

virtual void | onNotifyEntityDepartedSphere (ZonaClientEntity *zce)
Called by the Zona Services to notify that an entity departed Sphere.

virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Detailed Description

EntityCallback.

Provides a service to receive updates to the game state.

Developers extend this abstract class and register their derived class with ZonaServices to receive updates on the game state.

Definition at line 42 of file EntityCallback.h.

Constructor & Destructor Documentation

EntityCallback ( )

Constructor.

~EntityCallback ( )

Destructor.

Member Function Documentation

virtual void onNotifyEntityPropertyUpdate ( ZonaClientEntity * zce ) [virtual]

Called by Zona Services to notify the update of ZonaClientEnity's property.

Parameters:
zce Pointer to ZonaClientEntity whose property has updated.

virtual void onNotifyEntityParentChange ( ZonaClientEntity * zce ) [virtual]

Called by Zona Services to notify the update of an Entities owner.

Parameters:
zce Pointer to ZonaClientEntity whose property has updated.

virtual void onNotifyEntityJoinedSphere ( ZonaClientEntity * zce ) [virtual]

Called by the Zona Services to notify that an entity joined Sphere A local remote entity will instantiated of type ZonaClientEntity and and added to the CAPI's internal entity manager.

The entity can be retrevied by getEntityWithId(...). Before instantiating the client entity object, CAPI first calls onCreateNewClientEntity(...). If the method return NULL, then CAPI will create an instance of ZonaClientEntity. This object is automatically deleted by CAPI after onEntityDepartedSphere call returns from the client implementation.

Parameters:
zce pointer to ZonaClientEntity, which is created by CAPI and added to Zona Entity Manager before the callback. Zce always points to instance of ZonaClientEntity even for character entities entering the sphere. Hence, ZonaCharacterEntity specific methods should not be invoked on the passed in object.

virtual void onNotifyEntityDepartedSphere ( ZonaClientEntity * zce ) [virtual]

Called by the Zona Services to notify that an entity departed Sphere.

Upon returning from the client implementation of this callback, the departed entity will be deleted from the local cache and can no longer be accessible by game code.

Parameters:
zce Pointer to the ZonaClientEntity that has left the sphere

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual, inherited]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • EntityCallback.h


EntityCallback Member List

This is the complete list of members for EntityCallback, including all inherited members.
EntityCallback() | EntityCallback |
onNotifyEntityDepartedSphere(ZonaClientEntity *zce) | EntityCallback | [virtual]
onNotifyEntityJoinedSphere(ZonaClientEntity *zce) | EntityCallback | [virtual]
onNotifyEntityParentChange(ZonaClientEntity *zce) | EntityCallback | [virtual]
onNotifyEntityPropertyUpdate(ZonaClientEntity *zce) | EntityCallback | [virtual]
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]
~EntityCallback() | EntityCallback |


GameGuildCallback Class Reference

Inheritance diagram for GameGuildCallback:

Callback List of all members.

Public Member Functions

GameGuildCallback ()
Constructor.

~GameGuildCallback ()
Destructor.

virtual void | onAddGuild (ZonaClientGuild *guild)=0
virtual void | onRemoveGuild (ZonaClientGuild *guild)=0
virtual void | onMemberJoinGuild (ZonaClientGuildMembership *aShip)=0
virtual void | onMemberLeaveGuild (ZonaClientGuildMembership *aShip)=0
virtual void | onMemberEnterGuild (ZonaClientGuildMembership *aShip)=0
virtual void | onMemberExitGuild (ZonaClientGuildMembership *aShip)=0
virtual void | onAddModerator (int guildId, int moderatorId)=0
virtual void | onRemoveModerator (int guildId, int moderatorId)=0
virtual void | onGuildInvite (int guildId, int inviterId, int inviteeId)=0
virtual void | onGuildGameState (int guildId, char *state, int stateLength, int entityId)=0
virtual void | onGuildEntityUpdate (int guildId, ZonaClientEntity *zce)=0
virtual void | onGuildChatMessage (ZonaGuildChatMsg *msg)=0
virtual void | onGuildErrorMessage (int errorId, int guildId, int operationId, int entityId)=0
virtual void | onGuildPropertyUpdate (ZonaClientGuild *guild)=0
virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Constructor & Destructor Documentation

GameGuildCallback ( )

Constructor.

~GameGuildCallback ( )

Destructor.

Member Function Documentation

virtual void onAddGuild ( ZonaClientGuild * guild ) [pure virtual]

virtual void onRemoveGuild ( ZonaClientGuild * guild ) [pure virtual]

virtual void onMemberJoinGuild ( ZonaClientGuildMembership * aShip ) [pure virtual]

virtual void onMemberLeaveGuild ( ZonaClientGuildMembership * aShip ) [pure virtual]

virtual void onMemberEnterGuild ( ZonaClientGuildMembership * aShip ) [pure virtual]

virtual void onMemberExitGuild ( ZonaClientGuildMembership * aShip ) [pure virtual]

virtual void onAddModerator | ( | int | guildId,
 |  | int | moderatorId
 | ) | [pure virtual]

virtual void onRemoveModerator | ( | int | guildId,
 |  | int | moderatorId
 | ) | [pure virtual]

virtual void onGuildInvite | ( | int | guildId,
 |  | int | inviterId,
 |  | int | inviteeId
 | ) | [pure virtual]

virtual void onGuildGameState | ( | int | guildId,
 |  | char * | state,
 |  | int | stateLength,
 |  | int | entityId
 | ) | [pure virtual]

virtual void onGuildEntityUpdate | ( | int | guildId,
 |  | ZonaClientEntity * | zce
 | ) | [pure virtual]

virtual void onGuildChatMessage ( ZonaGuildChatMsg * msg ) [pure virtual]

virtual void onGuildErrorMessage | ( | int | errorId,
 |  | int | guildId,
 |  | int | operationId,
 |  | int | entityId
 | ) | [pure virtual]

virtual void onGuildPropertyUpdate ( ZonaClientGuild * guild ) [pure virtual]

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual, inherited]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • GameGuildCallback.h


GameGuildCallback Member List

This is the complete list of members for GameGuildCallback, including all inherited members.
GameGuildCallback() | GameGuildCallback |
onAddGuild(ZonaClientGuild *guild)=0 | GameGuildCallback | [pure virtual]
onAddModerator(int guildId, int moderatorId)=0 | GameGuildCallback | [pure virtual]
onGuildChatMessage(ZonaGuildChatMsg *msg)=0 | GameGuildCallback | [pure virtual]
onGuildEntityUpdate(int guildId, ZonaClientEntity *zce)=0 | GameGuildCallback | [pure virtual]
onGuildErrorMessage(int errorId, int guildId, int operationId, int entityId)=0 | GameGuildCallback | [pure virtual]
onGuildGameState(int guildId, char *state, int stateLength, int entityId)=0 | GameGuildCallback | [pure virtual]
onGuildInvite(int guildId, int inviterId, int inviteeId)=0 | GameGuildCallback | [pure virtual]
onGuildPropertyUpdate(ZonaClientGuild *guild)=0 | GameGuildCallback | [pure virtual]
onMemberEnterGuild(ZonaClientGuildMembership *aShip)=0 | GameGuildCallback | [pure virtual]
onMemberExitGuild(ZonaClientGuildMembership *aShip)=0 | GameGuildCallback | [pure virtual]
onMemberJoinGuild(ZonaClientGuildMembership *aShip)=0 | GameGuildCallback | [pure virtual]
onMemberLeaveGuild(ZonaClientGuildMembership *aShip)=0 | GameGuildCallback | [pure virtual]
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
onRemoveGuild(ZonaClientGuild *guild)=0 | GameGuildCallback | [pure virtual]
onRemoveModerator(int guildId, int moderatorId)=0 | GameGuildCallback | [pure virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]
~GameGuildCallback() | GameGuildCallback |


GameGuildServiceInterface Class Reference

List of all members.

Public Member Functions

GameGuildServiceInterface ()
virtual | ~GameGuildServiceInterface ()
virtual int | createGuild (ZonaClientGuild *guild, int entityId)=0
Creates a new Guild in the game.

virtual int | deleteGuild (ZonaClientGuild *guild, int entityId)=0
Deletes the specified Game Guild.

virtual int | requestMemberGuilds (int entityId)=0
Request to fetch the specified entities member guilds.

virtual int | joinGuild (short guildClassId, int guildId, int entityId)=0
Request to join the specified guild.

virtual int | leaveGuild (int guildId, int entityId)=0
Request to leave the specified guild.

virtual int | enterGuild (short guildClassId, int guildId, int entityId)=0
Request to enter the specified guild.

virtual int | exitGuild (int guildId, int entityId)=0
Request to exit the specified guild.

virtual int | inviteMember (int guildId, int inviteeId, int inviterId)=0
Request to invite another entity to join the specified guild.

virtual int | removeMember (int guildId, int targetEntityId, int memberId)=0
Request to remove existing member from the guild.

virtual int | monitorGuildMessage (GameGuildCallback *guildCallback)=0
Set a callback for listening to guild messages.

virtual int | stopMonitorGuildMessage ()=0
Stop listening to guild messages.

virtual int | addGuildModerator (int guildId, int entityId, int moderatorEntityId)=0
Request to add moderator to guild.

virtual int | removeGuildModerator (int guildId, int entityId, int moderatorEntityId)=0
Request to remove moderator from guild.

virtual int | sendChatMessage (ZonaGuildChatMsg *aMsg)=0
Send a chat message to the guild.

virtual int | sendGuildGameState (int guildId, int entityId, char *state, int stateLen)=0
Send a game state message to a guild.

virtual int | publishEntityPropertyUpdates (int guildId, int entityId)=0
Send entity Updates to a guild.

virtual ZonaClientGuild * | getGameGuild (int guildId)=0
Fetch an instance of a GameGuild.

virtual int | fetchMemberGuilds (int entityId, ZonaClientGuildPtrVector &gpv)=0
Fetch the all guilds of which the specified entity is the member.

virtual int | fetchAccessibleGuilds (int entityId, ZonaClientGuildPtrVector &gpv)=0
Fetch the all guilds to which the specified entity can access.

virtual int | fetchGuildMembers (short classId, int guildId, int entityId, ZonaClientEntityPtrVector &epv)=0
Fetch a list of the members for the specified guild.

virtual int | fetchZonaGuildChatMessages (int guildId, INT64 minDate, INT64 maxDate, ZonaGuildChatMsgPtrVector &msgs)=0
Fetch the ZonaGuildChatMsg messages whose attribute of the guild is persistent message.

Constructor & Destructor Documentation

GameGuildServiceInterface ( ) [inline]

Definition at line 22 of file GameGuildServiceInterface.h.

virtual ~GameGuildServiceInterface ( ) [inline, virtual]

Definition at line 24 of file GameGuildServiceInterface.h.

Member Function Documentation

virtual int createGuild | ( | ZonaClientGuild * | guild,
 |  | int | entityId
 | ) | [pure virtual]

Creates a new Guild in the game.

Parameters:
guild | The guild to be created. If the call is successful, the server fires an Add Guild notification for the guild created.
entityId | The entity that has requested the guild to be created.
Returns:
ERROR CODE

virtual int deleteGuild | ( | ZonaClientGuild * | guild,
 |  | int | entityId
 | ) | [pure virtual]

Deletes the specified Game Guild.

Parameters:
guild | The guild to be deleted. If the call is successful, the server fires a Remove Guild notification for the guild.
entityId | The entity that has requested the guild to be deleted.
Returns:
ERROR CODE

virtual int requestMemberGuilds ( int entityId ) [pure virtual]

Request to fetch the specified entities member guilds.

The information is retrieved aynchronously through guild callbacks

Parameters:
entityId The entity that has requested the information about its member guilds.
Returns:
ERROR CODE

virtual int joinGuild | ( | short | guildClassId,
 |  | int | guildId,
 |  | int | entityId
 | ) | [pure virtual]

Request to join the specified guild.

Parameters:
guildClassId | The class id of the guild that the entity wishes to join.
guildId | The id of the guild that the entity wishes to join.
entityId | The entity that has requested to join the guild.
Returns:
ERROR CODE

virtual int leaveGuild | ( | int | guildId,
 |  | int | entityId
 | ) | [pure virtual]

Request to leave the specified guild.

Parameters:
guildId | The id of the guild that the entity wishes to leave.
entityId | The entity that has requested to leave the guild.
Returns:
ERROR CODE

virtual int enterGuild | ( | short | guildClassId,
 |  | int | guildId,
 |  | int | entityId
 | ) | [pure virtual]

Request to enter the specified guild.

Parameters:
guildClassId | The class id of the guild that the entity wishes to enter.
guildId | The id of the guild that the entity wishes to enter.
entityId | The entity that has requested to enter the guild.
Returns:
ERROR CODE

virtual int exitGuild | ( | int | guildId,
 |  | int | entityId
 | ) | [pure virtual]

Request to exit the specified guild.

Parameters:
guildId | The id of the guild that the entity wishes to exit.
entityId | The entity that has requested to exit the guild.
Returns:
ERROR CODE

virtual int inviteMember | ( | int | guildId,
 |  | int | inviteeId,
 |  | int | inviterId
 | ) | [pure virtual]

Request to invite another entity to join the specified guild.

Parameters:
guildId | The id of the guild.
inviteeId | The entity acting as the invitee.
inviterId | The entity acting as the inviter.
Returns:
ERROR CODE

virtual int removeMember | ( | int | guildId,
 |  | int | targetEntityId,
 |  | int | memberId
 | ) | [pure virtual]

Request to remove existing member from the guild.

Parameters:
guildId | The id of the guild.
targetEntityId | The entity to be removed.
memberId | The entity that has requested the remove.
Returns:
ERROR CODE

virtual int monitorGuildMessage ( GameGuildCallback * guildCallback ) [pure virtual]

Set a callback for listening to guild messages.

Parameters:
guildCallback Callback object set by the client
Returns:
ERROR CODE

virtual int stopMonitorGuildMessage ( ) [pure virtual]

Stop listening to guild messages.

Returns:
ERROR CODE

virtual int addGuildModerator | ( | int | guildId,
 |  | int | entityId,
 |  | int | moderatorEntityId
 | ) | [pure virtual]

Request to add moderator to guild.

Parameters:
guildId | The id of the guild.
entityId | The entity that has requested to add moderator.
moderatorEntityId | The entity to be set as moderator.
Returns:
ERROR CODE

virtual int removeGuildModerator | ( | int | guildId,
 |  | int | entityId,
 |  | int | moderatorEntityId
 | ) | [pure virtual]

Request to remove moderator from guild.

Parameters:
guildId | The id of the guild.
entityId | The entity that has requested to remove moderator.
moderatorEntityId | The entity to be unset as moderator.
Returns:
ERROR CODE

virtual int sendChatMessage ( ZonaGuildChatMsg * aMsg ) [pure virtual]

Send a chat message to the guild.

Parameters:
aMsg A chat message object.
Returns:
ERROR CODE

virtual int sendGuildGameState | ( | int | guildId,
 |  | int | entityId,
 |  | char * | state,
 |  | int | stateLen
 | ) | [pure virtual]

Send a game state message to a guild.

Parameters:
guildId | The id of the guild.
entityId | The id of the entity sending the state
state | The pointer to guild game state.
stateLen | The length of the state packet.
Returns:
ERROR CODE

virtual int publishEntityPropertyUpdates | ( | int | guildId,
 |  | int | entityId
 | ) | [pure virtual]

Send entity Updates to a guild.

Parameters:
guildId | The id of the guild.
entityId | The id of the entity for propertyupdate
Returns:
ERROR CODE

virtual ZonaClientGuild* getGameGuild ( int guildId ) [pure virtual]

Fetch an instance of a GameGuild.

Parameters:
guildId The id of the guild to be fetched.
Returns:
The pointer to a GameGuild object. NULL if guild does not exist.

virtual int fetchMemberGuilds | ( | int | entityId,
 |  | ZonaClientGuildPtrVector & | gpv
 | ) | [pure virtual]

Fetch the all guilds of which the specified entity is the member.

Parameters:
entityId | The id of the member entity
gpv | The vector of ZonaClientGuild that contains the guilds
Returns:
ERROR CODE

virtual int fetchAccessibleGuilds | ( | int | entityId,
 |  | ZonaClientGuildPtrVector & | gpv
 | ) | [pure virtual]

Fetch the all guilds to which the specified entity can access.

i.e. a list of the guilds whose attribute is SELF_INVITE

Parameters:
entityId | The id of the member entity
gpv | The vector of ZonaClientGuild that contains the guilds
Returns:
ERROR CODE

virtual int fetchGuildMembers | ( | short | classId,
 |  | int | guildId,
 |  | int | entityId,
 |  | ZonaClientEntityPtrVector & | epv
 | ) | [pure virtual]

Fetch a list of the members for the specified guild.

Parameters:
classId | The class id of the Guild
guildId | The id of the Guild
entityId | The id of the entity requesting the operation
epv | The vector of ZonaClientEntity that contains the member entities for the Guild
Returns:
ERROR CODE

virtual int fetchZonaGuildChatMessages | ( | int | guildId,
 |  | INT64 | minDate,
 |  | INT64 | maxDate,
 |  | ZonaGuildChatMsgPtrVector & | msgs
 | ) | [pure virtual]

Fetch the ZonaGuildChatMsg messages whose attribute of the guild is persistent message.

Parameters:
guildId | The id of the guild.
minDate | an optional minimum sent date filter. The parameter is the number of seconds elapsed since midnight, 1/1/1970, as defined by the time() function. Default is midnight, 1/1/1970.
maxDate | an optional maximum sent date filter. The parameter is the number of seconds elapsed since midnight, 1/1/1970, as defined by the time() function. Default is now, the value returned by the time() function.
msgs | The returned Zona chat message objects.
Returns:
ERROR CODE

The documentation for this class was generated from the following file:
  • GameGuildServiceInterface.h


GameGuildServiceInterface Member List

This is the complete list of members for GameGuildServiceInterface, including all inherited members.
addGuildModerator(int guildId, int entityId, int moderatorEntityId)=0 | GameGuildServiceInterface | [pure virtual]
createGuild(ZonaClientGuild *guild, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
deleteGuild(ZonaClientGuild *guild, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
enterGuild(short guildClassId, int guildId, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
exitGuild(int guildId, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
fetchAccessibleGuilds(int entityId, ZonaClientGuildPtrVector &gpv)=0 | GameGuildServiceInterface | [pure virtual]
fetchGuildMembers(short classId, int guildId, int entityId, ZonaClientEntityPtrVector &epv)=0 | GameGuildServiceInterface | [pure virtual]
fetchMemberGuilds(int entityId, ZonaClientGuildPtrVector &gpv)=0 | GameGuildServiceInterface | [pure virtual]
fetchZonaGuildChatMessages(int guildId, INT64 minDate, INT64 maxDate, ZonaGuildChatMsgPtrVector &msgs)=0 | GameGuildServiceInterface | [pure virtual]
GameGuildServiceInterface() | GameGuildServiceInterface | [inline]
getGameGuild(int guildId)=0 | GameGuildServiceInterface | [pure virtual]
inviteMember(int guildId, int inviteeId, int inviterId)=0 | GameGuildServiceInterface | [pure virtual]
joinGuild(short guildClassId, int guildId, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
leaveGuild(int guildId, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
monitorGuildMessage(GameGuildCallback *guildCallback)=0 | GameGuildServiceInterface | [pure virtual]
publishEntityPropertyUpdates(int guildId, int entityId)=0 | GameGuildServiceInterface | [pure virtual]
removeGuildModerator(int guildId, int entityId, int moderatorEntityId)=0 | GameGuildServiceInterface | [pure virtual]
removeMember(int guildId, int targetEntityId, int memberId)=0 | GameGuildServiceInterface | [pure virtual]
requestMemberGuilds(int entityId)=0 | GameGuildServiceInterface | [pure virtual]
sendChatMessage(ZonaGuildChatMsg *aMsg)=0 | GameGuildServiceInterface | [pure virtual]
sendGuildGameState(int guildId, int entityId, char *state, int stateLen)=0 | GameGuildServiceInterface | [pure virtual]
stopMonitorGuildMessage()=0 | GameGuildServiceInterface | [pure virtual]
~GameGuildServiceInterface() | GameGuildServiceInterface | [inline, virtual]


GameStateCallback Class Reference

GameStateCallback. More...

Inheritance diagram for GameStateCallback:

Callback List of all members.

Public Member Functions

GameStateCallback ()
Constructor.

~GameStateCallback ()
Destructor.

virtual void | onReceivedGameStateMsg (int entityId, char *stateData, short dataSize)=0
Called by Zona Services and contains updates to the game state.

virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Detailed Description

GameStateCallback.

Provides a service to receive updates to the game state.

Developers extend this abstract class and register their derived class with ZonaServices to receive updates on the game state.

Definition at line 41 of file GameStateCallback.h.

Constructor & Destructor Documentation

GameStateCallback ( )

Constructor.

~GameStateCallback ( )

Destructor.

Member Function Documentation

virtual void onReceivedGameStateMsg | ( | int | entityId,
 |  | char * | stateData,
 |  | short | dataSize
 | ) | [pure virtual]

Called by Zona Services and contains updates to the game state.

Parameters:
entityId | EntityId for the gamestate. Note: Entityid will be -1 for received msgs that are published by server via publishGameStateMsgInSphere(...).
stateData | Pointer to data representing a change in the game state
dataSize | Total length of the data pointed to by GameState.

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual, inherited]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • GameStateCallback.h


GameStateCallback Member List

This is the complete list of members for GameStateCallback, including all inherited members.
GameStateCallback() | GameStateCallback |
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
onReceivedGameStateMsg(int entityId, char *stateData, short dataSize)=0 | GameStateCallback | [pure virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]
~GameStateCallback() | GameStateCallback |


Guild Class Reference

Guild. More...

List of all members.

Public Types

enum GuildAttributes {
PERSISTENT_MEMBERSHIP = 0x1,
EMAIL_FOLLOWUP = 0x2,
PERSISTENT_MSG = 0x4,
DESTROY_WITH_OWNER = 0x8,
DONT_SEND_MEMBERSHIP_CHANGES = 0x10,
MEMBERS_CAN_POST_MSG = 0x20,
MEMBERS_CAN_DELETE_ANY_MSG = 0x40,
MEMBERS_CAN_DELETE_OWN_MSG = 0x80,
DONT_SEND_NEW_MESSAGES = 0x100
}
These are bit field options which affect the behavior of a guild. More...

enum Inviter {
SYSTEM = 0x1,
MODERATOR = 0x2,
MEMBER = 0x4,
SELF = 0x8
}
These are bit field options which specify who has permission to invite people into the guild, and who can become the moderator for the guild, if there is no current moderator. More...

Public Member Functions

Guild (int attributes, int inv)
Creates a guild with specified options, and inviters.

virtual | ~Guild ()
int | getAttributes ()
int | getInviters ()
Guild ()
int | getId ()
void | setId (int id)
void | setName (const char *name)
const char * | getName ()

Static Public Member Functions

Guild * createPersistantGuildInstance ()
Convenience createInstance methods which create guilds in commonly used configurations.

Guild * createGroupInstance ()
Guild * createForum ()

Public Attributes

IntVector userIds
A vector of ids of characters who are members of this guild.

Friends

class | CharacterService
class | ZonaGuildMessage

Detailed Description

Guild.

A group of characters. Guilds can also be recipients of MailMessages.

See also:
ZonaServices.

Definition at line 20 of file Guild.h.

Member Enumeration Documentation

enum GuildAttributes

These are bit field options which affect the behavior of a guild.

Each option can be set independently in the attributes bit field in the constructor.

Enumeration values:
PERSISTENT_MEMBERSHIP The member of the guild continues to be a member of the guild even after he leaves the game.

Next time the character enters the game, he will remain a member of the guild. The membership information is stored in the database.

EMAIL_FOLLOWUP | If the character is not in the game and is a member of the guild, he will get an email copy of the message.
PERSISTENT_MSG In addition to sending the message to all the characters currently in the game, the message will also be saved in the database so that currently off-line characters can get the messages by calling fetchPersistentMessages() when they enter the game later.

See also:
ZonaServices::fetchPersistentMessages
DESTROY_WITH_OWNER This guild will be destroyed when the moderator leaves the game, or if the moderator is set to no one.

Useful for personal or special-purpose guilds

DONT_SEND_MEMBERSHIP_CHANGES For large guilds or bulletin boards where memberships are too large or not relavent.

IGNORED

MEMBERS_CAN_POST_MSG | Members can post messages to the guild even if moderator for the guild is set.
MEMBERS_CAN_DELETE_ANY_MSG | Members can delete any persistent messages even if moderator for the guild is set.
MEMBERS_CAN_DELETE_OWN_MSG | Members can delete persistent messages that they have posted even if moderator is set.
DONT_SEND_NEW_MESSAGES | This disallows members to send new messages*.

Definition at line 27 of file Guild.h.

enum Inviter

These are bit field options which specify who has permission to invite people into the guild, and who can become the moderator for the guild, if there is no current moderator.

Enumeration values:
SYSTEM | Reserved.
MODERATOR | The guild moderator can invite other characters into the guild.
MEMBER | A current guild member can invite other characters into the guild.
SELF Any character can invite himself into the guild.

This is makes the guild membership open everyone.

Definition at line 70 of file Guild.h.

Constructor & Destructor Documentation

Guild | ( | int | attributes,
 |  | int | inv
 | ) |

Creates a guild with specified options, and inviters.

See also:
GuildAttributes

Inviter

virtual ~Guild ( ) [virtual]

Guild ( )

Referenced by createForum(), createGroupInstance(), and createPersistantGuildInstance().

Member Function Documentation

Guild* createPersistantGuildInstance ( ) [inline, static]

Convenience createInstance methods which create guilds in commonly used configurations.

This can also be done by passing the apropriate options into the guild's constructor.

Returns:
a pointer to a new instance of a guild. The caller is responsible for freeing the memory.

Definition at line 108 of file Guild.h.

References Guild(), MODERATOR, PERSISTENT_MEMBERSHIP, and PERSISTENT_MSG.

Guild* createGroupInstance ( ) [inline, static]

Definition at line 112 of file Guild.h.

References DESTROY_WITH_OWNER, Guild(), and MODERATOR.

Guild* createForum ( ) [inline, static]

Definition at line 116 of file Guild.h.

References Guild(), PERSISTENT_MEMBERSHIP, and SELF.

int getAttributes ( )

int getInviters ( )

int getId ( )

void setId ( int id )

void setName ( const char * name )

const char* getName ( )

Friends And Related Function Documentation

friend class CharacterService [friend]

Definition at line 86 of file Guild.h.

friend class ZonaGuildMessage [friend]

Definition at line 141 of file Guild.h.

Member Data Documentation

IntVector userIds

A vector of ids of characters who are members of this guild.

This guild is accessible to all those characters, and they can read mail sent to this guild.

Definition at line 98 of file Guild.h.

The documentation for this class was generated from the following file:
  • Guild.h


Guild Member List

This is the complete list of members for Guild, including all inherited members.
CharacterService class | Guild | [friend]
createForum() | Guild | [inline, static]
createGroupInstance() | Guild | [inline, static]
createPersistantGuildInstance() | Guild | [inline, static]
DESTROY_WITH_OWNER enum value | Guild |
DONT_SEND_MEMBERSHIP_CHANGES enum value | Guild |
DONT_SEND_NEW_MESSAGES enum value | Guild |
EMAIL_FOLLOWUP enum value | Guild |
getAttributes() | Guild |
getId() | Guild |
getInviters() | Guild |
getName() | Guild |
Guild(int attributes, int inv) | Guild |
Guild() | Guild |
GuildAttributes enum name | Guild |
Inviter enum name | Guild |
MEMBER enum value | Guild |
MEMBERS_CAN_DELETE_ANY_MSG enum value | Guild |
MEMBERS_CAN_DELETE_OWN_MSG enum value | Guild |
MEMBERS_CAN_POST_MSG enum value | Guild |
MODERATOR enum value | Guild |
PERSISTENT_MEMBERSHIP enum value | Guild |
PERSISTENT_MSG enum value | Guild |
SELF enum value | Guild |
setId(int id) | Guild |
setName(const char *name) | Guild |
SYSTEM enum value | Guild |
userIds | Guild |
ZonaGuildMessage class | Guild | [friend]
~Guild() | Guild | [virtual]


GuildCallback Class Reference

Provides a service to recive chat messages for the sphere. More...

Inheritance diagram for GuildCallback:

Callback List of all members.

Public Member Functions

GuildCallback ()
Constructor.

~GuildCallback ()
Destructor.

virtual void | memberJoinedGuild (int guildId, int charId)
called by Zona Services when a new group member is added to the List

virtual void | memberDepartedGuild (int guildId, int charId)
called by Zona Services when the group member is removed from the List

virtual void | moderatorChanged (int guildId)
Called by Zona Services when the group moderator was changed.

virtual void | guildDestroyed (int guildId)
Called by Zona Services when a tracked guild has been destroyed.

virtual void | guildInvite (ZonaClientGuild *guild, int inviterId)
Called by Zona Services when the user receives an invitation to join a guild.

virtual void | serverThrownError (int errNum, ZWString *errMsg)
A way to catch errors from the server.

virtual void | serverThrownError (const char *errMsg)
A way to catch errors from the server.

virtual void | onNotifyPlayerReset (int resetAction, int resetReason)
When the player status is reset by the server this method is invoked by the Zona service.

Detailed Description

Provides a service to recive chat messages for the sphere.

Developers extend this abstract class and register their derived class with ZonaServices to receive updates on the player's sphere.

Definition at line 41 of file GuildCallback.h.

Constructor & Destructor Documentation

GuildCallback ( )

Constructor.

~GuildCallback ( )

Destructor.

Member Function Documentation

virtual void memberJoinedGuild | ( | int | guildId,
 |  | int | charId
 | ) | [virtual]

called by Zona Services when a new group member is added to the List

Parameters:
guildId | the Guild into which a character has joined
charId | the id of the new guild member

virtual void memberDepartedGuild | ( | int | guildId,
 |  | int | charId
 | ) | [virtual]

called by Zona Services when the group member is removed from the List

Parameters:
guildId | the Guild from which a charcter has departed
charId | the id of the departed guild member

virtual void moderatorChanged ( int guildId ) [virtual]

Called by Zona Services when the group moderator was changed.

Parameters:
guildId the Guild for which the moderator was changed

virtual void guildDestroyed ( int guildId ) [virtual]

Called by Zona Services when a tracked guild has been destroyed.

No more messages will be sent with regards to this guild, and all messages sent to this guild will not be delivered.

Parameters:
guildId The id of the destroyed guild.

virtual void guildInvite | ( | ZonaClientGuild * | guild,
 |  | int | inviterId
 | ) | [virtual]

Called by Zona Services when the user receives an invitation to join a guild.

THE CALLBACK IS RESPONSIBLE FOR FREEING THE MEMORY FOR guild.

Parameters:
guild | The guild into which the active character was invited.
inviterId | of the character who inviter the active character into the guild.

virtual void serverThrownError | ( | int | errNum,
 |  | ZWString * | errMsg
 | ) | [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errNum | Int of a pre defined error code
errMsg | An ASCII string of error message from server

virtual void serverThrownError ( const char * errMsg ) [virtual, inherited]

A way to catch errors from the server.

This will only be called if it is a sever error It is meant for debuging or durring development of a game. This call should not be implemented for a

Parameters:
errMsg An ASCII string of error message from server

virtual void onNotifyPlayerReset | ( | int | resetAction,
 |  | int | resetReason
 | ) | [virtual, inherited]

When the player status is reset by the server this method is invoked by the Zona service.

Parameters:
resetAction | whether action is to ACTIVATE or to DEACTIVATE the character
resetReason | the reset reason code , informing the player about the reason for reset message

The documentation for this class was generated from the following file:
  • GuildCallback.h


GuildCallback Member List

This is the complete list of members for GuildCallback, including all inherited members.
GuildCallback() | GuildCallback |
guildDestroyed(int guildId) | GuildCallback | [virtual]
guildInvite(ZonaClientGuild *guild, int inviterId) | GuildCallback | [virtual]
memberDepartedGuild(int guildId, int charId) | GuildCallback | [virtual]
memberJoinedGuild(int guildId, int charId) | GuildCallback | [virtual]
moderatorChanged(int guildId) | GuildCallback | [virtual]
onNotifyPlayerReset(int resetAction, int resetReason) | Callback | [virtual]
serverThrownError(int errNum, ZWString *errMsg) | Callback | [virtual]
serverThrownError(const char *errMsg) | Callback | [virtual]
~GuildCallback() | GuildCallback |


NamedZonaObject Class Reference

A ZonaObject with a text name. More...

Inheritance diagram for NamedZonaObject:

ZonaObject PersistableObject List of all members.

Public Member Functions

NamedZonaObject ()
virtual | ~NamedZonaObject ()
virtual OutStream & | serialize (OutStream &os)
Store this object into a stream.

virtual InStream & | deserialize (InStream &is)
Extract this object from a stream.

virtual ZWString | toString ()
Dump out this object into a debug string.

void | appendToZonaMessage (ZonaMessage *zm)
void | extractFromZonaMessage (ZonaMessage *zm)
ZonaPropertyData * | getPublicDisplayPropertyData ()
returns ptr to the ZonaPropertyData, which has actual data payload and length.

ZonaPropertyData * | getPublicStatePropertyData ()
ZonaPropertyData * | getPrivatePropertyData ()
ZonaPropertyData * | getSystemPropertyData ()
void | setPublicDisplayPropertyData (ZonaPropertyData &p)
sets ptr to the ZonaPropertyData, which has actual data payload and length.

void | setPublicStatePropertyData (ZonaPropertyData &p)
void | setPrivatePropertyData (ZonaPropertyData &p)
void | setSystemPropertyData (ZonaPropertyData &p)
void | setId (int theId)
void | clearPropertyData ()
void | setParent (int aParent)
void | setType (int aType)
short | getType ()
void | setClassId (short value)
short | getClassId ()
char * | getGenericDataBlob ()
These 3 functions are only using m_publicStateProperties for data carrier .

int | getGenericDataLength ()
void | setGenericData (char *blob, int length)

Public Attributes

ZWString name
The name of this object.

int | type
The ZonaObject's type.

int | parent
This object's parent id.

ZonaPropertyData | m_publicDisplayProperties
ZonaPropertyData | m_publicStateProperties
ZonaPropertyData | m_privateProperties
ZonaPropertyData | m_systemProperties
int | id
The id of the object.

Detailed Description

A ZonaObject with a text name.

Objects of this class are streamable.

Definition at line 16 of file NamedZonaObject.h.

Constructor & Destructor Documentation

NamedZonaObject ( )

virtual ~NamedZonaObject ( ) [virtual]

Member Function Documentation

virtual OutStream& serialize ( OutStream & os ) [virtual]

Store this object into a stream.

Parameters:
os The Out stream into which the object should be stored.
Returns:
The outstream which was passed in as the parameter, after the object was serialized into it.

Reimplemented from ZonaObject.

virtual InStream& deserialize ( InStream & is ) [virtual]

Extract this object from a stream.

Parameters:
is The In stream from which the object should be extracted.
Returns:
The instream which was passed in as the parameter, after the object was extracted from it.

Reimplemented from ZonaObject.

virtual ZWString toString ( ) [virtual]

Dump out this object into a debug string.

Reimplemented from ZonaObject.

void appendToZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented from ZonaObject.

void extractFromZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented from ZonaObject.

ZonaPropertyData* getPublicDisplayPropertyData ( ) [inline, inherited]

returns ptr to the ZonaPropertyData, which has actual data payload and length.

The memory will be freed when this ZonaPropertyData is destroyed.

Definition at line 78 of file ZonaObject.h.

References ZonaObject::m_publicDisplayProperties.

ZonaPropertyData* getPublicStatePropertyData ( ) [inline, inherited]

Definition at line 80 of file ZonaObject.h.

References ZonaObject::m_publicStateProperties.

ZonaPropertyData* getPrivatePropertyData ( ) [inline, inherited]

Definition at line 82 of file ZonaObject.h.

References ZonaObject::m_privateProperties.

ZonaPropertyData* getSystemPropertyData ( ) [inline, inherited]

Definition at line 84 of file ZonaObject.h.

References ZonaObject::m_systemProperties.

void setPublicDisplayPropertyData ( ZonaPropertyData & p ) [inline, inherited]

sets ptr to the ZonaPropertyData, which has actual data payload and length.

The memory will be freed when this ZonaPropertyData is destroyed.

Definition at line 91 of file ZonaObject.h.

References ZonaObject::m_publicDisplayProperties.

void setPublicStatePropertyData ( ZonaPropertyData & p ) [inline, inherited]

Definition at line 93 of file ZonaObject.h.

References ZonaObject::m_publicStateProperties.

void setPrivatePropertyData ( ZonaPropertyData & p ) [inline, inherited]

Definition at line 95 of file ZonaObject.h.

References ZonaObject::m_privateProperties.

void setSystemPropertyData ( ZonaPropertyData & p ) [inline, inherited]

Definition at line 97 of file ZonaObject.h.

References ZonaObject::m_systemProperties.

void setId ( int theId ) [inline, inherited]

Definition at line 99 of file ZonaObject.h.

References PersistableObject::id.

void clearPropertyData ( ) [inherited]

void setParent ( int aParent ) [inline, inherited]

Definition at line 130 of file ZonaObject.h.

References ZonaObject::parent.

void setType ( int aType ) [inline, inherited]

Definition at line 132 of file ZonaObject.h.

short getType ( ) [inline, inherited]

Definition at line 134 of file ZonaObject.h.

void setClassId ( short value ) [inherited]

short getClassId ( ) [inherited]

char* getGenericDataBlob ( ) [inherited]

These 3 functions are only using m_publicStateProperties for data carrier .

limited usage

int getGenericDataLength ( ) [inherited]

void setGenericData | ( | char * | blob,
 |  | int | length
 | ) | [inherited]

Member Data Documentation

ZWString name

The name of this object.

Definition at line 25 of file NamedZonaObject.h.

int type [inherited]

The ZonaObject's type.

This can be used by the game developer to distinguish the types of object, but it is not used by ZAF.

Definition at line 124 of file ZonaObject.h.

int parent [inherited]

This object's parent id.

The id must be the id of an existing ZonaObject. If it has no parent, this should be 0.

Definition at line 127 of file ZonaObject.h.

Referenced by ZonaObject::setParent().

ZonaPropertyData m_publicDisplayProperties [inherited]

Definition at line 158 of file ZonaObject.h.

Referenced by ZonaObject::getPublicDisplayPropertyData(), and ZonaObject::setPublicDisplayPropertyData().

ZonaPropertyData m_publicStateProperties [inherited]

Definition at line 159 of file ZonaObject.h.

Referenced by ZonaObject::getPublicStatePropertyData(), and ZonaObject::setPublicStatePropertyData().

ZonaPropertyData m_privateProperties [inherited]

Definition at line 160 of file ZonaObject.h.

Referenced by ZonaObject::getPrivatePropertyData(), and ZonaObject::setPrivatePropertyData().

ZonaPropertyData m_systemProperties [inherited]

Definition at line 161 of file ZonaObject.h.

Referenced by ZonaObject::getSystemPropertyData(), and ZonaObject::setSystemPropertyData().

int id [inherited]

The id of the object.

Definition at line 40 of file PersistableObject.h.

Referenced by ZonaObject::setId().

The documentation for this class was generated from the following file:
  • NamedZonaObject.h


NamedZonaObject Member List

This is the complete list of members for NamedZonaObject, including all inherited members.
appendToZonaMessage(ZonaMessage *zm) | NamedZonaObject | [virtual]
clearPropertyData() | ZonaObject |
deserialize(InStream &is) | NamedZonaObject | [virtual]
extractFromZonaMessage(ZonaMessage *zm) | NamedZonaObject | [virtual]
getClassId() | ZonaObject |
getGenericDataBlob() | ZonaObject |
getGenericDataLength() | ZonaObject |
getPrivatePropertyData() | ZonaObject | [inline]
getPublicDisplayPropertyData() | ZonaObject | [inline]
getPublicStatePropertyData() | ZonaObject | [inline]
getSystemPropertyData() | ZonaObject | [inline]
getType() | ZonaObject | [inline]
id | PersistableObject |
m_privateProperties | ZonaObject |
m_publicDisplayProperties | ZonaObject |
m_publicStateProperties | ZonaObject |
m_systemProperties | ZonaObject |
name | NamedZonaObject |
NamedZonaObject() | NamedZonaObject |
operator=(const ZonaObject &other) | ZonaObject |
PersistableObject::operator=(const PersistableObject &other) | PersistableObject |
parent | ZonaObject |
PersistableObject() | PersistableObject |
PersistableObject(const PersistableObject &other) | PersistableObject |
serialize(OutStream &os) | NamedZonaObject | [virtual]
setClassId(short value) | ZonaObject |
setGenericData(char *blob, int length) | ZonaObject |
setId(int theId) | ZonaObject | [inline]
setParent(int aParent) | ZonaObject | [inline]
setPrivatePropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setPublicDisplayPropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setPublicStatePropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setSystemPropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setType(int aType) | ZonaObject | [inline]
toString() | NamedZonaObject | [virtual]
type | ZonaObject |
ZonaObject() | ZonaObject |
ZonaObject(const ZonaObject &other) | ZonaObject |
ZonaObject(short type, int id) | ZonaObject |
~NamedZonaObject() | NamedZonaObject | [virtual]
~PersistableObject() | PersistableObject | [virtual]
~ZonaObject() | ZonaObject |


PersistableObject Class Reference

PersistableObject. More...

Inheritance diagram for PersistableObject:

ZonaObject NamedZonaObject List of all members.

Public Member Functions

PersistableObject ()
Initializes the id to 0.

PersistableObject (const PersistableObject &other)
Deep copy constructor.

virtual | ~PersistableObject ()
PersistableObject & | operator= (const PersistableObject &other)
Deep copy assignment.

virtual OutStream & | serialize (OutStream &os)
virtual InStream & | deserialize (InStream &is)
virtual void | appendToZonaMessage (ZonaMessage *zm)
virtual void | extractFromZonaMessage (ZonaMessage *zm)

Public Attributes

int | id
The id of the object.

Detailed Description

PersistableObject.

Object that can be stored in the database

Definition at line 20 of file PersistableObject.h.

Constructor & Destructor Documentation

PersistableObject ( )

Initializes the id to 0.

PersistableObject ( const PersistableObject & other )

Deep copy constructor.

virtual ~PersistableObject ( ) [virtual]

Member Function Documentation

PersistableObject& operator= ( const PersistableObject & other )

Deep copy assignment.

virtual OutStream& serialize ( OutStream & os ) [virtual]

Reimplemented in ZonaObject, and NamedZonaObject.

virtual InStream& deserialize ( InStream & is ) [virtual]

Reimplemented in ZonaObject, and NamedZonaObject.

virtual void appendToZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented in ZonaObject, and NamedZonaObject.

virtual void extractFromZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented in ZonaObject, and NamedZonaObject.

Member Data Documentation

int id

The id of the object.

Definition at line 40 of file PersistableObject.h.

Referenced by ZonaObject::setId().

The documentation for this class was generated from the following file:
  • PersistableObject.h


PersistableObject Member List

This is the complete list of members for PersistableObject, including all inherited members.
appendToZonaMessage(ZonaMessage *zm) | PersistableObject | [virtual]
deserialize(InStream &is) | PersistableObject | [virtual]
extractFromZonaMessage(ZonaMessage *zm) | PersistableObject | [virtual]
id | PersistableObject |
operator=(const PersistableObject &other) | PersistableObject |
PersistableObject() | PersistableObject |
PersistableObject(const PersistableObject &other) | PersistableObject |
serialize(OutStream &os) | PersistableObject | [virtual]
~PersistableObject() | PersistableObject | [virtual]


ZonaBaseEntity Class Reference

Inheritance diagram for ZonaBaseEntity:

ZonaClientEntity ZonaClientCharacter List of all members.

Public Member Functions

ZonaBaseEntity (int type)
Constructor.

ZonaBaseEntity ()
Constructor.

virtual | ~ZonaBaseEntity ()
Destructor.

virtual int | getEntityId ()=0
Return current Entity Id.

virtual int | getParentId ()=0
Return parent's entity id.

virtual int | getEntityType ()=0
Return entity's type.

virtual int | getEntityInfo ()=0
Return user defined entity information.

virtual int | getMapId ()=0
Return entity's mapId.

virtual void | setEntityId (int value)=0
Set the Id of current entity.

virtual void | setParentId (int value)=0
Set Parent Entity Id.

virtual void | setEntityType (int value)=0
Set Entity Type.

virtual void | setEntityInfo (int value)=0
Set Entity Info.

virtual void | setMapId (int value)=0
Set Entity's Map Id.

virtual void | setIsMaster (bool value)=0
virtual bool | getIsMaster ()=0

Constructor & Destructor Documentation

ZonaBaseEntity ( int type )

Constructor.

ZonaBaseEntity ( )

Constructor.

virtual ~ZonaBaseEntity ( ) [virtual]

Destructor.

Member Function Documentation

virtual int getEntityId ( ) [pure virtual]

Return current Entity Id.

Returns:
entity id

virtual int getParentId ( ) [pure virtual]

Return parent's entity id.

Returns:
entity parent id

virtual int getEntityType ( ) [pure virtual]

Return entity's type.

Returns:
entity's type

virtual int getEntityInfo ( ) [pure virtual]

Return user defined entity information.

Returns:
user defined entity information

virtual int getMapId ( ) [pure virtual]

Return entity's mapId.

Returns:
entity map Id

virtual void setEntityId ( int value ) [pure virtual]

Set the Id of current entity.

Parameters:
value Entity id of current entity

virtual void setParentId ( int value ) [pure virtual]

Set Parent Entity Id.

Parameters:
value Entity id of parent entity

virtual void setEntityType ( int value ) [pure virtual]

Set Entity Type.

Parameters:
value | Entity type
value | Entity type of parent entity

virtual void setEntityInfo ( int value ) [pure virtual]

Set Entity Info.

Parameters:
value user defined Entity Info,

virtual void setMapId ( int value ) [pure virtual]

Set Entity's Map Id.

Parameters:
value Map id of entity

virtual void setIsMaster ( bool value ) [pure virtual]

virtual bool getIsMaster ( ) [pure virtual]

The documentation for this class was generated from the following file:
  • ZonaBaseEntity.h


ZonaBaseEntity Member List

This is the complete list of members for ZonaBaseEntity, including all inherited members.
getEntityId()=0 | ZonaBaseEntity | [pure virtual]
getEntityInfo()=0 | ZonaBaseEntity | [pure virtual]
getEntityType()=0 | ZonaBaseEntity | [pure virtual]
getIsMaster()=0 | ZonaBaseEntity | [pure virtual]
getMapId()=0 | ZonaBaseEntity | [pure virtual]
getParentId()=0 | ZonaBaseEntity | [pure virtual]
setEntityId(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityInfo(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityType(int value)=0 | ZonaBaseEntity | [pure virtual]
setIsMaster(bool value)=0 | ZonaBaseEntity | [pure virtual]
setMapId(int value)=0 | ZonaBaseEntity | [pure virtual]
setParentId(int value)=0 | ZonaBaseEntity | [pure virtual]
ZonaBaseEntity(int type) | ZonaBaseEntity |
ZonaBaseEntity() | ZonaBaseEntity |
~ZonaBaseEntity() | ZonaBaseEntity | [virtual]


ZonaClientCharacter Class Reference

Inheritance diagram for ZonaClientCharacter:

ZonaClientEntity ZonaBaseEntity List of all members.

Public Member Functions

ZonaClientCharacter (int type)
Constructor.

ZonaClientCharacter ()
Constructor.

virtual | ~ZonaClientCharacter ()
Destructor.

int | enter (int subFilter=ZONA_MSG_ALL)
Places player into sphere for bandwidth-limiting.

int | exit ()
Removes a player from a sphere.

int | update ()
Updates the character in the database.

int | select ()
Selects the character for a logged in user.

int | acquireChildEntity (int entityId)
Asynchronous request to acquire a child entity by the character entity The callback onNotifyEntityUpdate(...) will be called to inform success/failure.

int | releaseChildEntity (int entityId)
Asynchronous request to release a child entity by the character entity.

virtual char * | getName (int &length)=0
Get the name of Character.

virtual void | setName (char *name, int length)=0
Set the name of Character.

int | publish ()
Publish dirty entity properties to the server.

int | getChildEntities (ZonaClientEntityPtrVector &childEntities, bool blockingCall=true)
Call to fetch all the children for a given entity Calling of getChildEntities(..) multiple times before a fetch has done will return ERR_INVALID_OPERATION.

bool | isFetchingChildEntities ()
Verify if the client finishs fetching child entities.

int | show ()
Makes an entity visible.

int | hide ()
Makes an entity invisible.

int | attachEntity (int entityId)
Attach an entity, the attached entity will no longer be needed to send its state to server for computing the region Id separately until it is detached.

int | detachEntity (int entityId)
Detachs an entity, the detached entity will now be tracked separately by the server.

int | activate ()
This causes the server to set the region id based on the current entity state.

int | deactivate ()
This causes the server to set the region id of the entity to be set to null.

void | retain ()
Increment the Reference count for the Entity Object.

void | release ()
Decrement the Reference count for the Entity Object.

virtual void | setRegionId (int regionId)=0
This method should not be called directly by game code.

virtual int | getRegionId ()=0
This method should not be called directly by game code.

virtual int | getEntityId ()=0
Return current Entity Id.

virtual int | getParentId ()=0
Return parent's entity id.

virtual int | getEntityType ()=0
Return entity's type.

virtual int | getEntityInfo ()=0
Return user defined entity information.

virtual int | getMapId ()=0
Return entity's mapId.

virtual void | setEntityId (int value)=0
Set the Id of current entity.

virtual void | setParentId (int value)=0
Set Parent Entity Id.

virtual void | setEntityType (int value)=0
Set Entity Type.

virtual void | setEntityInfo (int value)=0
Set Entity Info.

virtual void | setMapId (int value)=0
Set Entity's Map Id.

virtual void | setIsMaster (bool value)=0
virtual bool | getIsMaster ()=0

Protected Member Functions

int | updateEntityType (int childId, int newEntityType)
int | updateEntityType (int parentId, int childId, int newEntityType)

Protected Attributes

ZonaServices * m_zs
int | m_refCount

Constructor & Destructor Documentation

ZonaClientCharacter ( int type )

Constructor.

ZonaClientCharacter ( )

Constructor.

virtual ~ZonaClientCharacter ( ) [virtual]

Destructor.

Member Function Documentation

int enter ( int subFilter = ZONA_MSG_ALL )

Places player into sphere for bandwidth-limiting.

This character object will be added to the entity manager. This object will be deleted automatically when game code calls exit on this object.

Note: The default subscription Filters for the player are set to ZONA_MSG_ALL.

Returns:
ERR_SUCCESS after entering the player into the sphere and

ERR_MESSAGE_SEND upon failing to enter the player into a sphere

Reimplemented from ZonaClientEntity.

int exit ( )

Removes a player from a sphere.

This object will also deleted. No further references must be made to this object after this call.

Returns:
ERR_SUCCESS after removing the player from the sphere and

ERR_MESSAGE_SEND upon failing to remove the player from a sphere.

Reimplemented from ZonaClientEntity.

int update ( )

Updates the character in the database.

The server plugin will validate and and may update the name, type, initial character record, in which case, the the character object passed in will be updated with the changes. Note: This function cannot be called after call to enter, otherwise it would return ERR_INVALID_OPERATION

Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int select ( )

Selects the character for a logged in user.

Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int acquireChildEntity ( int entityId )

Asynchronous request to acquire a child entity by the character entity The callback onNotifyEntityUpdate(...) will be called to inform success/failure.

Note : Character cannot accquire other characters.

Parameters:
entityId id of child entity
Returns:
ERR_SUCCESS if sent the request succefully else error

int releaseChildEntity ( int entityId )

Asynchronous request to release a child entity by the character entity.

The callback onNotifyEntityUpdate(...) will be called to inform success/failure.

Parameters:
entityId id of child entity
Returns:
ERR_SUCCESS if sent the request succefully else error

virtual char* getName ( int & length ) [pure virtual]

Get the name of Character.

Returns:
Pointer to character name. (wchar_t)

virtual void setName | ( | char * | name,
 |  | int | length
 | ) | [pure virtual]

Set the name of Character.

Parameters:
name | pointer to character name. (wchar_t)
length | size of name string

int publish ( ) [inherited]

Publish dirty entity properties to the server.

The dirty bits are also cleared. The onValidateEntityPropertyUpdate is called on the plug-in.

Returns:
error code

int getChildEntities | ( | ZonaClientEntityPtrVector & | childEntities,
 |  | bool | blockingCall = true
 | ) | [inherited]

Call to fetch all the children for a given entity Calling of getChildEntities(..) multiple times before a fetch has done will return ERR_INVALID_OPERATION.

Parameters:
childEntities | return value of all the children of parentId
blockingCall | true if it's a synchronous call, this function will be blocked until all child entities are fetched. If blockingCall is false, this function will return immediately, use isFetchingChildEntities() to verify if the fetching child entities has done.
Returns:
error code

bool isFetchingChildEntities ( ) [inherited]

Verify if the client finishs fetching child entities.

Returns:
true if it's still fetching child entities

int show ( ) [inherited]

Makes an entity visible.

Turns off the ZONA_ET_IS_HIDDEN flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Returns:
error code

int hide ( ) [inherited]

Makes an entity invisible.

Turns on the ZONA_ET_IS_HIDDEN flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Returns:
error code

int attachEntity ( int entityId ) [inherited]

Attach an entity, the attached entity will no longer be needed to send its state to server for computing the region Id separately until it is detached.

Turns on the ZONA_ET_IS_ATTACHED flag. Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Parameters:
entityId id of the entity to be attached
Returns:
error code

int detachEntity ( int entityId ) [inherited]

Detachs an entity, the detached entity will now be tracked separately by the server.

The client needs to send separate game states to the server for computing the region Id. Turns off the ZONA_ET_IS_ATTACHED flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Parameters:
entityId id of the entity to be attached
Returns:
error code

int activate ( ) [inherited]

This causes the server to set the region id based on the current entity state.

Returns:
error code

int deactivate ( ) [inherited]

This causes the server to set the region id of the entity to be set to null.

This method does not have to be called for entering entities.

Returns:
error code

void retain ( ) [inherited]

Increment the Reference count for the Entity Object.

The client can increment the reference count for the Entity, to prevent the object from being deleted from the EntityStateManager cache.

Returns:
void

void release ( ) [inherited]

Decrement the Reference count for the Entity Object.

The client can decrement the reference count for the Entity, to signal ZonaServices to delete it from the EntityStateManager cache.

Returns:
void

virtual void setRegionId ( int regionId ) [pure virtual, inherited]

This method should not be called directly by game code.

This method will be not be accessible in the future.

virtual int getRegionId ( ) [pure virtual, inherited]

This method should not be called directly by game code.

This method will be not be accessible in the future.

int updateEntityType | ( | int | childId,
 |  | int | newEntityType
 | ) | [protected, inherited]

int updateEntityType | ( | int | parentId,
 |  | int | childId,
 |  | int | newEntityType
 | ) | [protected, inherited]

virtual int getEntityId ( ) [pure virtual, inherited]

Return current Entity Id.

Returns:
entity id

virtual int getParentId ( ) [pure virtual, inherited]

Return parent's entity id.

Returns:
entity parent id

virtual int getEntityType ( ) [pure virtual, inherited]

Return entity's type.

Returns:
entity's type

virtual int getEntityInfo ( ) [pure virtual, inherited]

Return user defined entity information.

Returns:
user defined entity information

virtual int getMapId ( ) [pure virtual, inherited]

Return entity's mapId.

Returns:
entity map Id

virtual void setEntityId ( int value ) [pure virtual, inherited]

Set the Id of current entity.

Parameters:
value Entity id of current entity

virtual void setParentId ( int value ) [pure virtual, inherited]

Set Parent Entity Id.

Parameters:
value Entity id of parent entity

virtual void setEntityType ( int value ) [pure virtual, inherited]

Set Entity Type.

Parameters:
value | Entity type
value | Entity type of parent entity

virtual void setEntityInfo ( int value ) [pure virtual, inherited]

Set Entity Info.

Parameters:
value user defined Entity Info,

virtual void setMapId ( int value ) [pure virtual, inherited]

Set Entity's Map Id.

Parameters:
value Map id of entity

virtual void setIsMaster ( bool value ) [pure virtual, inherited]

virtual bool getIsMaster ( ) [pure virtual, inherited]

Member Data Documentation

ZonaServices* m_zs [protected, inherited]

Definition at line 203 of file ZonaClientEntity.h.

int m_refCount [protected, inherited]

Definition at line 205 of file ZonaClientEntity.h.

The documentation for this class was generated from the following file:
  • ZonaClientCharacter.h


ZonaClientCharacter Member List

This is the complete list of members for ZonaClientCharacter, including all inherited members.
acquireChildEntity(int entityId) | ZonaClientCharacter |
activate() | ZonaClientEntity |
attachEntity(int entityId) | ZonaClientEntity |
deactivate() | ZonaClientEntity |
detachEntity(int entityId) | ZonaClientEntity |
enter(int subFilter=ZONA_MSG_ALL) | ZonaClientCharacter |
exit() | ZonaClientCharacter |
getChildEntities(ZonaClientEntityPtrVector &childEntities, bool blockingCall=true) | ZonaClientEntity |
getEntityId()=0 | ZonaBaseEntity | [pure virtual]
getEntityInfo()=0 | ZonaBaseEntity | [pure virtual]
getEntityType()=0 | ZonaBaseEntity | [pure virtual]
getIsMaster()=0 | ZonaBaseEntity | [pure virtual]
getMapId()=0 | ZonaBaseEntity | [pure virtual]
getName(int &length)=0 | ZonaClientCharacter | [pure virtual]
getParentId()=0 | ZonaBaseEntity | [pure virtual]
getRegionId()=0 | ZonaClientEntity | [pure virtual]
hide() | ZonaClientEntity |
isFetchingChildEntities() | ZonaClientEntity |
m_refCount | ZonaClientEntity | [protected]
m_zs | ZonaClientEntity | [protected]
publish() | ZonaClientEntity |
release() | ZonaClientEntity |
releaseChildEntity(int entityId) | ZonaClientCharacter |
retain() | ZonaClientEntity |
select() | ZonaClientCharacter |
setEntityId(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityInfo(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityType(int value)=0 | ZonaBaseEntity | [pure virtual]
setIsMaster(bool value)=0 | ZonaBaseEntity | [pure virtual]
setMapId(int value)=0 | ZonaBaseEntity | [pure virtual]
setName(char *name, int length)=0 | ZonaClientCharacter | [pure virtual]
setParentId(int value)=0 | ZonaBaseEntity | [pure virtual]
setRegionId(int regionId)=0 | ZonaClientEntity | [pure virtual]
show() | ZonaClientEntity |
update() | ZonaClientCharacter |
updateEntityType(int childId, int newEntityType) | ZonaClientEntity | [protected]
updateEntityType(int parentId, int childId, int newEntityType) | ZonaClientEntity | [protected]
ZonaBaseEntity(int type) | ZonaBaseEntity |
ZonaBaseEntity() | ZonaBaseEntity |
ZonaClientCharacter(int type) | ZonaClientCharacter |
ZonaClientCharacter() | ZonaClientCharacter |
ZonaClientEntity(int type) | ZonaClientEntity |
ZonaClientEntity() | ZonaClientEntity |
~ZonaBaseEntity() | ZonaBaseEntity | [virtual]
~ZonaClientCharacter() | ZonaClientCharacter | [virtual]
~ZonaClientEntity() | ZonaClientEntity | [virtual]


ZonaClientEntity Class Reference

Inheritance diagram for ZonaClientEntity:

ZonaBaseEntity ZonaClientCharacter List of all members.

Public Member Functions

ZonaClientEntity (int type)
Constructor.

ZonaClientEntity ()
Constructor.

virtual | ~ZonaClientEntity ()
Destructor.

int | publish ()
Publish dirty entity properties to the server.

int | enter (int subFilter=ZONA_MSG_ALL)
Informs the server a entity is entering the world.

int | exit ()
Informs the server a child entity is leaving the world.

int | getChildEntities (ZonaClientEntityPtrVector &childEntities, bool blockingCall=true)
Call to fetch all the children for a given entity Calling of getChildEntities(..) multiple times before a fetch has done will return ERR_INVALID_OPERATION.

bool | isFetchingChildEntities ()
Verify if the client finishs fetching child entities.

int | show ()
Makes an entity visible.

int | hide ()
Makes an entity invisible.

int | attachEntity (int entityId)
Attach an entity, the attached entity will no longer be needed to send its state to server for computing the region Id separately until it is detached.

int | detachEntity (int entityId)
Detachs an entity, the detached entity will now be tracked separately by the server.

int | activate ()
This causes the server to set the region id based on the current entity state.

int | deactivate ()
This causes the server to set the region id of the entity to be set to null.

void | retain ()
Increment the Reference count for the Entity Object.

void | release ()
Decrement the Reference count for the Entity Object.

virtual void | setRegionId (int regionId)=0
This method should not be called directly by game code.

virtual int | getRegionId ()=0
This method should not be called directly by game code.

virtual int | getEntityId ()=0
Return current Entity Id.

virtual int | getParentId ()=0
Return parent's entity id.

virtual int | getEntityType ()=0
Return entity's type.

virtual int | getEntityInfo ()=0
Return user defined entity information.

virtual int | getMapId ()=0
Return entity's mapId.

virtual void | setEntityId (int value)=0
Set the Id of current entity.

virtual void | setParentId (int value)=0
Set Parent Entity Id.

virtual void | setEntityType (int value)=0
Set Entity Type.

virtual void | setEntityInfo (int value)=0
Set Entity Info.

virtual void | setMapId (int value)=0
Set Entity's Map Id.

virtual void | setIsMaster (bool value)=0
virtual bool | getIsMaster ()=0

Protected Member Functions

int | updateEntityType (int childId, int newEntityType)
int | updateEntityType (int parentId, int childId, int newEntityType)

Protected Attributes

ZonaServices * m_zs
int | m_refCount

Constructor & Destructor Documentation

ZonaClientEntity ( int type )

Constructor.

ZonaClientEntity ( )

Constructor.

virtual ~ZonaClientEntity ( ) [virtual]

Destructor.

Member Function Documentation

int publish ( )

Publish dirty entity properties to the server.

The dirty bits are also cleared. The onValidateEntityPropertyUpdate is called on the plug-in.

Returns:
error code

int enter ( int subFilter = ZONA_MSG_ALL )

Informs the server a entity is entering the world.

The entity is also activated. This entity object is also added to the internal entity manager and can be reteived by getEntityWithId(...) This object will be deleted automatically upon calling exit().

Note: The default subscription Filters for a Entity are set to ZONA_MSG_ALL.

Returns:
error code

Reimplemented in ZonaClientCharacter.

int exit ( )

Informs the server a child entity is leaving the world.

The onEntityDepartedGame and onExitEntity will be called on the plugin. This object will be removed from the internal entity manager and will be deleted. Game code must not refer to this object after this call.

Returns:
error code

Reimplemented in ZonaClientCharacter.

int getChildEntities | ( | ZonaClientEntityPtrVector & | childEntities,
 |  | bool | blockingCall = true
 | ) |

Call to fetch all the children for a given entity Calling of getChildEntities(..) multiple times before a fetch has done will return ERR_INVALID_OPERATION.

Parameters:
childEntities | return value of all the children of parentId
blockingCall | true if it's a synchronous call, this function will be blocked until all child entities are fetched. If blockingCall is false, this function will return immediately, use isFetchingChildEntities() to verify if the fetching child entities has done.
Returns:
error code

bool isFetchingChildEntities ( )

Verify if the client finishs fetching child entities.

Returns:
true if it's still fetching child entities

int show ( )

Makes an entity visible.

Turns off the ZONA_ET_IS_HIDDEN flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Returns:
error code

int hide ( )

Makes an entity invisible.

Turns on the ZONA_ET_IS_HIDDEN flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Returns:
error code

int attachEntity ( int entityId )

Attach an entity, the attached entity will no longer be needed to send its state to server for computing the region Id separately until it is detached.

Turns on the ZONA_ET_IS_ATTACHED flag. Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Parameters:
entityId id of the entity to be attached
Returns:
error code

int detachEntity ( int entityId )

Detachs an entity, the detached entity will now be tracked separately by the server.

The client needs to send separate game states to the server for computing the region Id. Turns off the ZONA_ET_IS_ATTACHED flag Calls the plugin onValidateEntityTypeUpdate(...) for server-side validation.

Parameters:
entityId id of the entity to be attached
Returns:
error code

int activate ( )

This causes the server to set the region id based on the current entity state.

Returns:
error code

int deactivate ( )

This causes the server to set the region id of the entity to be set to null.

This method does not have to be called for entering entities.

Returns:
error code

void retain ( )

Increment the Reference count for the Entity Object.

The client can increment the reference count for the Entity, to prevent the object from being deleted from the EntityStateManager cache.

Returns:
void

void release ( )

Decrement the Reference count for the Entity Object.

The client can decrement the reference count for the Entity, to signal ZonaServices to delete it from the EntityStateManager cache.

Returns:
void

virtual void setRegionId ( int regionId ) [pure virtual]

This method should not be called directly by game code.

This method will be not be accessible in the future.

virtual int getRegionId ( ) [pure virtual]

This method should not be called directly by game code.

This method will be not be accessible in the future.

int updateEntityType | ( | int | childId,
 |  | int | newEntityType
 | ) | [protected]

int updateEntityType | ( | int | parentId,
 |  | int | childId,
 |  | int | newEntityType
 | ) | [protected]

virtual int getEntityId ( ) [pure virtual, inherited]

Return current Entity Id.

Returns:
entity id

virtual int getParentId ( ) [pure virtual, inherited]

Return parent's entity id.

Returns:
entity parent id

virtual int getEntityType ( ) [pure virtual, inherited]

Return entity's type.

Returns:
entity's type

virtual int getEntityInfo ( ) [pure virtual, inherited]

Return user defined entity information.

Returns:
user defined entity information

virtual int getMapId ( ) [pure virtual, inherited]

Return entity's mapId.

Returns:
entity map Id

virtual void setEntityId ( int value ) [pure virtual, inherited]

Set the Id of current entity.

Parameters:
value Entity id of current entity

virtual void setParentId ( int value ) [pure virtual, inherited]

Set Parent Entity Id.

Parameters:
value Entity id of parent entity

virtual void setEntityType ( int value ) [pure virtual, inherited]

Set Entity Type.

Parameters:
value | Entity type
value | Entity type of parent entity

virtual void setEntityInfo ( int value ) [pure virtual, inherited]

Set Entity Info.

Parameters:
value user defined Entity Info,

virtual void setMapId ( int value ) [pure virtual, inherited]

Set Entity's Map Id.

Parameters:
value Map id of entity

virtual void setIsMaster ( bool value ) [pure virtual, inherited]

virtual bool getIsMaster ( ) [pure virtual, inherited]

Member Data Documentation

ZonaServices* m_zs [protected]

Definition at line 203 of file ZonaClientEntity.h.

int m_refCount [protected]

Definition at line 205 of file ZonaClientEntity.h.

The documentation for this class was generated from the following file:
  • ZonaClientEntity.h


ZonaClientEntity Member List

This is the complete list of members for ZonaClientEntity, including all inherited members.
activate() | ZonaClientEntity |
attachEntity(int entityId) | ZonaClientEntity |
deactivate() | ZonaClientEntity |
detachEntity(int entityId) | ZonaClientEntity |
enter(int subFilter=ZONA_MSG_ALL) | ZonaClientEntity |
exit() | ZonaClientEntity |
getChildEntities(ZonaClientEntityPtrVector &childEntities, bool blockingCall=true) | ZonaClientEntity |
getEntityId()=0 | ZonaBaseEntity | [pure virtual]
getEntityInfo()=0 | ZonaBaseEntity | [pure virtual]
getEntityType()=0 | ZonaBaseEntity | [pure virtual]
getIsMaster()=0 | ZonaBaseEntity | [pure virtual]
getMapId()=0 | ZonaBaseEntity | [pure virtual]
getParentId()=0 | ZonaBaseEntity | [pure virtual]
getRegionId()=0 | ZonaClientEntity | [pure virtual]
hide() | ZonaClientEntity |
isFetchingChildEntities() | ZonaClientEntity |
m_refCount | ZonaClientEntity | [protected]
m_zs | ZonaClientEntity | [protected]
publish() | ZonaClientEntity |
release() | ZonaClientEntity |
retain() | ZonaClientEntity |
setEntityId(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityInfo(int value)=0 | ZonaBaseEntity | [pure virtual]
setEntityType(int value)=0 | ZonaBaseEntity | [pure virtual]
setIsMaster(bool value)=0 | ZonaBaseEntity | [pure virtual]
setMapId(int value)=0 | ZonaBaseEntity | [pure virtual]
setParentId(int value)=0 | ZonaBaseEntity | [pure virtual]
setRegionId(int regionId)=0 | ZonaClientEntity | [pure virtual]
show() | ZonaClientEntity |
updateEntityType(int childId, int newEntityType) | ZonaClientEntity | [protected]
updateEntityType(int parentId, int childId, int newEntityType) | ZonaClientEntity | [protected]
ZonaBaseEntity(int type) | ZonaBaseEntity |
ZonaBaseEntity() | ZonaBaseEntity |
ZonaClientEntity(int type) | ZonaClientEntity |
ZonaClientEntity() | ZonaClientEntity |
~ZonaBaseEntity() | ZonaBaseEntity | [virtual]
~ZonaClientEntity() | ZonaClientEntity | [virtual]


ZonaObject Class Reference

ZonaObject. More...

Inheritance diagram for ZonaObject:

PersistableObject NamedZonaObject List of all members.

Public Member Functions

ZonaObject ()
initializes all fields to 0, and sets the Blob to NULL

ZonaObject (const ZonaObject &other)
Deep copy constructor.

~ZonaObject ()
ZonaObject & | operator= (const ZonaObject &other)
ZonaObject (short type, int id)
Initializes the structure with passed in arguments.

ZWString toString ()
Returns a descrption of the object.

ZonaPropertyData * | getPublicDisplayPropertyData ()
returns ptr to the ZonaPropertyData, which has actual data payload and length.

ZonaPropertyData * | getPublicStatePropertyData ()
ZonaPropertyData * | getPrivatePropertyData ()
ZonaPropertyData * | getSystemPropertyData ()
void | setPublicDisplayPropertyData (ZonaPropertyData &p)
sets ptr to the ZonaPropertyData, which has actual data payload and length.

void | setPublicStatePropertyData (ZonaPropertyData &p)
void | setPrivatePropertyData (ZonaPropertyData &p)
void | setSystemPropertyData (ZonaPropertyData &p)
void | setId (int theId)
void | clearPropertyData ()
virtual OutStream & | serialize (OutStream &os)
Store this object into a stream.

virtual InStream & | deserialize (InStream &is)
Extract this object from a stream.

virtual void | appendToZonaMessage (ZonaMessage *zm)
virtual void | extractFromZonaMessage (ZonaMessage *zm)
void | setParent (int aParent)
void | setType (int aType)
short | getType ()
void | setClassId (short value)
short | getClassId ()
char * | getGenericDataBlob ()
These 3 functions are only using m_publicStateProperties for data carrier .

int | getGenericDataLength ()
void | setGenericData (char *blob, int length)

Public Attributes

int | type
The ZonaObject's type.

int | parent
This object's parent id.

ZonaPropertyData | m_publicDisplayProperties
ZonaPropertyData | m_publicStateProperties
ZonaPropertyData | m_privateProperties
ZonaPropertyData | m_systemProperties
int | id
The id of the object.

Detailed Description

ZonaObject.

Objects of this class are streamable.

Definition at line 50 of file ZonaObject.h.

Constructor & Destructor Documentation

ZonaObject ( )

initializes all fields to 0, and sets the Blob to NULL

ZonaObject ( const ZonaObject & other )

Deep copy constructor.

~ZonaObject ( )

ZonaObject | ( | short | type,
 |  | int | id
 | ) |

Initializes the structure with passed in arguments.

Member Function Documentation

ZonaObject& operator= ( const ZonaObject & other )

ZWString toString ( )

Returns a descrption of the object.

For debugging purposes.

Reimplemented in NamedZonaObject.

ZonaPropertyData* getPublicDisplayPropertyData ( ) [inline]

returns ptr to the ZonaPropertyData, which has actual data payload and length.

The memory will be freed when this ZonaPropertyData is destroyed.

Definition at line 78 of file ZonaObject.h.

References m_publicDisplayProperties.

ZonaPropertyData* getPublicStatePropertyData ( ) [inline]

Definition at line 80 of file ZonaObject.h.

References m_publicStateProperties.

ZonaPropertyData* getPrivatePropertyData ( ) [inline]

Definition at line 82 of file ZonaObject.h.

References m_privateProperties.

ZonaPropertyData* getSystemPropertyData ( ) [inline]

Definition at line 84 of file ZonaObject.h.

References m_systemProperties.

void setPublicDisplayPropertyData ( ZonaPropertyData & p ) [inline]

sets ptr to the ZonaPropertyData, which has actual data payload and length.

The memory will be freed when this ZonaPropertyData is destroyed.

Definition at line 91 of file ZonaObject.h.

References m_publicDisplayProperties.

void setPublicStatePropertyData ( ZonaPropertyData & p ) [inline]

Definition at line 93 of file ZonaObject.h.

References m_publicStateProperties.

void setPrivatePropertyData ( ZonaPropertyData & p ) [inline]

Definition at line 95 of file ZonaObject.h.

References m_privateProperties.

void setSystemPropertyData ( ZonaPropertyData & p ) [inline]

Definition at line 97 of file ZonaObject.h.

References m_systemProperties.

void setId ( int theId ) [inline]

Definition at line 99 of file ZonaObject.h.

References PersistableObject::id.

void clearPropertyData ( )

virtual OutStream& serialize ( OutStream & os ) [virtual]

Store this object into a stream.

Parameters:
os The Out stream into which the object should be stored.
Returns:
The outstream which was passed in as the parameter, after the object was serialized into it.

Reimplemented from PersistableObject.

Reimplemented in NamedZonaObject.

virtual InStream& deserialize ( InStream & is ) [virtual]

Extract this object from a stream.

Parameters:
is The In stream from which the object should be extracted.
Returns:
The instream which was passed in as the parameter, after the object was extracted from it.

Reimplemented from PersistableObject.

Reimplemented in NamedZonaObject.

virtual void appendToZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented from PersistableObject.

Reimplemented in NamedZonaObject.

virtual void extractFromZonaMessage ( ZonaMessage * zm ) [virtual]

Reimplemented from PersistableObject.

Reimplemented in NamedZonaObject.

void setParent ( int aParent ) [inline]

Definition at line 130 of file ZonaObject.h.

References parent.

void setType ( int aType ) [inline]

Definition at line 132 of file ZonaObject.h.

short getType ( ) [inline]

Definition at line 134 of file ZonaObject.h.

void setClassId ( short value )

short getClassId ( )

char* getGenericDataBlob ( )

These 3 functions are only using m_publicStateProperties for data carrier .

limited usage

int getGenericDataLength ( )

void setGenericData | ( | char * | blob,
 |  | int | length
 | ) |

Member Data Documentation

int type

The ZonaObject's type.

This can be used by the game developer to distinguish the types of object, but it is not used by ZAF.

Definition at line 124 of file ZonaObject.h.

int parent

This object's parent id.

The id must be the id of an existing ZonaObject. If it has no parent, this should be 0.

Definition at line 127 of file ZonaObject.h.

Referenced by setParent().

ZonaPropertyData m_publicDisplayProperties

Definition at line 158 of file ZonaObject.h.

Referenced by getPublicDisplayPropertyData(), and setPublicDisplayPropertyData().

ZonaPropertyData m_publicStateProperties

Definition at line 159 of file ZonaObject.h.

Referenced by getPublicStatePropertyData(), and setPublicStatePropertyData().

ZonaPropertyData m_privateProperties

Definition at line 160 of file ZonaObject.h.

Referenced by getPrivatePropertyData(), and setPrivatePropertyData().

ZonaPropertyData m_systemProperties

Definition at line 161 of file ZonaObject.h.

Referenced by getSystemPropertyData(), and setSystemPropertyData().

int id [inherited]

The id of the object.

Definition at line 40 of file PersistableObject.h.

Referenced by setId().

The documentation for this class was generated from the following file:
  • ZonaObject.h


ZonaObject Member List

This is the complete list of members for ZonaObject, including all inherited members.
appendToZonaMessage(ZonaMessage *zm) | ZonaObject | [virtual]
clearPropertyData() | ZonaObject |
deserialize(InStream &is) | ZonaObject | [virtual]
extractFromZonaMessage(ZonaMessage *zm) | ZonaObject | [virtual]
getClassId() | ZonaObject |
getGenericDataBlob() | ZonaObject |
getGenericDataLength() | ZonaObject |
getPrivatePropertyData() | ZonaObject | [inline]
getPublicDisplayPropertyData() | ZonaObject | [inline]
getPublicStatePropertyData() | ZonaObject | [inline]
getSystemPropertyData() | ZonaObject | [inline]
getType() | ZonaObject | [inline]
id | PersistableObject |
m_privateProperties | ZonaObject |
m_publicDisplayProperties | ZonaObject |
m_publicStateProperties | ZonaObject |
m_systemProperties | ZonaObject |
operator=(const ZonaObject &other) | ZonaObject |
PersistableObject::operator=(const PersistableObject &other) | PersistableObject |
parent | ZonaObject |
PersistableObject() | PersistableObject |
PersistableObject(const PersistableObject &other) | PersistableObject |
serialize(OutStream &os) | ZonaObject | [virtual]
setClassId(short value) | ZonaObject |
setGenericData(char *blob, int length) | ZonaObject |
setId(int theId) | ZonaObject | [inline]
setParent(int aParent) | ZonaObject | [inline]
setPrivatePropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setPublicDisplayPropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setPublicStatePropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setSystemPropertyData(ZonaPropertyData &p) | ZonaObject | [inline]
setType(int aType) | ZonaObject | [inline]
toString() | ZonaObject |
type | ZonaObject |
ZonaObject() | ZonaObject |
ZonaObject(const ZonaObject &other) | ZonaObject |
ZonaObject(short type, int id) | ZonaObject |
~PersistableObject() | PersistableObject | [virtual]
~ZonaObject() | ZonaObject |


ZonaServices Class Reference

Inheritance diagram for ZonaServices:

BaseServices List of all members.

Public Member Functions

ZonaServices (bool messageBuffering=true, bool autoUpdate=false)
Constructor.

~ZonaServices ()
Destructor.

int | getCharacters (ZonaClientCharacterPtrVector &zccVector)
Returns the character objects associated with the user's login Id.

int | getNewChildEntityId ()
Get a global unique id for a new Child Entity.

int | createSingleChildEntity (ZonaClientEntity &aEntity)
Create one Child Entity.

int | createMultipleChildEntities (ZonaClientEntityPtrVector &zChars)
create mulitiple Child Entities, Success/failure is reported via an asynchronous notification onNotifyChildCreate.

int | deleteChildEntity (int childEntityId)
Deletes child entity from the database and exits it from the world.

int | publishEntityPropertyUpdates (int entityId)
Publish Dirty Properties on a specific Entity.

int | publishAllEntityProperties (int entityId)
Publish All Properties on a specific Entity.

int | getIdForCharacterName (const char *name, int &id)
Returns the id for a character with a particular name.

int | getIdForGuildName (const char *name, int &id)
Similar to the getIdForCharacterName(), but instead the id of a guild is retrieved.

int | createCharacter (ZonaClientCharacter &newCharacter)
Creates new persistent character, and assigns ids to it.

int | deleteCharacter (int characterId)
Deletes the character specified by characterId.

int | createGuild (ZonaClientGuild *zcg, int entityId)
Creates a new persistent Guild Creates, assigns an id to it and subscribes the client to updates.

int | deleteGuild (ZonaClientGuild *zcg, int entityId)
Deletes a Guild.

int | joinGuild (int guildId)
Joins the active character to the specified guild.

int | removeGuildMember (int guildId, int charId)
removes a character from the guild.

int | inviteGuildMember (int guildId, int charId)
Invites the character into the guild.

bool | addGuildModerator (int guildId, int charId)
bool | removeGuildModerator (int guildId, int charId)
bool | getModerators (int guildId, IntVector &vec)
int | fetchMyGuilds (ZonaClientGuildPtrVector &gpv)
Retrieves all accessible Guilds and subscribes the client to guild updates.

int | monitorGuildUpdates (GuildCallback &guildCallback)
Sets the handler for guild update messages.

int | stopMonitorGuildUpdates ()
Sets the guild update handler to a blank handler which does not react to guild updates.

int | sendChatMessage (const ChatMsg &m)
Sends a Chat message.

int | setChatHandler (ChatType type, ChatCallback &chatCallback)
Associates a default chat message handler for specific Chat Type.

int | stopMonitorChat (ChatType type)
Unsubscribe the default handler for chat messages of specified TYPE.

void | setFilterOptions (bool options)
Toggles use of client side filtering.

int | setChatHandler (int entityId, ChatCallback &chatCallback)
Associates a chat handler with a particular guild / character.

int | stopMonitorChat (int entityId)
Unsubscribe the handler for chat messages from specified guilds.

int | setDefaultChatHandler (ChatCallback &chatCallback)
Sets a default message handler for messages Priority : This handler type has lowest priority.

int | stopMonitorChatDefault (void)
Unsubscribe the default handler for chat messages.

int | deletePersistentMessage (int messageId)
Deletes a persistent mail message.

int | fetchPersistentMessages (ChatMsgPtrVector &mpv, int recipientId, int flag=0, INT64 minDate=-1, INT64 maxDate=-1, int senderId=-1)
Retrieves persistent MailMessages according to specified filters.

GameGuildServiceInterface * getGameGuildServices ()
This method returns a handle to Game Guild Services Interface implementation.

int | login (char *dispatcherURL, char *clientName, char *password)
(BaseServices) Logs users onto the Zona service.

int | loginAsync (char *dispatcherURL, char *clientName, char *password)
(BaseServices) Logs users onto the Zona service asynchronously.

void | logoff ()
(BaseServices) Logs users off the Zona service, ending all services.

int | getLoginStatus ()
(BaseServices) Return the current login status.

int | sendGameStateMsg (char *stateData, short dataSize)
(BaseServices) Communicates game state events to the Zona game servers.

int | sendGameStateMsg (int entityId, char *stateData, short dataSize)
(BaseServices) Communicates game state events to the Zona game servers.

int | monitorGameState (GameStateCallback *callback)
(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

int | monitorEntityUpdates (EntityCallback *callback)
(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

int | subscribeToGameStateMsgs (int entityId, int msgFilters)
(BaseServices) Subscribes an entity to updates in game state from the Zona service.

int | getSessionId () const
(BaseServices) Get player session Id, which is assigned to the player upon login

const char * | getLoginName () const
(BaseServices) Get player name used for login

int | getCharacterId () const
(BaseServices) Returns the character id which was picked by the user.

ZonaClientCharacter * getCharacter ()
int | getMillsSinceLogin ()
(BaseServices) Get Milliseconds since the user logined in

int | getMillsSinceZGST ()
(BaseServices) Get Milliseconds since Zona Global Sync Time The ZGST is reset every day and its purpose is to allow for 4 byte timestamp that are valid for 24 hours

char * | getZAFVersion ()
(BaseServices) Returns pointer to string of current version of ZAF static lib Do not delete the string.

bool | setGameVersion (char *gameVersion, short size)
(BaseServices) This function gives the CAPI a client specified version string to track the current version of the client game code.

jlong | getGlobalServerLoginTime ()
(BaseServices) Get global server login time This is the last time the servers time was set to zero.

ZonaClientEntity * | getEntityWithId (int eid)
(BaseServices) Retrieve ZonaClientEntity from Entity Manager

int | getAllEntities (ZonaBaseEntityPtrVector *entityVecPtr)
(BaseServices) Fetches a list of all local entities(character and children) that have entered the game as well as all remote entities in the same sphere as the character and children from the Zona Entity Manager.

void | processMessage (int count=1)
If autoUpdate is false during the construction of ZonaServices, game code should call this method preferably in the game loop to process messages received from the network.

int | getMessageBufferCount ()
This method returns the count of pending incoming network messages that need to be processed.

Static Public Member Functions

int | a2w (const char *as, wchar_t *sBuf, int sBufSize)
(BaseServices) This function converts a 8bit based ASCII string to a wide character unicode string.

int | w2a (const wchar_t *ws, char *sBuf, int sBufSize)
(BaseServices) This function converts a wide character UNICODE string to 8 bit based ASCII string.

Public Attributes

char | lastError [255]

Protected Member Functions

void | initializeChatServices ()
void | initializeServices ()
void | setServiceEntityId (int id)

Protected Attributes

ZonaClient * | zonaClient
SessionIdManager * | sid
GameStateService * | gameStateService
ServiceState * | m_state
bool | m_autoUpdate
bool | m_messageBuffering
BaseBuffer * | _downcastBuffer

Detailed Description

ZonaServices

Provides user services based on permissions and uses callbacks to comunicate the information.

Definition at line 66 of file ZonaServices.h.

Constructor & Destructor Documentation

ZonaServices | ( | bool | messageBuffering = true,
 |  | bool | autoUpdate = false
 | ) |

Constructor.

Parameters:
messageBuffering | Enable/Disable outbound Message Buffering. @ The default value is true.
autoUpdate | Enable/Disable automatic update of inbound messages. If set to false, client would have to periodically call processMessage in order to flush and process inbound messages. @ The default value is true.

~ZonaServices ( )

Destructor.

Member Function Documentation

int getCharacters ( ZonaClientCharacterPtrVector & zccVector )

Returns the character objects associated with the user's login Id.

It returns an empty ZonaClientCharacterPtrVector if no character exists.

It is the responsibility of the caller to delete the character objects pointed to by the pointers in the returned ZonaClientCharacterPtrVector. (Don't delete the character object that is going to be selected)

Parameters:
zccVector a vector of pointers to character objects associated with the user.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int getNewChildEntityId ( )

Get a global unique id for a new Child Entity.

Returns:
new Entity Id

int createSingleChildEntity ( ZonaClientEntity & aEntity )

Create one Child Entity.

Success/failure is reported via an asynchronous notification onNotifyChildCreate.

Parameters:
aEntity place to store ChildEntity, whose parent id should be set in aEntity.parentId when calling
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.
See also:
ZonaErrors.h

int createMultipleChildEntities ( ZonaClientEntityPtrVector & zChars )

create mulitiple Child Entities, Success/failure is reported via an asynchronous notification onNotifyChildCreate.

Parameters:
zChars a vector of pointers to the new entities to be created. zChars[i].parantId must be set when calling.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.
See also:
ZonaErrors.h

int deleteChildEntity ( int childEntityId )

Deletes child entity from the database and exits it from the world.

Parameters:
childEntityId The child entity to be destroyed and the id will recycled The child entity will also be exited from the game. There is no need for the game code to call exitEntity for the deleted entities. The callback childRemoveUpdate(...) will be called to inform success/failure
Returns:
ERR_SUCCESS if childEntityId is valid else error

int publishEntityPropertyUpdates ( int entityId )

Publish Dirty Properties on a specific Entity.

Parameters:
entityId The entity whose dirty properties should be published
Returns:
ERR_SUCCESS if publish was sent

int publishAllEntityProperties ( int entityId )

Publish All Properties on a specific Entity.

Parameters:
entityId The entity whose properties should be published
Returns:
ERR_SUCCESS if publish was sent

int getIdForCharacterName | ( | const char * | name,
 |  | int & | id
 | ) |

Returns the id for a character with a particular name.

This method can be used to get the id of a character that has been discovered outside of the game (for example, when someone meets the player on the street and tells him his character's name.) If the character is met in the game, the id should be obtained from GameStateCallback.entityJoinedSphere(), and this method should not be called. This is a blocking call.

Parameters:
name | The name of the character for which the id should be looked up.
id | A reference to an integer which will be set to the fetched value. If the character is not found, the id will be set to 0
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int getIdForGuildName | ( | const char * | name,
 |  | int & | id
 | ) |

Similar to the getIdForCharacterName(), but instead the id of a guild is retrieved.

See also:
getIdForCharacterName()

int createCharacter ( ZonaClientCharacter & newCharacter )

Creates new persistent character, and assigns ids to it.

Parameters:
newCharacter place to store the ZonaClientCharacter. newCharacter.id must be 0 when calling this function for all new characters. If the creation succeeds, the newCharacter.id will be set to the permanent id assigned to the character by the server. Note: This function cannot be called after call to "enter player", otherwise it would return ERR_INVALID_OPERATION
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int deleteCharacter ( int characterId )

Deletes the character specified by characterId.

All messages sent to the character are deleted, but all messages sent by the charcter are not deleted. The character is also removed from all guilds. If the character was an moderator of a guild, the guild's moderator will be cleared, but the guild will not be erased. Note: This function cannot be called after call to "enter player", otherwise it would return ERR_INVALID_OPERATION

Parameters:
characterId The id of the character to be deleted.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

int createGuild | ( | ZonaClientGuild * | zcg,
 |  | int | entityId
 | ) |

Creates a new persistent Guild Creates, assigns an id to it and subscribes the client to updates.

for that guild.

Parameters:
zcg | The guild to be created.
entityId | The entity that has requested the guild to be created
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.
See also:
ZonaErrors.h

int deleteGuild | ( | ZonaClientGuild * | zcg,
 |  | int | entityId
 | ) |

Deletes a Guild.

If the guild is persistent, all messages sent to the guild are also deleted.

Parameters:
zcg | The guild to be delted.
entityId | The entity that has requested the guild to be deleted
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.
See also:
ZonaErrors.h

int joinGuild ( int guildId )

Joins the active character to the specified guild.

The active character is set by calling ZonaClientCharacter.select().

Parameters:
guildId The id of the guild which the active character should join.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.
See also:
ZonaErrors.h

int removeGuildMember | ( | int | guildId,
 |  | int | charId
 | ) |

removes a character from the guild.

Parameters:
guildId | The id of the guild from which the character should be removed
charId | The id of the character to be removed from the guild
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.
See also:
ZonaErrors.h

int inviteGuildMember | ( | int | guildId,
 |  | int | charId
 | ) |

Invites the character into the guild.

The invited character does not join the guild until he actually calls joinGuild(). inviteGuildMember() also informs the server that the invited character has permission to join the guild.

Parameters:
guildId | The id of the guild into which the character is invited
charId | The id of the character to invite into the guild
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to invite the character into the guild, an error is returned.
See also:
ZonaErrors.h

bool addGuildModerator | ( | int | guildId,
 |  | int | charId
 | ) |

bool removeGuildModerator | ( | int | guildId,
 |  | int | charId
 | ) |

bool getModerators | ( | int | guildId,
 |  | IntVector & | vec
 | ) |

int fetchMyGuilds ( ZonaClientGuildPtrVector & gpv )

Retrieves all accessible Guilds and subscribes the client to guild updates.

A guild is accessible if it is a system guild or if the selected character (chosen with ZonaClientCharacter.select() ) is a memeber of that guild. GuildCallback is called whenever the membership or other settings of the guild change.

Parameters:
gpv The vector holding pointers to accessible Guild objects.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.
See also:
ZonaErrors.h

int monitorGuildUpdates ( GuildCallback & guildCallback )

Sets the handler for guild update messages.

ZonaServices will call the apropriate functions of the callback when guild updates are sent to the client.

Parameters:
guildCallback a reference to a callback object to receive guild messages.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, an error is returned.

int stopMonitorGuildUpdates ( )

Sets the guild update handler to a blank handler which does not react to guild updates.

Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.

int sendChatMessage ( const ChatMsg & m )

Sends a Chat message.

The recipient and other attributes of the message are set in the ChatMsg class. This method is used to send all chat messages, including sphere chat. To send a sphere chat message, set m.recipientId to m.RECIPIENT_ID_SPHERE. To send a system wide message, set m.recipientId to m.RECIPIENT_ID_SYSTEMWIDE.

Parameters:
m Message to send. If the send is successful, m.id will be assigned a non-zero value. At a minimum, the m.recipientId is required to be non-zero.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.

int setChatHandler | ( | ChatType | type,
 |  | ChatCallback & | chatCallback
 | ) |

Associates a default chat message handler for specific Chat Type.

Messages sent with the specified type will be forwarded to the specified callback by default. This can be overridden per guild by calling setChatHandler(). Priority : This handler type has lower priority than the handler associated for guildId / characterid.

Parameters:
type | The chat message type
chatCallback | The callback to be called if the message has the specified type
Returns:
errorcode

int stopMonitorChat ( ChatType type )

Unsubscribe the default handler for chat messages of specified TYPE.

Parameters:
type The ChatType to be unsubscribed.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.

void setFilterOptions ( bool options )

Toggles use of client side filtering.

Parameters:
options TRUE for client filtering on, FALSE for turning client filter off Note: does not stop server side filter, the words for client side (and server) filtering are set in zona_home/zona_word_filter.ini on the GSS and downloaded to the client everytime a user logs on.
Returns:
none

int setChatHandler | ( | int | entityId,
 |  | ChatCallback & | chatCallback
 | ) |

Associates a chat handler with a particular guild / character.

Messages sent "to a guild" / "from a character" with the specified id will be forwarded to the specified chatCallback. Priority : This handler type has highest priority.

Parameters:
entityId | The guildId / characterid for which the callback handler is being registered
chatCallback | The callback to be called if the recipient guild / sending character has the specified id
Returns:
errorcode

int stopMonitorChat ( int entityId )

Unsubscribe the handler for chat messages from specified guilds.

Parameters:
entityId The guildid / characterid to be unsubscribed.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.

int setDefaultChatHandler ( ChatCallback & chatCallback )

Sets a default message handler for messages Priority : This handler type has lowest priority.

Parameters:
chatCallback The callback to be used.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.

int stopMonitorChatDefault ( void )

Unsubscribe the default handler for chat messages.

Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h.

int deletePersistentMessage ( int messageId )

Deletes a persistent mail message.

Parameters:
messageId Message id to delete. Message with that id must exist.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful character selection call, or if the active character does not have permision to perform this operation, an error is returned.

int fetchPersistentMessages | ( | ChatMsgPtrVector & | mpv,
 |  | int | recipientId,
 |  | int | flag = 0,
 |  | INT64 | minDate = -1,
 |  | INT64 | maxDate = -1,
 |  | int | senderId = -1
 | ) |

Retrieves persistent MailMessages according to specified filters.

Parameters:
mpv | The vector containing pointers to fetched MailMessages. It is the caller's responsibility to free the memory pointed to by those pointers.
recipientId | The Id of the intended recipient of the message. it can either be a characterId returned by getCharacterId() or an accessible guild id, returned by getAccessibleGuilds().
flag | a bit field specifying various properties of the message. See ChatMsg class for more info.
minDate | an optional minimum sent date filter. The parameter is the number of seconds elapsed since midnight, 1/1/1970, as defined by the time() function. Default is midnight, 1/1/1970.
maxDate | an optional maximum sent date filter. The parameter is the number of seconds elapsed since midnight, 1/1/1970, as defined by the time() function. Default is now, the value returned by the time() function.
senderId | an optional value specifying who the fetchedMessages can be from. It can be any characterId. Default is that the fetched messages could have been sent by anyone.
Returns:
ERR_SUCCESS or one of the errors defined in ZonaErrors.h. If the function is called before a successful login, an error is returned.
See also:
ZonaErrors.h

GameGuildServiceInterface* getGameGuildServices ( )

This method returns a handle to Game Guild Services Interface implementation.

Returns:
Pointer to GameGuildServicesInterface object .

void initializeChatServices ( ) [protected]

void initializeServices ( ) [protected, virtual]

Reimplemented from BaseServices.

void setServiceEntityId ( int id ) [protected]

int login | ( | char * | dispatcherURL,
 |  | char * | clientName,
 |  | char * | password
 | ) | [inherited]

(BaseServices) Logs users onto the Zona service.

Parameters:
dispatcherURL | URL of Dispatcher Must be in the form of http://MyDispatcher:port i.e. http://192.168.1.10:2000
clientName | player identification
password | validation of player identity
Returns:
ERR_NODATABASE, ERR_SUCCESS or ERR_LOGON_FAIL
See also:
ZonaErrors.h

int loginAsync | ( | char * | dispatcherURL,
 |  | char * | clientName,
 |  | char * | password
 | ) | [inherited]

(BaseServices) Logs users onto the Zona service asynchronously.

The calling thread returns immediately. Status of login can be queried by calling getLoginStatus().

Parameters:
dispatcherURL | URL of Dispatcher Must be in the form of http://MyDispatcher:port i.e. http://192.168.1.10:2000
clientName | player identification
password | validation of player identity
Returns:
ERR_NODATABASE, ERR_SUCCESS or ERR_LOGON_FAIL
See also:
ZonaErrors.h

void logoff ( ) [inherited]

(BaseServices) Logs users off the Zona service, ending all services.

int getLoginStatus ( ) [inherited]

(BaseServices) Return the current login status.

Used for asynchronous login.

Returns:
NOT_LOGGED_IN, LOGGED_IN, LOGIN_IN_PROGRESS, LOGOUT_IN_PROGRESS, LOGIN_FAIL_NODATABASE, LOGIN_FAIL_WRONG_PASS

int sendGameStateMsg | ( | char * | stateData,
 |  | short | dataSize
 | ) | [inherited]

(BaseServices) Communicates game state events to the Zona game servers.

It may also be used for communicating changes in the state of dynamic game objects in special cases, specifically where setting the character properties will not apply.

Parameters:
stateData | a pointer to an arbitrary data structure holding entity state information
dataSize | the length, in bytes, of the data pointed to stateData
Returns:
ERR_SUCCESS upon successful transmission of the game state information

ERR_MESSAGE_SEND upon failure to transmit game state information.

int sendGameStateMsg | ( | int | entityId,
 |  | char * | stateData,
 |  | short | dataSize
 | ) | [inherited]

(BaseServices) Communicates game state events to the Zona game servers.

It may also be used for communicating changes in the state of dynamic game objects in special cases, specifically where setting the entity properties will not apply.

Parameters:
entityId | id of the entity whose game state is being sent
stateData | a pointer to an arbitrary data structure holding entity state information
dataSize | the length, in bytes, of the data pointed to stateData
Returns:
ERR_SUCCESS upon successful transmission of the game state information

ERR_MESSAGE_SEND upon failure to transmit game state information.

int monitorGameState ( GameStateCallback * callback ) [inherited]

(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

Parameters:
callback Implemented callback class pointer for GameStateCallback
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int monitorEntityUpdates ( EntityCallback * callback ) [inherited]

(BaseServices) Sets up the Api for receiving messages from the server Should be called at least once and only once during startup.

Parameters:
callback Implemented callback class pointer for EntityCallback
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int subscribeToGameStateMsgs | ( | int | entityId,
 |  | int | msgFilters
 | ) | [inherited]

(BaseServices) Subscribes an entity to updates in game state from the Zona service.

Must be called at least once for each entity to receive any messages on behalf of the entity

Parameters:
entityId | Id of the entity that should start receiving state update information
msgFilters | subscribes to messages specified in the msgFilters, use one of ZONA_MSG_*
Returns:
ERR_SUCCESS when successfully subscribing to game state updates

ERR_SUBSCRIBE upon failing to subscribe to game state information.

int getSessionId ( ) const [inherited]

(BaseServices) Get player session Id, which is assigned to the player upon login

Returns:
player session Id

const char* getLoginName ( ) const [inherited]

(BaseServices) Get player name used for login

Returns:
user name

int getCharacterId ( ) const [inherited]

(BaseServices) Returns the character id which was picked by the user.

If this function is called before pickCharacter() is called, it returns 0;

ZonaClientCharacter* getCharacter ( ) [inherited]

int getMillsSinceLogin ( ) [inherited]

(BaseServices) Get Milliseconds since the user logined in

Returns:
number of mills since login

int getMillsSinceZGST ( ) [inherited]

(BaseServices) Get Milliseconds since Zona Global Sync Time The ZGST is reset every day and its purpose is to allow for 4 byte timestamp that are valid for 24 hours

Returns:
number of mills since login

char* getZAFVersion ( ) [inherited]

(BaseServices) Returns pointer to string of current version of ZAF static lib Do not delete the string.

Returns:
Version of Zona Application Framework

bool setGameVersion | ( | char * | gameVersion,
 |  | short | size
 | ) | [inherited]

(BaseServices) This function gives the CAPI a client specified version string to track the current version of the client game code.

This function MUST be called before login can be called. The server plugin must validate this game specific version string. If the client game version does not match the server plugin the client must upgraded before being able to log on successfully.

Parameters:
gameVersion | string of client game code version validated by server plugin before successful login (size can be upto MAX_INI_BUFFER defined in ZonaGlobalConstants.h 8-bit char ASCII string)
size | Size of the gameVersion
Returns:
void

jlong getGlobalServerLoginTime ( ) [inherited]

(BaseServices) Get global server login time This is the last time the servers time was set to zero.

This allows getMillsSinceZGST to return mills since ZGST. Given a known zero point allows time stamps to be a smaller value. The getMillsSinceZGST returns a 32 bit value at millisecond accuracy. Note: These time stamps should not be used for long term time stamps. Use the OS full 64 bit time stamps for time stamps that will need to date data for more than 24 hours. This function is designed for use of prediction algorithms that require a syncronized time stamp between clients.

Returns:
global server time when login

ZonaClientEntity* getEntityWithId ( int eid ) [inherited]

(BaseServices) Retrieve ZonaClientEntity from Entity Manager

Parameters:
eid entity ID
Returns:
a pointer to ZonaClientEntity if found, otherwise NULL.

int getAllEntities ( ZonaBaseEntityPtrVector * entityVecPtr ) [inherited]

(BaseServices) Fetches a list of all local entities(character and children) that have entered the game as well as all remote entities in the same sphere as the character and children from the Zona Entity Manager.

The function returns a count of all such entities. This call is executed locally and does not access the server. The references to entities are not guaranteed to be legal for remote entities after the call is returned.

This method will be deprecated in the future.

Parameters:
entityVecPtr A vector holding pointers to ZonaBaseEntity
Returns:
total number of entities

int a2w | ( | const char * | as,
 |  | wchar_t * | sBuf,
 |  | int | sBufSize
 | ) | [static, inherited]

(BaseServices) This function converts a 8bit based ASCII string to a wide character unicode string.

Call this function once with a value of a sBufSize=0 to get size of buffer the user should create to get copied into. Then allocate memory for the UNICODE buffer and call function again to fill buffer.

Returns:
The size of the buffer copied or size of buffer needed A zero value indicated error

int w2a | ( | const wchar_t * | ws,
 |  | char * | sBuf,
 |  | int | sBufSize
 | ) | [static, inherited]

(BaseServices) This function converts a wide character UNICODE string to 8 bit based ASCII string.

Call this function once with a value of a sBufSize=0 to get size of buffer user should create to get copied into. Then allocate memory for the ASCII buffer and call function again to fill buffer.

Returns:
The size of the buffer copied or size of buffer needed A zero value indicated error

void processMessage ( int count = 1 ) [inherited]

If autoUpdate is false during the construction of ZonaServices, game code should call this method preferably in the game loop to process messages received from the network.

Parameters:
count The number of messages to flush from the inbound message buffer . @ The default value is 1.
Returns:
void

int getMessageBufferCount ( ) [inherited]

This method returns the count of pending incoming network messages that need to be processed.

This method is typically used when client specifies the autoUpdate parameter as false in the ZonaServices constructor

Returns:
The number of pending messages in the inbound message buffer .

Member Data Documentation

char lastError[255]

Definition at line 451 of file ZonaServices.h.

ZonaClient* zonaClient [protected, inherited]

Definition at line 346 of file BaseServices.h.

SessionIdManager* sid [protected, inherited]

Definition at line 347 of file BaseServices.h.

GameStateService* gameStateService [protected, inherited]

Definition at line 348 of file BaseServices.h.

ServiceState* m_state [protected, inherited]

Definition at line 349 of file BaseServices.h.

bool m_autoUpdate [protected, inherited]

Definition at line 350 of file BaseServices.h.

bool m_messageBuffering [protected, inherited]

Definition at line 351 of file BaseServices.h.

BaseBuffer* _downcastBuffer [protected, inherited]

Definition at line 352 of file BaseServices.h.

The documentation for this class was generated from the following file:
  • ZonaServices.h


ZonaServices Member List

This is the complete list of members for ZonaServices, including all inherited members.
_downcastBuffer | BaseServices | [protected]
a2w(const char *as, wchar_t *sBuf, int sBufSize) | BaseServices | [static]
addGuildModerator(int guildId, int charId) | ZonaServices |
BaseServices(bool bMessageBuffering=true, bool bautoUpdate=true) | BaseServices |
createCharacter(ZonaClientCharacter &newCharacter) | ZonaServices |
createGuild(ZonaClientGuild *zcg, int entityId) | ZonaServices |
createMultipleChildEntities(ZonaClientEntityPtrVector &zChars) | ZonaServices |
createSingleChildEntity(ZonaClientEntity &aEntity) | ZonaServices |
deleteCharacter(int characterId) | ZonaServices |
deleteChildEntity(int childEntityId) | ZonaServices |
deleteGuild(ZonaClientGuild *zcg, int entityId) | ZonaServices |
deletePersistentMessage(int messageId) | ZonaServices |
fetchMyGuilds(ZonaClientGuildPtrVector &gpv) | ZonaServices |
fetchPersistentMessages(ChatMsgPtrVector &mpv, int recipientId, int flag=0, INT64 minDate=-1, INT64 maxDate=-1, int senderId=-1) | ZonaServices |
gameStateService | BaseServices | [protected]
getAllEntities(ZonaBaseEntityPtrVector *entityVecPtr) | BaseServices |
getCharacter() | BaseServices |
getCharacterId() const | BaseServices |
getCharacters(ZonaClientCharacterPtrVector &zccVector) | ZonaServices |
getEntityWithId(int eid) | BaseServices |
getGameGuildServices() | ZonaServices |
getGlobalServerLoginTime() | BaseServices |
getIdForCharacterName(const char *name, int &id) | ZonaServices |
getIdForGuildName(const char *name, int &id) | ZonaServices |
getLoginName() const | BaseServices |
getLoginStatus() | BaseServices |
getMessageBufferCount() | BaseServices |
getMillsSinceLogin() | BaseServices |
getMillsSinceZGST() | BaseServices |
getModerators(int guildId, IntVector &vec) | ZonaServices |
getNewChildEntityId() | ZonaServices |
getSessionId() const | BaseServices |
getZAFVersion() | BaseServices |
initializeChatServices() | ZonaServices | [protected]
initializeServices() | ZonaServices | [protected, virtual]
inviteGuildMember(int guildId, int charId) | ZonaServices |
joinGuild(int guildId) | ZonaServices |
lastError | ZonaServices |
login(char *dispatcherURL, char *clientName, char *password) | BaseServices |
loginAsync(char *dispatcherURL, char *clientName, char *password) | BaseServices |
logoff() | BaseServices |
m_autoUpdate | BaseServices | [protected]
m_messageBuffering | BaseServices | [protected]
m_state | BaseServices | [protected]
monitorEntityUpdates(EntityCallback *callback) | BaseServices |
monitorGameState(GameStateCallback *callback) | BaseServices |
monitorGuildUpdates(GuildCallback &guildCallback) | ZonaServices |
processMessage(int count=1) | BaseServices |
publishAllEntityProperties(int entityId) | ZonaServices |
publishEntityPropertyUpdates(int entityId) | ZonaServices |
removeGuildMember(int guildId, int charId) | ZonaServices |
removeGuildModerator(int guildId, int charId) | ZonaServices |
sendChatMessage(const ChatMsg &m) | ZonaServices |
sendGameStateMsg(char *stateData, short dataSize) | BaseServices |
sendGameStateMsg(int entityId, char *stateData, short dataSize) | BaseServices |
setChatHandler(ChatType type, ChatCallback &chatCallback) | ZonaServices |
setChatHandler(int entityId, ChatCallback &chatCallback) | ZonaServices |
setDefaultChatHandler(ChatCallback &chatCallback) | ZonaServices |
setFilterOptions(bool options) | ZonaServices |
setGameVersion(char *gameVersion, short size) | BaseServices |
setServiceEntityId(int id) | ZonaServices | [protected]
sid | BaseServices | [protected]
stopMonitorChat(ChatType type) | ZonaServices |
stopMonitorChat(int entityId) | ZonaServices |
stopMonitorChatDefault(void) | ZonaServices |
stopMonitorGuildUpdates() | ZonaServices |
subscribeToGameStateMsgs(int entityId, int msgFilters) | BaseServices |
w2a(const wchar_t *ws, char *sBuf, int sBufSize) | BaseServices | [static]
zonaClient | BaseServices | [protected]
ZonaServices(bool messageBuffering=true, bool autoUpdate=false) | ZonaServices |
~BaseServices() | BaseServices |
~ZonaServices() | ZonaServices |


ZonaTimeUtils Class Reference

ZonaTimeUtils. More...

List of all members.

Public Member Functions

ZonaTimeUtils ()
~ZonaTimeUtils ()

Static Public Member Functions

void | ZonaTimeToFileTime (jlong jtime, FILETIME *timeFT)
jlong | FileTimeToZonaTime (FILETIME *timeFT)
int | millsSinceGlobalSyncPoint (jlong localSyncPoint, int millsSinceZST)
jlong | millsAtCurrentTime ()

Detailed Description

ZonaTimeUtils.

Platform to Java Server time conversion tools

Definition at line 22 of file ZonaTimeUtils.h.

Constructor & Destructor Documentation

ZonaTimeUtils ( )

~ZonaTimeUtils ( )

Member Function Documentation

void ZonaTimeToFileTime | ( | jlong | jtime,
 |  | FILETIME * | timeFT
 | ) | [static]

jlong FileTimeToZonaTime ( FILETIME * timeFT ) [static]

int millsSinceGlobalSyncPoint | ( | jlong | localSyncPoint,
 |  | int | millsSinceZST
 | ) | [static]

jlong millsAtCurrentTime ( ) [static]

The documentation for this class was generated from the following file:
  • ZonaTimeUtils.h


ZonaTimeUtils Member List

This is the complete list of members for ZonaTimeUtils, including all inherited members.
FileTimeToZonaTime(FILETIME *timeFT) | ZonaTimeUtils | [static]
millsAtCurrentTime() | ZonaTimeUtils | [static]
millsSinceGlobalSyncPoint(jlong localSyncPoint, int millsSinceZST) | ZonaTimeUtils | [static]
ZonaTimeToFileTime(jlong jtime, FILETIME *timeFT) | ZonaTimeUtils | [static]
ZonaTimeUtils() | ZonaTimeUtils |
~ZonaTimeUtils() | ZonaTimeUtils |


ZScalarVector Class Template Reference

Inheritance diagram for ZScalarVector:

ZVector List of all members.

Public Member Functions

ZScalarVector ()
void | add (T &addObject)
Add element to the vector at the current position.

T & | operator[] (int index)
Returns the element at index.

T & | get (int index)
Returns the element at index.

T & | get ()
Returns the next element, during iteration.

void | remove ()
Removes the element at the current position.

bool | remove (T &remObject)
Removes an element from the vector.

bool | contains (T &object)
Check if the element is present in the vector.

void | start ()
Start the iterator.

bool | next ()
Used during iteration.

int | getSize () const
Returns the current number of elements in the vector.

void | clear ()
Removes all elements from the vector.

Protected Attributes

int | size
bool | m_disableDelete
ZVectorNode< T > * | headNode
ZVectorNode< T > * | currentNode
ZVectorNode< T > * | lastCurrentNode

template<class T>
class ZScalarVector< T >

Constructor & Destructor Documentation

ZScalarVector ( ) [inline]

Definition at line 247 of file ZVector.h.

Member Function Documentation

void add ( T & addObject ) [inline]

Add element to the vector at the current position.

Reimplemented from ZVector.

Definition at line 249 of file ZVector.h.

T& operator[] ( int index ) [inline, inherited]

Returns the element at index.

Definition at line 45 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::get().

T& get ( int index ) [inline, inherited]

Returns the element at index.

Definition at line 68 of file ZVector.h.

T& get ( ) [inline, inherited]

Returns the next element, during iteration.

Definition at line 78 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

void remove ( ) [inline, inherited]

Removes the element at the current position.

Definition at line 112 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), and ZVector< ZonaClientEntity * >::remove().

bool remove ( T & remObject ) [inline, inherited]

Removes an element from the vector.

Parameters:
remObject element to be removed from the vector

Definition at line 136 of file ZVector.h.

bool contains ( T & object ) [inline, inherited]

Check if the element is present in the vector.

Parameters:
object The element to look for
Returns:
returns true if a match was found

Definition at line 157 of file ZVector.h.

void start ( ) [inline, inherited]

Start the iterator.

Returns:
returns true if a match was found

Definition at line 178 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

bool next ( ) [inline, inherited]

Used during iteration.

Advances the pointer to the next element.

Returns:
returns false if the no more elements were found.

Definition at line 191 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

int getSize ( ) const [inline, inherited]

Returns the current number of elements in the vector.

Definition at line 213 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::operator[]().

void clear ( ) [inline, inherited]

Removes all elements from the vector.

Definition at line 220 of file ZVector.h.

Member Data Documentation

int size [protected, inherited]

Definition at line 237 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::getSize(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), and ZVector< ZonaClientEntity * >::ZVector().

bool m_disableDelete [protected, inherited]

Definition at line 238 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::add(), and ZVector< ZonaClientEntity * >::ZVector().

ZVectorNode<T>* headNode [protected, inherited]

Definition at line 239 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::remove(), ZVector< ZonaClientEntity * >::start(), ZVector< ZonaClientEntity * >::ZVector(), and ZVector< ZonaClientEntity * >::~ZVector().

ZVectorNode<T>* currentNode [protected, inherited]

Definition at line 240 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), ZVector< ZonaClientEntity * >::start(), and ZVector< ZonaClientEntity * >::ZVector().

ZVectorNode<T> * lastCurrentNode [protected, inherited]

Definition at line 240 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), and ZVector< ZonaClientEntity * >::start().

The documentation for this class was generated from the following file:
  • ZVector.h


ZScalarVector Member List

This is the complete list of members for ZScalarVector, including all inherited members.
add(T &addObject) | ZScalarVector | [inline]
clear() | ZVector | [inline]
contains(T &object) | ZVector | [inline]
currentNode | ZVector | [protected]
get(int index) | ZVector | [inline]
get() | ZVector | [inline]
getSize() const | ZVector | [inline]
headNode | ZVector | [protected]
lastCurrentNode | ZVector | [protected]
m_disableDelete | ZVector | [protected]
next() | ZVector | [inline]
operator[](int index) | ZVector | [inline]
remove() | ZVector | [inline]
remove(T &remObject) | ZVector | [inline]
size | ZVector | [protected]
start() | ZVector | [inline]
ZScalarVector() | ZScalarVector | [inline]
ZVector(bool disableDelete=true) | ZVector | [inline]
~ZVector() | ZVector | [inline]


ZString Class Reference

ZString. More...

List of all members.

Public Member Functions

ZString (const char *value="")
char | operator[] (int index) const
char & | operator[] (int index)
const char * | toString ()
const wchar_t * | toWString ()
bool | compare (const char *value)
void | append (const char *str)
int | length ()

Static Public Member Functions

int | w2a (const wchar_t *ws, char *sBuf, int sBufSize)
int | a2w (const char *as, wchar_t *sBuf, int sBufSize)

Detailed Description

ZString.

Simple multi platform string class

Definition at line 62 of file ZString.h.

Constructor & Destructor Documentation

ZString ( const char * value = "" )

Member Function Documentation

char operator[] ( int index ) const

char& operator[] ( int index )

const char* toString ( )

const wchar_t* toWString ( )

bool compare ( const char * value )

void append ( const char * str )

int length ( )

int w2a | ( | const wchar_t * | ws,
 |  | char * | sBuf,
 |  | int | sBufSize
 | ) | [static]

int a2w | ( | const char * | as,
 |  | wchar_t * | sBuf,
 |  | int | sBufSize
 | ) | [static]

The documentation for this class was generated from the following file:
  • ZString.h


ZString Member List

This is the complete list of members for ZString, including all inherited members.
a2w(const char *as, wchar_t *sBuf, int sBufSize) | ZString | [static]
append(const char *str) | ZString |
compare(const char *value) | ZString |
length() | ZString |
operator[](int index) const | ZString |
operator[](int index) | ZString |
toString() | ZString |
toWString() | ZString |
w2a(const wchar_t *ws, char *sBuf, int sBufSize) | ZString | [static]
ZString(const char *value="") | ZString |


ZVector Class Template Reference

Inheritance diagram for ZVector:

ZScalarVector List of all members.

Public Member Functions

ZVector (bool disableDelete=true)
ZVector.

~ZVector ()
T & | operator[] (int index)
Returns the element at index.

T & | get (int index)
Returns the element at index.

T & | get ()
Returns the next element, during iteration.

void | add (T &addObject)
Add element to the vector at the current position.

void | remove ()
Removes the element at the current position.

bool | remove (T &remObject)
Removes an element from the vector.

bool | contains (T &object)
Check if the element is present in the vector.

void | start ()
Start the iterator.

bool | next ()
Used during iteration.

int | getSize () const
Returns the current number of elements in the vector.

void | clear ()
Removes all elements from the vector.

Protected Attributes

int | size
bool | m_disableDelete
ZVectorNode< T > * | headNode
ZVectorNode< T > * | currentNode
ZVectorNode< T > * | lastCurrentNode

template<class T>
class ZVector< T >

Constructor & Destructor Documentation

ZVector ( bool disableDelete = true ) [inline]

ZVector.

Simple multi platform vector class. Please note that this class is not thread-safe.

Parameters:
disableDelete if the flag is true (default) deleting the vector will not delete the elements.

Definition at line 19 of file ZVector.h.

~ZVector ( ) [inline]

Definition at line 30 of file ZVector.h.

Member Function Documentation

T& operator[] ( int index ) [inline]

Returns the element at index.

Definition at line 45 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::get().

T& get ( int index ) [inline]

Returns the element at index.

Definition at line 68 of file ZVector.h.

T& get ( ) [inline]

Returns the next element, during iteration.

Definition at line 78 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

void add ( T & addObject ) [inline]

Add element to the vector at the current position.

Reimplemented in ZScalarVector, and ZScalarVector< int >.

Definition at line 94 of file ZVector.h.

void remove ( ) [inline]

Removes the element at the current position.

Definition at line 112 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), and ZVector< ZonaClientEntity * >::remove().

bool remove ( T & remObject ) [inline]

Removes an element from the vector.

Parameters:
remObject element to be removed from the vector

Definition at line 136 of file ZVector.h.

bool contains ( T & object ) [inline]

Check if the element is present in the vector.

Parameters:
object The element to look for
Returns:
returns true if a match was found

Definition at line 157 of file ZVector.h.

void start ( ) [inline]

Start the iterator.

Returns:
returns true if a match was found

Definition at line 178 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

bool next ( ) [inline]

Used during iteration.

Advances the pointer to the next element.

Returns:
returns false if the no more elements were found.

Definition at line 191 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::contains(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::operator[](), and ZVector< ZonaClientEntity * >::remove().

int getSize ( ) const [inline]

Returns the current number of elements in the vector.

Definition at line 213 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::operator[]().

void clear ( ) [inline]

Removes all elements from the vector.

Definition at line 220 of file ZVector.h.

Member Data Documentation

int size [protected]

Definition at line 237 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::clear(), ZVector< ZonaClientEntity * >::getSize(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), and ZVector< ZonaClientEntity * >::ZVector().

bool m_disableDelete [protected]

Definition at line 238 of file ZVector.h.

Referenced by ZVector< ZonaClientEntity * >::add(), and ZVector< ZonaClientEntity * >::ZVector().

ZVectorNode<T>* headNode [protected]

Definition at line 239 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::remove(), ZVector< ZonaClientEntity * >::start(), ZVector< ZonaClientEntity * >::ZVector(), and ZVector< ZonaClientEntity * >::~ZVector().

ZVectorNode<T>* currentNode [protected]

Definition at line 240 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::get(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), ZVector< ZonaClientEntity * >::start(), and ZVector< ZonaClientEntity * >::ZVector().

ZVectorNode<T> * lastCurrentNode [protected]

Definition at line 240 of file ZVector.h.

Referenced by ZScalarVector< int >::add(), ZVector< ZonaClientEntity * >::add(), ZVector< ZonaClientEntity * >::next(), ZVector< ZonaClientEntity * >::remove(), and ZVector< ZonaClientEntity * >::start().

The documentation for this class was generated from the following file:
  • ZVector.h


ZVector Member List

This is the complete list of members for ZVector, including all inherited members.
add(T &addObject) | ZVector | [inline]
clear() | ZVector | [inline]
contains(T &object) | ZVector | [inline]
currentNode | ZVector | [protected]
get(int index) | ZVector | [inline]
get() | ZVector | [inline]
getSize() const | ZVector | [inline]
headNode | ZVector | [protected]
lastCurrentNode | ZVector | [protected]
m_disableDelete | ZVector | [protected]
next() | ZVector | [inline]
operator[](int index) | ZVector | [inline]
remove() | ZVector | [inline]
remove(T &remObject) | ZVector | [inline]
size | ZVector | [protected]
start() | ZVector | [inline]
ZVector(bool disableDelete=true) | ZVector | [inline]
~ZVector() | ZVector | [inline]


ZWString Class Reference

ZWString. More...

List of all members.

Public Member Functions

ZWString (const wchar_t *value=L"")
ZWString (const char *valueA)
wchar_t | operator[] (int index) const
wchar_t & | operator[] (int index)
const wchar_t * | toString ()
const char * | toStringA ()
bool | compare (const wchar_t *value)
void | append (const wchar_t *str)
int | length ()
void | copyFromChar (const wchar_t *str)

Static Public Member Functions

int | w2a (const wchar_t *ws, char *sBuf, int sBufSize)
int | a2w (const char *as, wchar_t *sBuf, int sBufSize)

Detailed Description

ZWString.

Simple multi platform string class

Definition at line 101 of file ZString.h.

Constructor & Destructor Documentation

ZWString ( const wchar_t * value = L"" )

ZWString ( const char * valueA )

Member Function Documentation

wchar_t operator[] ( int index ) const

wchar_t& operator[] ( int index )

const wchar_t* toString ( )

const char* toStringA ( )

bool compare ( const wchar_t * value )

void append ( const wchar_t * str )

int length ( )

void copyFromChar ( const wchar_t * str )

int w2a | ( | const wchar_t * | ws,
 |  | char * | sBuf,
 |  | int | sBufSize
 | ) | [static]

int a2w | ( | const char * | as,
 |  | wchar_t * | sBuf,
 |  | int | sBufSize
 | ) | [static]

The documentation for this class was generated from the following file:
  • ZString.h


ZWString Member List

This is the complete list of members for ZWString, including all inherited members.
a2w(const char *as, wchar_t *sBuf, int sBufSize) | ZWString | [static]
append(const wchar_t *str) | ZWString |
compare(const wchar_t *value) | ZWString |
copyFromChar(const wchar_t *str) | ZWString |
length() | ZWString |
operator[](int index) const | ZWString |
operator[](int index) | ZWString |
toString() | ZWString |
toStringA() | ZWString |
w2a(const wchar_t *ws, char *sBuf, int sBufSize) | ZWString | [static]
ZWString(const wchar_t *value=L"") | ZWString |
ZWString(const char *valueA) | ZWString |


Here is a list of all class members with links to the classes they belong to:

- _ -

  • _downcastBuffer : BaseServices

- a -

  • a2w() : ZWString, ZString, BaseServices
  • acquireChildEntity() : ZonaClientCharacter
  • activate() : ZonaClientEntity
  • add() : ZScalarVector, ZVector
  • addGuildModerator() : GameGuildServiceInterface, ZonaServices
  • append() : ZWString, ZString
  • appendToZonaMessage() : NamedZonaObject, PersistableObject, ZonaObject
  • attachEntity() : ZonaClientEntity

- b -

  • BaseServices() : BaseServices
  • body : ChatMsg

- c -

  • CharacterService : Guild
  • ChatCallback() : ChatCallback
  • ChatMsg() : ChatMsg
  • clear() : ZVector
  • clearPropertyData() : ZonaObject
  • compare() : ZWString, ZString
  • contains() : ZVector
  • copyFromChar() : ZWString
  • createCharacter() : ZonaServices
  • createForum() : Guild
  • createGroupInstance() : Guild
  • createGuild() : GameGuildServiceInterface, ZonaServices
  • createMultipleChildEntities() : ZonaServices
  • createPersistantGuildInstance() : Guild
  • createSingleChildEntity() : ZonaServices
  • currentNode : ZVector

- d -

  • date : ChatMsg
  • deactivate() : ZonaClientEntity
  • deleteCharacter() : ZonaServices
  • deleteChildEntity() : ZonaServices
  • deleteGuild() : GameGuildServiceInterface, ZonaServices
  • deletePersistentMessage() : ZonaServices
  • deserialize() : NamedZonaObject, PersistableObject, ZonaObject
  • DESTROY_WITH_OWNER : Guild
  • detachEntity() : ZonaClientEntity
  • DONT_SEND_MEMBERSHIP_CHANGES : Guild
  • DONT_SEND_NEW_MESSAGES : Guild

- e -

  • EMAIL_FOLLOWUP : Guild
  • enter() : ZonaClientEntity, ZonaClientCharacter
  • enterGuild() : GameGuildServiceInterface
  • EntityCallback() : EntityCallback
  • exit() : ZonaClientEntity, ZonaClientCharacter
  • exitGuild() : GameGuildServiceInterface
  • extractFromZonaMessage() : NamedZonaObject, PersistableObject, ZonaObject

- f -

  • fetchAccessibleGuilds() : GameGuildServiceInterface
  • fetchGuildMembers() : GameGuildServiceInterface
  • fetchMemberGuilds() : GameGuildServiceInterface
  • fetchMyGuilds() : ZonaServices
  • fetchPersistentMessages() : ZonaServices
  • fetchZonaGuildChatMessages() : GameGuildServiceInterface
  • FileTimeToZonaTime() : ZonaTimeUtils
  • flag : ChatMsg
  • FLAG_DELETED : ChatMsg
  • FLAG_REPLIED : ChatMsg
  • FLAG_UNDOWNLOADED : ChatMsg
  • FLAG_UNREAD : ChatMsg

- g -

  • GameGuildCallback() : GameGuildCallback
  • GameGuildServiceInterface() : GameGuildServiceInterface
  • GameStateCallback() : GameStateCallback
  • gameStateService : BaseServices
  • get() : ZVector
  • getAllEntities() : BaseServices
  • getAttributes() : Guild
  • getCharacter() : BaseServices
  • getCharacterId() : BaseServices
  • getCharacters() : ZonaServices
  • getChildEntities() : ZonaClientEntity
  • getClassId() : ZonaObject
  • getEntityId() : ZonaBaseEntity
  • getEntityInfo() : ZonaBaseEntity
  • getEntityType() : ZonaBaseEntity
  • getEntityWithId() : BaseServices
  • getGameGuild() : GameGuildServiceInterface
  • getGameGuildServices() : ZonaServices
  • getGenericDataBlob() : ZonaObject
  • getGenericDataLength() : ZonaObject
  • getGlobalServerLoginTime() : BaseServices
  • getId() : Guild
  • getIdForCharacterName() : ZonaServices
  • getIdForGuildName() : ZonaServices
  • getInviters() : Guild
  • getIsMaster() : ZonaBaseEntity
  • getLoginName() : BaseServices
  • getLoginStatus() : BaseServices
  • getMapId() : ZonaBaseEntity
  • getMessageBufferCount() : BaseServices
  • getMillsSinceLogin() : BaseServices
  • getMillsSinceZGST() : BaseServices
  • getModerators() : ZonaServices
  • getName() : ZonaClientCharacter, Guild
  • getNewChildEntityId() : ZonaServices
  • getParentId() : ZonaBaseEntity
  • getPrivatePropertyData() : ZonaObject
  • getPublicDisplayPropertyData() : ZonaObject
  • getPublicStatePropertyData() : ZonaObject
  • getRegionId() : ZonaClientEntity
  • getSessionId() : BaseServices
  • getSize() : ZVector
  • getSystemPropertyData() : ZonaObject
  • getType() : ZonaObject
  • getZAFVersion() : BaseServices
  • Guild() : Guild
  • GuildAttributes : Guild
  • GuildCallback() : GuildCallback
  • guildDestroyed() : GuildCallback
  • guildInvite() : GuildCallback

- h -

  • headNode : ZVector
  • hide() : ZonaClientEntity

- i -

  • id : ChatMsg, PersistableObject
  • init() : ChatMsg
  • initializeChatServices() : ZonaServices
  • initializeServices() : ZonaServices, BaseServices
  • intensity : ChatMsg
  • inviteGuildMember() : ZonaServices
  • inviteMember() : GameGuildServiceInterface
  • Inviter : Guild
  • isFetchingChildEntities() : ZonaClientEntity

- j -

  • joinGuild() : GameGuildServiceInterface, ZonaServices

- l -

  • lastCurrentNode : ZVector
  • lastError : ZonaServices
  • leaveGuild() : GameGuildServiceInterface
  • length() : ZWString, ZString
  • login() : BaseServices
  • loginAsync() : BaseServices
  • logoff() : BaseServices

- m -

  • m_autoUpdate : BaseServices
  • m_disableDelete : ZVector
  • m_messageBuffering : BaseServices
  • m_privateProperties : ZonaObject
  • m_publicDisplayProperties : ZonaObject
  • m_publicStateProperties : ZonaObject
  • m_refCount : ZonaClientEntity
  • m_state : BaseServices
  • m_systemProperties : ZonaObject
  • m_zs : ZonaClientEntity
  • MailFlags : ChatMsg
  • MEMBER : Guild
  • memberDepartedGuild() : GuildCallback
  • memberJoinedGuild() : GuildCallback
  • MEMBERS_CAN_DELETE_ANY_MSG : Guild
  • MEMBERS_CAN_DELETE_OWN_MSG : Guild
  • MEMBERS_CAN_POST_MSG : Guild
  • millsAtCurrentTime() : ZonaTimeUtils
  • millsSinceGlobalSyncPoint() : ZonaTimeUtils
  • MODERATOR : Guild
  • moderatorChanged() : GuildCallback
  • monitorEntityUpdates() : BaseServices
  • monitorGameState() : BaseServices
  • monitorGuildMessage() : GameGuildServiceInterface
  • monitorGuildUpdates() : ZonaServices

- n -

  • name : NamedZonaObject
  • NamedZonaObject() : NamedZonaObject
  • next() : ZVector

- o -

  • onAddGuild() : GameGuildCallback
  • onAddModerator() : GameGuildCallback
  • onGuildChatMessage() : GameGuildCallback
  • onGuildEntityUpdate() : GameGuildCallback
  • onGuildErrorMessage() : GameGuildCallback
  • onGuildGameState() : GameGuildCallback
  • onGuildInvite() : GameGuildCallback
  • onGuildPropertyUpdate() : GameGuildCallback
  • onMemberEnterGuild() : GameGuildCallback
  • onMemberExitGuild() : GameGuildCallback
  • onMemberJoinGuild() : GameGuildCallback
  • onMemberLeaveGuild() : GameGuildCallback
  • onNotifyEntityDepartedSphere() : EntityCallback
  • onNotifyEntityJoinedSphere() : EntityCallback
  • onNotifyEntityParentChange() : EntityCallback
  • onNotifyEntityPropertyUpdate() : EntityCallback
  • onNotifyPlayerReset() : Callback
  • onReceiveChat() : ChatCallback
  • onReceivedGameStateMsg() : GameStateCallback
  • onRemoveGuild() : GameGuildCallback
  • onRemoveModerator() : GameGuildCallback
  • operator=() : PersistableObject, ZonaObject
  • operator[]() : ZVector, ZWString, ZString

- p -

  • parent : ZonaObject
  • PersistableObject() : PersistableObject
  • PERSISTENT_MEMBERSHIP : Guild
  • PERSISTENT_MSG : Guild
  • processMessage() : BaseServices
  • publish() : ZonaClientEntity
  • publishAllEntityProperties() : ZonaServices
  • publishEntityPropertyUpdates() : GameGuildServiceInterface, ZonaServices

- r -

  • RECIPIENT_ID_BY_NAME : ChatMsg
  • RECIPIENT_ID_SPHERE : ChatMsg
  • RECIPIENT_ID_SYSTEMWIDE : ChatMsg
  • recipientId : ChatMsg
  • recipientProperties : ChatMsg
  • release() : ZonaClientEntity
  • releaseChildEntity() : ZonaClientCharacter
  • remove() : ZVector
  • removeGuildMember() : ZonaServices
  • removeGuildModerator() : GameGuildServiceInterface, ZonaServices
  • removeMember() : GameGuildServiceInterface
  • requestMemberGuilds() : GameGuildServiceInterface
  • retain() : ZonaClientEntity

- s -

  • select() : ZonaClientCharacter
  • SELF : Guild
  • sendChatMessage() : GameGuildServiceInterface, ZonaServices
  • senderId : ChatMsg
  • sendGameStateMsg() : BaseServices
  • sendGuildGameState() : GameGuildServiceInterface
  • serialize() : NamedZonaObject, PersistableObject, ZonaObject
  • serverThrownError() : Callback
  • setChatHandler() : ZonaServices
  • setClassId() : ZonaObject
  • setDefaultChatHandler() : ZonaServices
  • setEntityId() : ZonaBaseEntity
  • setEntityInfo() : ZonaBaseEntity
  • setEntityType() : ZonaBaseEntity
  • setFilterOptions() : ZonaServices
  • setGameVersion() : BaseServices
  • setGenericData() : ZonaObject
  • setId() : Guild, ZonaObject
  • setIsMaster() : ZonaBaseEntity
  • setMapId() : ZonaBaseEntity
  • setName() : ZonaClientCharacter, Guild
  • setParent() : ZonaObject
  • setParentId() : ZonaBaseEntity
  • setPrivatePropertyData() : ZonaObject
  • setPublicDisplayPropertyData() : ZonaObject
  • setPublicStatePropertyData() : ZonaObject
  • setRegionId() : ZonaClientEntity
  • setServiceEntityId() : ZonaServices
  • setSystemPropertyData() : ZonaObject
  • setType() : ZonaObject
  • show() : ZonaClientEntity
  • sid : BaseServices
  • size : ZVector
  • SpecialRecipients : ChatMsg
  • start() : ZVector
  • stopMonitorChat() : ZonaServices
  • stopMonitorChatDefault() : ZonaServices
  • stopMonitorGuildMessage() : GameGuildServiceInterface
  • stopMonitorGuildUpdates() : ZonaServices
  • subject : ChatMsg
  • subscribeToGameStateMsgs() : BaseServices
  • SYSTEM : Guild

- t -

  • toCharacterName : ChatMsg
  • toString() : ZWString, ZString, NamedZonaObject, ZonaObject
  • toStringA() : ZWString
  • toWString() : ZString
  • type : ZonaObject

- u -

  • update() : ZonaClientCharacter
  • updateEntityType() : ZonaClientEntity
  • userIds : Guild

- w -

  • w2a() : ZWString, ZString, BaseServices

- z -

  • ZonaBaseEntity() : ZonaBaseEntity
  • zonaClient : BaseServices
  • ZonaClientCharacter() : ZonaClientCharacter
  • ZonaClientEntity() : ZonaClientEntity
  • ZonaGuildMessage : Guild
  • ZonaObject() : ZonaObject
  • ZonaServices() : ZonaServices
  • ZonaTimeToFileTime() : ZonaTimeUtils
  • ZonaTimeUtils() : ZonaTimeUtils
  • ZScalarVector() : ZScalarVector
  • ZString() : ZString
  • ZVector() : ZVector
  • ZWString() : ZWString

- ~ -

  • ~BaseServices() : BaseServices
  • ~ChatCallback() : ChatCallback
  • ~ChatMsg() : ChatMsg
  • ~EntityCallback() : EntityCallback
  • ~GameGuildCallback() : GameGuildCallback
  • ~GameGuildServiceInterface() : GameGuildServiceInterface
  • ~GameStateCallback() : GameStateCallback
  • ~Guild() : Guild
  • ~GuildCallback() : GuildCallback
  • ~NamedZonaObject() : NamedZonaObject
  • ~PersistableObject() : PersistableObject
  • ~ZonaBaseEntity() : ZonaBaseEntity
  • ~ZonaClientCharacter() : ZonaClientCharacter
  • ~ZonaClientEntity() : ZonaClientEntity
  • ~ZonaObject() : ZonaObject
  • ~ZonaServices() : ZonaServices
  • ~ZonaTimeUtils() : ZonaTimeUtils
  • ~ZVector() : ZVector


  • GuildAttributes : Guild
  • Inviter : Guild
  • MailFlags : ChatMsg
  • SpecialRecipients : ChatMsg


  • DESTROY_WITH_OWNER : Guild
  • DONT_SEND_MEMBERSHIP_CHANGES : Guild
  • DONT_SEND_NEW_MESSAGES : Guild
  • EMAIL_FOLLOWUP : Guild
  • FLAG_DELETED : ChatMsg
  • FLAG_REPLIED : ChatMsg
  • FLAG_UNDOWNLOADED : ChatMsg
  • FLAG_UNREAD : ChatMsg
  • MEMBER : Guild
  • MEMBERS_CAN_DELETE_ANY_MSG : Guild
  • MEMBERS_CAN_DELETE_OWN_MSG : Guild
  • MEMBERS_CAN_POST_MSG : Guild
  • MODERATOR : Guild
  • PERSISTENT_MEMBERSHIP : Guild
  • PERSISTENT_MSG : Guild
  • RECIPIENT_ID_BY_NAME : ChatMsg
  • RECIPIENT_ID_SPHERE : ChatMsg
  • RECIPIENT_ID_SYSTEMWIDE : ChatMsg
  • SELF : Guild
  • SYSTEM : Guild


- a -

  • a2w() : ZWString, ZString, BaseServices
  • acquireChildEntity() : ZonaClientCharacter
  • activate() : ZonaClientEntity
  • add() : ZScalarVector, ZVector
  • addGuildModerator() : GameGuildServiceInterface, ZonaServices
  • append() : ZWString, ZString
  • appendToZonaMessage() : NamedZonaObject, PersistableObject, ZonaObject
  • attachEntity() : ZonaClientEntity

- b -

  • BaseServices() : BaseServices

- c -

  • ChatCallback() : ChatCallback
  • ChatMsg() : ChatMsg
  • clear() : ZVector
  • clearPropertyData() : ZonaObject
  • compare() : ZWString, ZString
  • contains() : ZVector
  • copyFromChar() : ZWString
  • createCharacter() : ZonaServices
  • createForum() : Guild
  • createGroupInstance() : Guild
  • createGuild() : GameGuildServiceInterface, ZonaServices
  • createMultipleChildEntities() : ZonaServices
  • createPersistantGuildInstance() : Guild
  • createSingleChildEntity() : ZonaServices

- d -

  • deactivate() : ZonaClientEntity
  • deleteCharacter() : ZonaServices
  • deleteChildEntity() : ZonaServices
  • deleteGuild() : GameGuildServiceInterface, ZonaServices
  • deletePersistentMessage() : ZonaServices
  • deserialize() : NamedZonaObject, PersistableObject, ZonaObject
  • detachEntity() : ZonaClientEntity

- e -

  • enter() : ZonaClientEntity, ZonaClientCharacter
  • enterGuild() : GameGuildServiceInterface
  • EntityCallback() : EntityCallback
  • exit() : ZonaClientEntity, ZonaClientCharacter
  • exitGuild() : GameGuildServiceInterface
  • extractFromZonaMessage() : NamedZonaObject, PersistableObject, ZonaObject

- f -

  • fetchAccessibleGuilds() : GameGuildServiceInterface
  • fetchGuildMembers() : GameGuildServiceInterface
  • fetchMemberGuilds() : GameGuildServiceInterface
  • fetchMyGuilds() : ZonaServices
  • fetchPersistentMessages() : ZonaServices
  • fetchZonaGuildChatMessages() : GameGuildServiceInterface
  • FileTimeToZonaTime() : ZonaTimeUtils

- g -

  • GameGuildCallback() : GameGuildCallback
  • GameGuildServiceInterface() : GameGuildServiceInterface
  • GameStateCallback() : GameStateCallback
  • get() : ZVector
  • getAllEntities() : BaseServices
  • getAttributes() : Guild
  • getCharacter() : BaseServices
  • getCharacterId() : BaseServices
  • getCharacters() : ZonaServices
  • getChildEntities() : ZonaClientEntity
  • getClassId() : ZonaObject
  • getEntityId() : ZonaBaseEntity
  • getEntityInfo() : ZonaBaseEntity
  • getEntityType() : ZonaBaseEntity
  • getEntityWithId() : BaseServices
  • getGameGuild() : GameGuildServiceInterface
  • getGameGuildServices() : ZonaServices
  • getGenericDataBlob() : ZonaObject
  • getGenericDataLength() : ZonaObject
  • getGlobalServerLoginTime() : BaseServices
  • getId() : Guild
  • getIdForCharacterName() : ZonaServices
  • getIdForGuildName() : ZonaServices
  • getInviters() : Guild
  • getIsMaster() : ZonaBaseEntity
  • getLoginName() : BaseServices
  • getLoginStatus() : BaseServices
  • getMapId() : ZonaBaseEntity
  • getMessageBufferCount() : BaseServices
  • getMillsSinceLogin() : BaseServices
  • getMillsSinceZGST() : BaseServices
  • getModerators() : ZonaServices
  • getName() : ZonaClientCharacter, Guild
  • getNewChildEntityId() : ZonaServices
  • getParentId() : ZonaBaseEntity
  • getPrivatePropertyData() : ZonaObject
  • getPublicDisplayPropertyData() : ZonaObject
  • getPublicStatePropertyData() : ZonaObject
  • getRegionId() : ZonaClientEntity
  • getSessionId() : BaseServices
  • getSize() : ZVector
  • getSystemPropertyData() : ZonaObject
  • getType() : ZonaObject
  • getZAFVersion() : BaseServices
  • Guild() : Guild
  • GuildCallback() : GuildCallback
  • guildDestroyed() : GuildCallback
  • guildInvite() : GuildCallback

- h -

  • hide() : ZonaClientEntity

- i -

  • init() : ChatMsg
  • initializeChatServices() : ZonaServices
  • initializeServices() : ZonaServices, BaseServices
  • inviteGuildMember() : ZonaServices
  • inviteMember() : GameGuildServiceInterface
  • isFetchingChildEntities() : ZonaClientEntity

- j -

  • joinGuild() : GameGuildServiceInterface, ZonaServices

- l -

  • leaveGuild() : GameGuildServiceInterface
  • length() : ZWString, ZString
  • login() : BaseServices
  • loginAsync() : BaseServices
  • logoff() : BaseServices

- m -

  • memberDepartedGuild() : GuildCallback
  • memberJoinedGuild() : GuildCallback
  • millsAtCurrentTime() : ZonaTimeUtils
  • millsSinceGlobalSyncPoint() : ZonaTimeUtils
  • moderatorChanged() : GuildCallback
  • monitorEntityUpdates() : BaseServices
  • monitorGameState() : BaseServices
  • monitorGuildMessage() : GameGuildServiceInterface
  • monitorGuildUpdates() : ZonaServices

- n -

  • NamedZonaObject() : NamedZonaObject
  • next() : ZVector

- o -

  • onAddGuild() : GameGuildCallback
  • onAddModerator() : GameGuildCallback
  • onGuildChatMessage() : GameGuildCallback
  • onGuildEntityUpdate() : GameGuildCallback
  • onGuildErrorMessage() : GameGuildCallback
  • onGuildGameState() : GameGuildCallback
  • onGuildInvite() : GameGuildCallback
  • onGuildPropertyUpdate() : GameGuildCallback
  • onMemberEnterGuild() : GameGuildCallback
  • onMemberExitGuild() : GameGuildCallback
  • onMemberJoinGuild() : GameGuildCallback
  • onMemberLeaveGuild() : GameGuildCallback
  • onNotifyEntityDepartedSphere() : EntityCallback
  • onNotifyEntityJoinedSphere() : EntityCallback
  • onNotifyEntityParentChange() : EntityCallback
  • onNotifyEntityPropertyUpdate() : EntityCallback
  • onNotifyPlayerReset() : Callback
  • onReceiveChat() : ChatCallback
  • onReceivedGameStateMsg() : GameStateCallback
  • onRemoveGuild() : GameGuildCallback
  • onRemoveModerator() : GameGuildCallback
  • operator=() : PersistableObject, ZonaObject
  • operator[]() : ZVector, ZWString, ZString

- p -

  • PersistableObject() : PersistableObject
  • processMessage() : BaseServices
  • publish() : ZonaClientEntity
  • publishAllEntityProperties() : ZonaServices
  • publishEntityPropertyUpdates() : GameGuildServiceInterface, ZonaServices

- r -

  • release() : ZonaClientEntity
  • releaseChildEntity() : ZonaClientCharacter
  • remove() : ZVector
  • removeGuildMember() : ZonaServices
  • removeGuildModerator() : GameGuildServiceInterface, ZonaServices
  • removeMember() : GameGuildServiceInterface
  • requestMemberGuilds() : GameGuildServiceInterface
  • retain() : ZonaClientEntity

- s -

  • select() : ZonaClientCharacter
  • sendChatMessage() : GameGuildServiceInterface, ZonaServices
  • sendGameStateMsg() : BaseServices
  • sendGuildGameState() : GameGuildServiceInterface
  • serialize() : NamedZonaObject, PersistableObject, ZonaObject
  • serverThrownError() : Callback
  • setChatHandler() : ZonaServices
  • setClassId() : ZonaObject
  • setDefaultChatHandler() : ZonaServices
  • setEntityId() : ZonaBaseEntity
  • setEntityInfo() : ZonaBaseEntity
  • setEntityType() : ZonaBaseEntity
  • setFilterOptions() : ZonaServices
  • setGameVersion() : BaseServices
  • setGenericData() : ZonaObject
  • setId() : Guild, ZonaObject
  • setIsMaster() : ZonaBaseEntity
  • setMapId() : ZonaBaseEntity
  • setName() : ZonaClientCharacter, Guild
  • setParent() : ZonaObject
  • setParentId() : ZonaBaseEntity
  • setPrivatePropertyData() : ZonaObject
  • setPublicDisplayPropertyData() : ZonaObject
  • setPublicStatePropertyData() : ZonaObject
  • setRegionId() : ZonaClientEntity
  • setServiceEntityId() : ZonaServices
  • setSystemPropertyData() : ZonaObject
  • setType() : ZonaObject
  • show() : ZonaClientEntity
  • start() : ZVector
  • stopMonitorChat() : ZonaServices
  • stopMonitorChatDefault() : ZonaServices
  • stopMonitorGuildMessage() : GameGuildServiceInterface
  • stopMonitorGuildUpdates() : ZonaServices
  • subscribeToGameStateMsgs() : BaseServices

- t -

  • toString() : ZWString, ZString, NamedZonaObject, ZonaObject
  • toStringA() : ZWString
  • toWString() : ZString

- u -

  • update() : ZonaClientCharacter
  • updateEntityType() : ZonaClientEntity

- w -

  • w2a() : ZWString, ZString, BaseServices

- z -

  • ZonaBaseEntity() : ZonaBaseEntity
  • ZonaClientCharacter() : ZonaClientCharacter
  • ZonaClientEntity() : ZonaClientEntity
  • ZonaObject() : ZonaObject
  • ZonaServices() : ZonaServices
  • ZonaTimeToFileTime() : ZonaTimeUtils
  • ZonaTimeUtils() : ZonaTimeUtils
  • ZScalarVector() : ZScalarVector
  • ZString() : ZString
  • ZVector() : ZVector
  • ZWString() : ZWString

- ~ -

  • ~BaseServices() : BaseServices
  • ~ChatCallback() : ChatCallback
  • ~ChatMsg() : ChatMsg
  • ~EntityCallback() : EntityCallback
  • ~GameGuildCallback() : GameGuildCallback
  • ~GameGuildServiceInterface() : GameGuildServiceInterface
  • ~GameStateCallback() : GameStateCallback
  • ~Guild() : Guild
  • ~GuildCallback() : GuildCallback
  • ~NamedZonaObject() : NamedZonaObject
  • ~PersistableObject() : PersistableObject
  • ~ZonaBaseEntity() : ZonaBaseEntity
  • ~ZonaClientCharacter() : ZonaClientCharacter
  • ~ZonaClientEntity() : ZonaClientEntity
  • ~ZonaObject() : ZonaObject
  • ~ZonaServices() : ZonaServices
  • ~ZonaTimeUtils() : ZonaTimeUtils
  • ~ZVector() : ZVector


  • CharacterService : Guild
  • ZonaGuildMessage : Guild


- _ -

  • _downcastBuffer : BaseServices

- b -

  • body : ChatMsg

- c -

  • currentNode : ZVector

- d -

  • date : ChatMsg

- f -

  • flag : ChatMsg

- g -

  • gameStateService : BaseServices

- h -

  • headNode : ZVector

- i -

  • id : ChatMsg, PersistableObject
  • intensity : ChatMsg

- l -

  • lastCurrentNode : ZVector
  • lastError : ZonaServices

- m -

  • m_autoUpdate : BaseServices
  • m_disableDelete : ZVector
  • m_messageBuffering : BaseServices
  • m_privateProperties : ZonaObject
  • m_publicDisplayProperties : ZonaObject
  • m_publicStateProperties : ZonaObject
  • m_refCount : ZonaClientEntity
  • m_state : BaseServices
  • m_systemProperties : ZonaObject
  • m_zs : ZonaClientEntity

- n -

  • name : NamedZonaObject

- p -

  • parent : ZonaObject

- r -

  • recipientId : ChatMsg
  • recipientProperties : ChatMsg

- s -

  • senderId : ChatMsg
  • sid : BaseServices
  • size : ZVector
  • subject : ChatMsg

- t -

  • toCharacterName : ChatMsg
  • type : ZonaObject

- u -

  • userIds : Guild

- z -

  • zonaClient : BaseServices


Here is a list of all file members with links to the files they belong to:

- _ -

  • _BASESERVICES_H_ : BaseServices.h
  • _CHATCALLBACK_H : ChatCallBack.h
  • _ENTITYCALLBACK_H_ : EntityCallback.h
  • _GAMESTATECALLBACK_H_ : GameStateCallback.h
  • _ZONABASEENTITY_H_INCLUDED_ : ZonaBaseEntity.h
  • _ZONACLIENTCHARACTER_H_INCLUDED_ : ZonaClientCharacter.h
  • _ZONACLIENTENTITY_H_INCLUDED_ : ZonaClientEntity.h
  • _ZONASERVICES_H_ : ZonaServices.h

- a -

  • AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_ : GameGuildCallback.h

- c -

  • CHAT_CHANNEL_GROUP : ZonaGlobalConstants.h
  • CHAT_CHANNEL_GUILD : ZonaGlobalConstants.h
  • CHAT_CHANNEL_PRIVATE : ZonaGlobalConstants.h
  • CHAT_CHANNEL_PUBLIC : ZonaGlobalConstants.h
  • CHAT_CHANNEL_SPHERE : ZonaGlobalConstants.h
  • CHAT_COVERAGE_FAR : ZonaGlobalConstants.h
  • CHAT_COVERAGE_NEAR : ZonaGlobalConstants.h
  • CHAT_INTENSITY_SHOUT : ZonaGlobalConstants.h
  • CHAT_INTENSITY_TALK : ZonaGlobalConstants.h
  • CHAT_INTENSITY_WHISPER : ZonaGlobalConstants.h
  • CHAT_INTENSITY_YELL : ZonaGlobalConstants.h
  • CHATMSG_H : ChatMsg.h
  • ChatMsgPtrVector : ChatMsg.h
  • ChatType : ZonaGlobalConstants.h
  • COUNT : ZonaGlobalConstants.h

- e -

  • ENTITY_DEPARTED_SPHERE : ZonaGlobalConstants.h
  • ENTITY_JOINED_SPHERE : ZonaGlobalConstants.h
  • ERR_ALREADY_ACTIVE : ZonaErrors.h
  • ERR_ALREADY_INACTIVE : ZonaErrors.h
  • ERR_CHAT : ZonaErrors.h
  • ERR_CHAT_NO_PERMISION : ZonaErrors.h
  • ERR_CHAT_NOT_MODERATOR : ZonaErrors.h
  • ERR_CHAT_SERVICE_CANT_INIT : ZonaErrors.h
  • ERR_CHAT_SERVICE_NOT_INIT : ZonaErrors.h
  • ERR_CHAT_UNKNOWN : ZonaErrors.h
  • ERR_CONNECTION_FAILED : ZonaErrors.h
  • ERR_DB_INTEGRITY_CONST : ZonaErrors.h
  • ERR_DISCONNECT_FAIL : ZonaErrors.h
  • ERR_DUP_CHARACTER_NAME : ZonaErrors.h
  • ERR_EMPTY_CHARACTER_NAME : ZonaErrors.h
  • ERR_ENTITY_MGNT : ZonaErrors.h
  • ERR_ENTITY_NOT_FOUND : ZonaErrors.h
  • ERR_GAME_PROFILE : ZonaErrors.h
  • ERR_GAME_STATE : ZonaErrors.h
  • ERR_INVALID_CHILD_ENTITY : ZonaErrors.h
  • ERR_INVALID_GUILD : ZonaErrors.h
  • ERR_INVALID_ID : ZonaErrors.h
  • ERR_INVALID_OPERATION : ZonaErrors.h
  • ERR_LOGON_ALREADY_LOGGED_IN : ZonaErrors.h
  • ERR_LOGON_FAIL : ZonaErrors.h
  • ERR_LOGON_FAIL_BAD_PASSWD : ZonaErrors.h
  • ERR_LOGON_FAIL_NO_USER : ZonaErrors.h
  • ERR_LOGON_FAIL_UNSET_VER : ZonaErrors.h
  • ERR_LOGON_FAIL_WRONG_GSS : ZonaErrors.h
  • ERR_LOGON_FAILURE : ZonaErrors.h
  • ERR_LOGON_IN_PROGRESS : ZonaErrors.h
  • ERR_LOGON_WRONG_GAME_VER : ZonaErrors.h
  • ERR_LOGON_WRONG_ZAF_VER : ZonaErrors.h
  • ERR_MAX_CONN_LIMIT : ZonaErrors.h
  • ERR_MESSAGE_RECEIVE : ZonaErrors.h
  • ERR_MESSAGE_SEND : ZonaErrors.h
  • ERR_MONITOR_SPHERE : ZonaErrors.h
  • ERR_NO_ENTER_CHARACTER : ZonaErrors.h
  • ERR_NO_EXIT_CHARACTER : ZonaErrors.h
  • ERR_NO_FREE_SERVER : ZonaErrors.h
  • ERR_NO_INIT_SERVICE : ZonaErrors.h
  • ERR_NO_LISTENER : ZonaErrors.h
  • ERR_NO_LOGIN : ZonaErrors.h
  • ERR_NO_REG_CALLBACK : ZonaErrors.h
  • ERR_NO_SUBS_FILTERS_SET : ZonaErrors.h
  • ERR_NODATABASE : ZonaErrors.h
  • ERR_NOT_CONNECTED : ZonaErrors.h
  • ERR_NULL_SERVICE : ZonaErrors.h
  • ERR_OPEN_LOGFILE : ZonaErrors.h
  • ERR_PLUGIN_RET_INVALID : ZonaErrors.h
  • ERR_PREV_CHARACTER_NOT_FOUND : ZonaErrors.h
  • ERR_READ_INI_FILE : ZonaErrors.h
  • ERR_READ_INI_STRING : ZonaErrors.h
  • ERR_REGISTER_CALLBACK : ZonaErrors.h
  • ERR_RESET_IN_PROGRESS : ZonaErrors.h
  • ERR_SPHERE : ZonaErrors.h
  • ERR_SUBSCRIBE : ZonaErrors.h
  • ERR_SUCCESS : ZonaErrors.h
  • ERR_UNKNOWN : ZonaErrors.h
  • ERR_UNKNOWN_PARENT_ID : ZonaErrors.h
  • ERR_UNSUBSCRIBE : ZonaErrors.h
  • ERR_WRITE_LOGFILE : ZonaErrors.h

- g -

  • GameCharacter : ZonaClientCharacter.h
  • GameStateCallback : BaseServices.h
  • GROUP_CHAT_CMD_ACCEPT : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_DISBAND : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_INVITE : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_LEAVE : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_SEND_MSG : ZonaGlobalConstants.h
  • GUILD : ZonaGlobalConstants.h
  • GUILD_H : Guild.h
  • GUILDCALLBACK_H : GuildCallback.h
  • GuildPtrVector : Guild.h

- h -

  • HOST_URL : ZonaGlobalConstants.h

- i -

  • INI_CONNECTION_SECTION : ZonaGlobalConstants.h
  • INI_FILE_NAME : ZonaGlobalConstants.h
  • IntList : ZonaGlobalConstants.h
  • IntVector : ZVector.h

- l -

  • LOGGED_IN : ZonaGlobalConstants.h
  • LOGIN_FAIL_NODATABASE : ZonaGlobalConstants.h
  • LOGIN_FAIL_WRONG_PASS : ZonaGlobalConstants.h
  • LOGIN_IN_PROGRESS : ZonaGlobalConstants.h
  • loginStatus : ZonaGlobalConstants.h
  • LOGOUT_IN_PROGRESS : ZonaGlobalConstants.h

- m -

  • MAX_INI_BUFFER : ZonaGlobalConstants.h

- n -

  • NamedZonaObject_H : NamedZonaObject.h
  • NOT_LOGGED_IN : ZonaGlobalConstants.h

- p -

  • PASSWORD : ZonaGlobalConstants.h
  • PERSISTABLEOBJECT_H : PersistableObject.h
  • PersistableObjectPtrVector : PersistableObject.h
  • PLAYER_DEPARTED_GAME : ZonaGlobalConstants.h
  • PLAYER_JOINED_GAME : ZonaGlobalConstants.h
  • PLAYER_RECONNECT_GAME : ZonaGlobalConstants.h
  • PRIVATE : ZonaGlobalConstants.h

- s -

  • S_CHAT_COVERAGE_FAR : ZonaGlobalConstants.h
  • S_CHAT_COVERAGE_NEAR : ZonaGlobalConstants.h
  • SPHERE : ZonaGlobalConstants.h
  • SPHERE_CHAT_COVERAGE : ZonaGlobalConstants.h
  • SYSTEMWIDE : ZonaGlobalConstants.h

- u -

  • UPDATE_CHILD_ADD : ZonaGlobalConstants.h
  • UPDATE_CHILD_REMOVE : ZonaGlobalConstants.h
  • USER_NAME : ZonaGlobalConstants.h

- z -

  • ZAC_INI_FILENAME : ZonaGlobalConstants.h
  • ZONA_ET_DEFAULT : ZonaGlobalConstants.h
  • ZONA_ET_IS_ATTACHED : ZonaGlobalConstants.h
  • ZONA_ET_IS_HIDDEN : ZonaGlobalConstants.h
  • ZONA_ET_IS_USER_ENTITY : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_1 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_2 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_3 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_4 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_5 : ZonaGlobalConstants.h
  • ZONA_MSG_ALL : ZonaGlobalConstants.h
  • ZONA_MSG_GAMEEVENT : ZonaGlobalConstants.h
  • ZONA_MSG_GAMESTATE : ZonaGlobalConstants.h
  • ZONA_MSG_NONE : ZonaGlobalConstants.h
  • ZONA_MSG_SPHERE_UPDATES : ZonaGlobalConstants.h
  • ZONA_NAMESPACE_BEGIN : ChatMsg.h
  • ZONA_PING : ZonaGlobalConstants.h
  • ZONA_TIMEUTILS_H_INCLUDED_ : ZonaTimeUtils.h
  • ZonaBaseEntityPtrVector : ZonaBaseEntity.h
  • ZonaClientCharacterPtrVector : ZonaClientCharacter.h, ZonaServices.h
  • ZonaClientEntity : ZonaClientEntity.h, ZonaServices.h
  • ZonaClientEntityPtrVector : ZonaClientEntity.h, ZonaServices.h
  • ZonaClientGuild : GameGuildCallback.h, GameGuildServiceInterface.h, GuildCallback.h
  • ZonaClientGuildPtrVector : GameGuildServiceInterface.h
  • ZonaEntityList : ZonaGlobalConstants.h
  • ZonaGuildChatMsgPtrVector : GameGuildServiceInterface.h
  • ZonaMessage : PersistableObject.h, ZonaObject.h
  • ZONAOBJECT_H : ZonaObject.h
  • ZonaObjectPtrVector : ZonaObject.h
  • ZSTRING_H : ZString.h


- _ -

  • _BASESERVICES_H_ : BaseServices.h
  • _CHATCALLBACK_H : ChatCallBack.h
  • _ENTITYCALLBACK_H_ : EntityCallback.h
  • _GAMESTATECALLBACK_H_ : GameStateCallback.h
  • _ZONABASEENTITY_H_INCLUDED_ : ZonaBaseEntity.h
  • _ZONACLIENTCHARACTER_H_INCLUDED_ : ZonaClientCharacter.h
  • _ZONACLIENTENTITY_H_INCLUDED_ : ZonaClientEntity.h
  • _ZONASERVICES_H_ : ZonaServices.h

- a -

  • AFX_GAMEGUILDCALLBACK_H__C55E6C9B_AF89_41C2_9FE0_9B8BF757CB53__INCLUDED_ : GameGuildCallback.h

- c -

  • CHATMSG_H : ChatMsg.h

- e -

  • ENTITY_DEPARTED_SPHERE : ZonaGlobalConstants.h
  • ENTITY_JOINED_SPHERE : ZonaGlobalConstants.h
  • ERR_ALREADY_ACTIVE : ZonaErrors.h
  • ERR_ALREADY_INACTIVE : ZonaErrors.h
  • ERR_CHAT : ZonaErrors.h
  • ERR_CHAT_NO_PERMISION : ZonaErrors.h
  • ERR_CHAT_NOT_MODERATOR : ZonaErrors.h
  • ERR_CHAT_SERVICE_CANT_INIT : ZonaErrors.h
  • ERR_CHAT_SERVICE_NOT_INIT : ZonaErrors.h
  • ERR_CHAT_UNKNOWN : ZonaErrors.h
  • ERR_CONNECTION_FAILED : ZonaErrors.h
  • ERR_DB_INTEGRITY_CONST : ZonaErrors.h
  • ERR_DISCONNECT_FAIL : ZonaErrors.h
  • ERR_DUP_CHARACTER_NAME : ZonaErrors.h
  • ERR_EMPTY_CHARACTER_NAME : ZonaErrors.h
  • ERR_ENTITY_MGNT : ZonaErrors.h
  • ERR_ENTITY_NOT_FOUND : ZonaErrors.h
  • ERR_GAME_PROFILE : ZonaErrors.h
  • ERR_GAME_STATE : ZonaErrors.h
  • ERR_INVALID_CHILD_ENTITY : ZonaErrors.h
  • ERR_INVALID_GUILD : ZonaErrors.h
  • ERR_INVALID_ID : ZonaErrors.h
  • ERR_INVALID_OPERATION : ZonaErrors.h
  • ERR_LOGON_ALREADY_LOGGED_IN : ZonaErrors.h
  • ERR_LOGON_FAIL : ZonaErrors.h
  • ERR_LOGON_FAIL_BAD_PASSWD : ZonaErrors.h
  • ERR_LOGON_FAIL_NO_USER : ZonaErrors.h
  • ERR_LOGON_FAIL_UNSET_VER : ZonaErrors.h
  • ERR_LOGON_FAIL_WRONG_GSS : ZonaErrors.h
  • ERR_LOGON_FAILURE : ZonaErrors.h
  • ERR_LOGON_IN_PROGRESS : ZonaErrors.h
  • ERR_LOGON_WRONG_GAME_VER : ZonaErrors.h
  • ERR_LOGON_WRONG_ZAF_VER : ZonaErrors.h
  • ERR_MAX_CONN_LIMIT : ZonaErrors.h
  • ERR_MESSAGE_RECEIVE : ZonaErrors.h
  • ERR_MESSAGE_SEND : ZonaErrors.h
  • ERR_MONITOR_SPHERE : ZonaErrors.h
  • ERR_NO_ENTER_CHARACTER : ZonaErrors.h
  • ERR_NO_EXIT_CHARACTER : ZonaErrors.h
  • ERR_NO_FREE_SERVER : ZonaErrors.h
  • ERR_NO_INIT_SERVICE : ZonaErrors.h
  • ERR_NO_LISTENER : ZonaErrors.h
  • ERR_NO_LOGIN : ZonaErrors.h
  • ERR_NO_REG_CALLBACK : ZonaErrors.h
  • ERR_NO_SUBS_FILTERS_SET : ZonaErrors.h
  • ERR_NODATABASE : ZonaErrors.h
  • ERR_NOT_CONNECTED : ZonaErrors.h
  • ERR_NULL_SERVICE : ZonaErrors.h
  • ERR_OPEN_LOGFILE : ZonaErrors.h
  • ERR_PLUGIN_RET_INVALID : ZonaErrors.h
  • ERR_PREV_CHARACTER_NOT_FOUND : ZonaErrors.h
  • ERR_READ_INI_FILE : ZonaErrors.h
  • ERR_READ_INI_STRING : ZonaErrors.h
  • ERR_REGISTER_CALLBACK : ZonaErrors.h
  • ERR_RESET_IN_PROGRESS : ZonaErrors.h
  • ERR_SPHERE : ZonaErrors.h
  • ERR_SUBSCRIBE : ZonaErrors.h
  • ERR_SUCCESS : ZonaErrors.h
  • ERR_UNKNOWN : ZonaErrors.h
  • ERR_UNKNOWN_PARENT_ID : ZonaErrors.h
  • ERR_UNSUBSCRIBE : ZonaErrors.h
  • ERR_WRITE_LOGFILE : ZonaErrors.h

- g -

  • GUILD_H : Guild.h
  • GUILDCALLBACK_H : GuildCallback.h

- m -

  • MAX_INI_BUFFER : ZonaGlobalConstants.h

- n -

  • NamedZonaObject_H : NamedZonaObject.h

- p -

  • PERSISTABLEOBJECT_H : PersistableObject.h
  • PLAYER_DEPARTED_GAME : ZonaGlobalConstants.h
  • PLAYER_JOINED_GAME : ZonaGlobalConstants.h
  • PLAYER_RECONNECT_GAME : ZonaGlobalConstants.h

- u -

  • UPDATE_CHILD_ADD : ZonaGlobalConstants.h
  • UPDATE_CHILD_REMOVE : ZonaGlobalConstants.h

- z -

  • ZONA_MSG_ALL : ZonaGlobalConstants.h
  • ZONA_MSG_GAMEEVENT : ZonaGlobalConstants.h
  • ZONA_MSG_GAMESTATE : ZonaGlobalConstants.h
  • ZONA_MSG_NONE : ZonaGlobalConstants.h
  • ZONA_MSG_SPHERE_UPDATES : ZonaGlobalConstants.h
  • ZONA_PING : ZonaGlobalConstants.h
  • ZONA_TIMEUTILS_H_INCLUDED_ : ZonaTimeUtils.h
  • ZONAOBJECT_H : ZonaObject.h
  • ZSTRING_H : ZString.h


  • ChatType : ZonaGlobalConstants.h
  • loginStatus : ZonaGlobalConstants.h
  • SPHERE_CHAT_COVERAGE : ZonaGlobalConstants.h


  • COUNT : ZonaGlobalConstants.h
  • GUILD : ZonaGlobalConstants.h
  • LOGGED_IN : ZonaGlobalConstants.h
  • LOGIN_FAIL_NODATABASE : ZonaGlobalConstants.h
  • LOGIN_FAIL_WRONG_PASS : ZonaGlobalConstants.h
  • LOGIN_IN_PROGRESS : ZonaGlobalConstants.h
  • LOGOUT_IN_PROGRESS : ZonaGlobalConstants.h
  • NOT_LOGGED_IN : ZonaGlobalConstants.h
  • PRIVATE : ZonaGlobalConstants.h
  • S_CHAT_COVERAGE_FAR : ZonaGlobalConstants.h
  • S_CHAT_COVERAGE_NEAR : ZonaGlobalConstants.h
  • SPHERE : ZonaGlobalConstants.h
  • SYSTEMWIDE : ZonaGlobalConstants.h


  • ChatMsgPtrVector : ChatMsg.h
  • GuildPtrVector : Guild.h
  • IntList : ZonaGlobalConstants.h
  • IntVector : ZVector.h
  • ZonaBaseEntityPtrVector : ZonaBaseEntity.h
  • ZonaClientCharacterPtrVector : ZonaClientCharacter.h, ZonaServices.h
  • ZonaClientEntityPtrVector : ZonaClientEntity.h, ZonaServices.h
  • ZonaClientGuildPtrVector : GameGuildServiceInterface.h
  • ZonaEntityList : ZonaGlobalConstants.h
  • ZonaGuildChatMsgPtrVector : GameGuildServiceInterface.h
  • ZonaObjectPtrVector : ZonaObject.h


- c -

  • CHAT_CHANNEL_GROUP : ZonaGlobalConstants.h
  • CHAT_CHANNEL_GUILD : ZonaGlobalConstants.h
  • CHAT_CHANNEL_PRIVATE : ZonaGlobalConstants.h
  • CHAT_CHANNEL_PUBLIC : ZonaGlobalConstants.h
  • CHAT_CHANNEL_SPHERE : ZonaGlobalConstants.h
  • CHAT_COVERAGE_FAR : ZonaGlobalConstants.h
  • CHAT_COVERAGE_NEAR : ZonaGlobalConstants.h
  • CHAT_INTENSITY_SHOUT : ZonaGlobalConstants.h
  • CHAT_INTENSITY_TALK : ZonaGlobalConstants.h
  • CHAT_INTENSITY_WHISPER : ZonaGlobalConstants.h
  • CHAT_INTENSITY_YELL : ZonaGlobalConstants.h

- g -

  • GameCharacter : ZonaClientCharacter.h
  • GameStateCallback : BaseServices.h
  • GROUP_CHAT_CMD_ACCEPT : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_DISBAND : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_INVITE : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_LEAVE : ZonaGlobalConstants.h
  • GROUP_CHAT_CMD_SEND_MSG : ZonaGlobalConstants.h

- h -

  • HOST_URL : ZonaGlobalConstants.h

- i -

  • INI_CONNECTION_SECTION : ZonaGlobalConstants.h
  • INI_FILE_NAME : ZonaGlobalConstants.h

- p -

  • PASSWORD : ZonaGlobalConstants.h
  • PersistableObjectPtrVector : PersistableObject.h

- u -

  • USER_NAME : ZonaGlobalConstants.h

- z -

  • ZAC_INI_FILENAME : ZonaGlobalConstants.h
  • ZONA_ET_DEFAULT : ZonaGlobalConstants.h
  • ZONA_ET_IS_ATTACHED : ZonaGlobalConstants.h
  • ZONA_ET_IS_HIDDEN : ZonaGlobalConstants.h
  • ZONA_ET_IS_USER_ENTITY : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_1 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_2 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_3 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_4 : ZonaGlobalConstants.h
  • ZONA_ET_RESERVED_5 : ZonaGlobalConstants.h
  • ZONA_NAMESPACE_BEGIN : ChatMsg.h
  • ZonaClientEntity : ZonaClientEntity.h, ZonaServices.h
  • ZonaClientGuild : GameGuildCallback.h, GameGuildServiceInterface.h, GuildCallback.h
  • ZonaMessage : PersistableObject.h, ZonaObject.h


Terazona C++ Client API Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
BaseServices | BaseServices
Callback | Base class for all callbacks
ChatCallback | Provides a service to recive chat messages for the sphere
ChatMsg | ChatMsg
EntityCallback | EntityCallback
GameGuildCallback |
GameGuildServiceInterface |
GameStateCallback | GameStateCallback
Guild | Guild
GuildCallback | Provides a service to recive chat messages for the sphere
NamedZonaObject | A ZonaObject with a text name
PersistableObject | PersistableObject
ZonaBaseEntity |
ZonaClientCharacter |
ZonaClientEntity |
ZonaObject | ZonaObject
ZonaServices |
ZonaTimeUtils | ZonaTimeUtils
ZScalarVector |
ZString | ZString
ZVector |
ZWString | ZWString


Terazona C++ Client API Class Index

B
E
Guild
Z
ZonaTimeUtils
BaseServices EntityCallback GuildCallback ZonaBaseEntity ZScalarVector
C
G
N
ZonaClientCharacter ZString
Callback GameGuildCallback NamedZonaObject ZonaClientEntity ZVector
ChatCallback GameGuildServiceInterface
P
ZonaObject ZWString
ChatMsg GameStateCallback PersistableObject ZonaServices


Terazona C++ Client API File List

Here is a list of all files with brief descriptions:
BaseServices.h [code]
Callback.h [code]
ChatCallBack.h [code]
ChatMsg.h [code]
EntityCallback.h [code]
GameGuildCallback.h [code]
GameGuildServiceInterface.h [code]
GameStateCallback.h [code]
Guild.h [code]
GuildCallback.h [code]
NamedZonaObject.h [code]
PersistableObject.h [code]
ZonaBaseEntity.h [code]
ZonaClientCharacter.h [code]
ZonaClientEntity.h [code]
ZonaErrors.h [code]
ZonaGlobalConstants.h [code]
ZonaObject.h [code]
ZonaServices.h [code]
ZonaTimeUtils.h [code]
ZString.h [code]
ZVector.h [code]


Terazona C++ Client API Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • BaseServices
    • ZonaServices
  • Callback
    • ChatCallback
    • EntityCallback
    • GameGuildCallback
    • GameStateCallback
    • GuildCallback
  • ChatMsg
  • GameGuildServiceInterface
  • Guild
  • PersistableObject
    • ZonaObject
      • NamedZonaObject
  • ZonaBaseEntity
    • ZonaClientEntity
      • ZonaClientCharacter
  • ZonaTimeUtils
  • ZString
  • ZVector
    • ZScalarVector
  • ZWString